#opendaylight-netvirt: NetVirt Weekly 01/30/18

Meeting started by shague at 16:02:03 UTC (full logs).

Meeting summary

  1. Roll call and agenda bashing (please #info <your-nick>) (shague, 16:02:16)
  2. Review existing action items (shague, 16:02:17)
    1. https://meetings.opendaylight.org/opendaylight-netvirt/2018/netvirt_weekly_01_23_18/opendaylight-netvirt-netvirt_weekly_01_23_18.2018-01-23-16.01.html (shague, 16:02:25)
    2. skitt (skitt, 16:02:38)
    3. Aswin Suryanarayanan (aswin__, 16:02:52)

  3. [WIP] jamoluhrsen to push a job to use port status and report on results (shague, 16:03:29)
    1. job pas pushed and passing (shague, 16:03:50)
    2. Sridhar Gaddam (sridharg, 16:04:05)
    3. vpickard (vpickard, 16:04:32)
    4. job was merged (shague, 16:04:41)

  4. [DONE] jhershbe check which openstack versions support port status - Pike and later support port-status (shague, 16:04:59)
    1. jamoluhrsen (jamoluhrsen, 16:04:59)

  5. [WIP] jamoluhrsen to use distchanges on SR2 and latest carbon SR3 candidate to see differences between two branches. SR2 is passing tests whereas SR3 fails some. (shague, 16:05:31)
  6. [WIP] jamoluhrsen and shague to try and run dualstack csit in sandbox. Patches are being actively reviewed. possibly add to new tdd-wip test-patch (shague, 16:05:53)
    1. dualstack csit patches are being reviewed (shague, 16:06:27)
    2. csit has failures to be addressed (shague, 16:06:37)
    3. Hanamantagoud (Hanamantagoud, 16:07:20)
    4. kiran mentions most patches are looking good. (shague, 16:07:46)
    5. ACTION: jamoluhrsen to send email for someone from the dev/design side of dualstack to review the csit patch to understand what gaps we might or might not have (jamoluhrsen, 16:10:46)
    6. daya to assign resources to look at csit failures in new dualstack tests (shague, 16:11:10)
    7. need to understand the status of where we are in two router dualstack csit patches (jamoluhrsen, 16:12:28)
    8. ACTION: shague to run gates on current patches (shague, 16:12:35)
    9. ACTION: shague check with jhershbe_ on reviews for those patches (shague, 16:12:55)
    10. aswin__ mentions patches on vpnid in nitrogen (shague, 16:13:42)
    11. drop support in nitrogen (shague, 16:14:58)
    12. ACTION: daya kiran to send current list of duslstack patches to merge (shague, 16:16:01)
    13. https://git.opendaylight.org/gerrit/#/c/59919/ may be abandoned since https://git.opendaylight.org/gerrit/#/c/66973/ removes vpnid dependecny (aswin__, 16:16:06)

  7. [WIP] daya to look into adding csit for acl patches - multicast/broadcast types (shague, 16:16:59)
    1. ACTION: daya to follw up (shague, 16:17:15)
    2. netvirt acl patches are pushed and under review (shague, 16:17:42)

  8. [DONE] shague to verify if the ovs version has changed for [OPNFLWPLUG-974](https://jira.opendaylight.org/browse/OPNFLWPLUG-974) - ovs-vswitchd (Open vSwitch) 2.7.3 been used before and after failures, so doesn't look related to ovs version (shague, 16:18:51)
  9. https://trello.com/c/SCmPOAY6/18-carbon-release-planning - sr3 blocked on netvirt blockers. patches pushed yesterday, need to reevaluate status [tracking sheet](https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=40307633) (shague, 16:19:24)
    1. jamoluhrsen started more jobs in sandbox. (shague, 16:19:50)
    2. ACTION: jamoluhrsen needs to add tcpdump and trace log jobs (shague, 16:20:06)
    3. https://jira.opendaylight.org/browse/NETVIRT-1022 (shague, 16:20:30)
    4. https://jenkins.opendaylight.org/sandbox/job/jamo-netvirt-csit-1node-openstack-ocata-upstream-stateful-carbon/ <-- job to debug carbon sr3 troubles (jamoluhrsen, 16:20:34)
    5. looking like an openflowplugin bug (shague, 16:20:51)
    6. jamoluhrsen, there is a new job to copy sandbox logs to save them (vpickard, 16:20:59)
    7. copy-logs: <job-name>/<job-number> (vpickard, 16:21:05)

  10. https://trello.com/c/BTurOwXh/42-oxygen-release-planning - 1/21/18 Code Freeze - TSC agreed to delay release one week so now 1/28/18 as well as move all dates back one week. A soft code freeze was decided meaning another discussion would take place to decide when to really freeze and pull a stable branch. (shague, 16:23:02)
    1. aaa patches have impact on dates (shague, 16:24:07)
    2. jamoluhrsen, logs will be stored under builder-copy-sandbox-logs.job (vpickard, 16:24:53)
    3. https://git.opendaylight.org/gerrit/#/c/67198/ (shague, 16:29:21)
    4. e/// team (jaya) has some csit tests downstream that are being upstreamed (shague, 16:34:16)

  11. chaingin spec: https://git.opendaylight.org/gerrit/#/c/65948/ (shague, 16:36:04)
    1. ACTION: : daya to add another round of reviews (shague, 16:36:21)
    2. vivek n has comments that should be addressed (shague, 16:36:39)
    3. ACTION: jhershbe_ forward email to the exat review comments in question (shague, 16:38:56)

  12. [OPNFLWPLUG-974](https://jira.opendaylight.org/browse/OPNFLWPLUG-974) - Message deserialization failed...msgType: 36864 oxm_field: 6 experimenterID: null was not found - please verify that all needed deserializers ale loaded correctly - nitrogen and carbon fail. Maybe related to NETVIRT-1069 (shague, 16:39:15)
    1. gobinath will update status soon (shague, 16:40:15)

  13. [jc-metrics](https://git.opendaylight.org/gerrit/#/q/topic:jc-metrics) - used to monitor jobCoordinator (shague, 16:41:18)
  14. genius auto tunnel patches - new patch to fix OOO deployment https://git.opendaylight.org/gerrit/#/c/67674/ (shague, 16:42:23)
    1. downstream testing fails. tunnels do not come up (shague, 16:42:56)

  15. queens csit broken - anyone looking at this? New l2gw csit test cases for updating ports on l2gw with existing connections requires queens (shague, 16:47:54)
    1. gvrangan has pacthes under test to fix queens (shague, 16:48:21)
    2. https://git.opendaylight.org/gerrit/#/c/67411/ (shague, 16:50:38)
    3. (shague, 16:51:06)
    4. https://git.opendaylight.org/gerrit/#/c/67411/ (shague, 16:51:07)
    5. https://jenkins.opendaylight.org/sandbox/job/netvirt-csit-1node-openstack-queens-upstream-stateful-snat-conntrack-oxygen/14/ (shague, 16:51:09)


Meeting ended at 16:53:34 UTC (full logs).

Action items

  1. jamoluhrsen to send email for someone from the dev/design side of dualstack to review the csit patch to understand what gaps we might or might not have
  2. shague to run gates on current patches
  3. shague check with jhershbe_ on reviews for those patches
  4. daya kiran to send current list of duslstack patches to merge
  5. daya to follw up
  6. jamoluhrsen needs to add tcpdump and trace log jobs
  7. : daya to add another round of reviews
  8. jhershbe_ forward email to the exat review comments in question


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to send email for someone from the dev/design side of dualstack to review the csit patch to understand what gaps we might or might not have
    2. jamoluhrsen needs to add tcpdump and trace log jobs
  2. shague
    1. shague to run gates on current patches
    2. shague check with jhershbe_ on reviews for those patches
  3. UNASSIGNED
    1. daya kiran to send current list of duslstack patches to merge
    2. daya to follw up
    3. : daya to add another round of reviews
    4. jhershbe_ forward email to the exat review comments in question


People present (lines said)

  1. shague (48)
  2. jamoluhrsen (8)
  3. vpickard (6)
  4. gvrangan (4)
  5. odl_meetbot (3)
  6. aswin__ (2)
  7. sridharg (1)
  8. skitt (1)
  9. Hanamantagoud (1)


Generated by MeetBot 0.1.4.