#opendaylight-netvirt: NetVirt Weekly 02/06/18

Meeting started by vthapar at 16:00:34 UTC (full logs).

Meeting summary

  1. Roll call and agenda bashing (please #info <your-nick>) (vthapar, 16:01:01)
    1. Vishal (vthapar, 16:01:05)
    2. jamoluhrsen (jamoluhrsen, 16:01:06)
    3. vpickard (vpickard, 16:01:55)
    4. Aswin (aswin__, 16:03:33)

  2. dual stack (vthapar, 16:04:30)
    1. still some failures in new dual stack csit that needs some debugging and fixing (jamoluhrsen, 16:04:40)
    2. Andre Fredette (afredette, 16:05:30)
    3. acl patches in progress, patches will be raised soon (vpickard, 16:07:45)

  3. Carbon SR3 (vthapar, 16:08:08)
    1. was good, but failing again. (vthapar, 16:08:31)

  4. router chaining patches (vthapar, 16:09:06)
    1. daya to follow up on next round of patches. action item pending from last week (vthapar, 16:09:34)

  5. SRIOV hw offload update (vthapar, 16:09:51)
    1. facing issues with netvirt tunnels in TripleO deployment (vthapar, 16:10:22)
    2. all ODL patches are merged (vpickard, 16:10:42)
    3. triple0 with odl master, testing end to end (vpickard, 16:11:25)
    4. vxlan, need to boot 2 vms on different hypervisors to get vxlan tunnel (vpickard, 16:11:44)
    5. Sridhar Gaddam (sridharg, 16:12:52)
    6. moshe gathering debug info to help figure out why no tunnel when spinning up 1 vm on compute node (vpickard, 16:13:52)
    7. vxlan offloading working in manual testing. 2 vms, same network (vpickard, 16:14:46)
    8. vlan testing, dhcp not working. OF rules on controller going to br-ex instead of br-int (vpickard, 16:16:24)
    9. arp responder issues with vlan testing. Needs more testing. Works with static ip (vpickard, 16:16:51)
    10. ACTION: vpickard to send jira for compute node reboot missing host config (vpickard, 16:19:40)
    11. vlan issue may be issue we sometimes see for patch ports missing between br-ex and br-int (vpickard, 16:20:22)

  6. Carbon SR3 (vthapar, 16:24:21)
    1. https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=40307633 tracking sheet (vthapar, 16:24:38)

  7. Nitrogen Release planning (vthapar, 16:26:11)
    1. Deserialization bug [OPNFLWPLUG-974] (vthapar, 16:26:34)
    2. https://git.opendaylight.org/gerrit/#/c/67905/ (vthapar, 16:27:15)
    3. patch needs one more go (vpickard, 16:27:19)

  8. Oxygen Release planning (vthapar, 16:27:43)
    1. dual stack still going on (vthapar, 16:28:00)
    2. delayed by CSIT and other infra issues (vthapar, 16:28:36)
    3. CSIT on Friday looked good, only 1 tempest failure (vpickard, 16:30:26)
    4. https://jenkins.opendaylight.org/releng/user/jluhrsen/my-views/view/netvirt%20csit/job/netvirt-csit-1node-openstack-ocata-upstream-stateful-oxygen/ <-- oxy csit looking ok (jamoluhrsen, 16:30:46)

  9. genius auto tunnel (vthapar, 16:33:22)
    1. Vic pushed a patch (vthapar, 16:33:35)
    2. https://git.opendaylight.org/gerrit/#/c/67674/ (vthapar, 16:33:56)
    3. https://jenkins.opendaylight.org/sandbox/job/netvirt-csit-1node-openstack-ocata-vic-upstream-stateful-oxygen/1/ (vthapar, 16:37:11)
    4. auto tunnel patch failing for Ipv6 CSITs which are flaky, so no need to block the patch on those failures (vthapar, 16:40:11)
    5. jamoluhrsen and vivekanandan agree that auto tunnel can be merged (vthapar, 16:40:33)

  10. L2GW CSIT failures on oxygen (vthapar, 16:40:51)
    1. https://jenkins.opendaylight.org/sandbox/job/netvirt-csit-hwvtep-1node-openstack-queens-vic-upstream-stateful-oxygen/5/ (vpickard, 16:42:01)
    2. https://jenkins.opendaylight.org/sandbox/job/netvirt-csit-hwvtep-1node-openstack-queens-vic-upstream-stateful-oxygen/5/ (vpickard, 16:42:14)
    3. https://logs.opendaylight.org/sandbox/vex-yul-odl-jenkins-2/netvirt-csit-hwvtep-1node-openstack-queens-vic-upstream-stateful-oxygen/5/control_1/stack.log.gz (vthapar, 16:43:40)
    4. ACTION: vivekanandan looking into networking-l2gw plugin.sh issue (vthapar, 16:45:25)

  11. Make conntrack based SNAT the default in netvirt (vthapar, 16:45:43)
    1. https://git.opendaylight.org/gerrit/#/c/67963/ (vthapar, 16:45:51)
    2. make Conntrak based SNAT the default (vthapar, 16:46:16)
    3. need to test with dpdk (vpickard, 16:47:01)

  12. cookies (vthapar, 16:47:37)


Meeting ended at 16:47:44 UTC (full logs).

Action items

  1. vpickard to send jira for compute node reboot missing host config
  2. vivekanandan looking into networking-l2gw plugin.sh issue


Action items, by person

  1. vpickard
    1. vpickard to send jira for compute node reboot missing host config


People present (lines said)

  1. vthapar (33)
  2. vpickard (16)
  3. odl_meetbot (4)
  4. jamoluhrsen (4)
  5. gvrangan (1)
  6. sridharg (1)
  7. skitt (1)
  8. aswin__ (1)
  9. afredette (1)


Generated by MeetBot 0.1.4.