#opendaylight-netvirt: NetVirt Weekly 04/10/18

Meeting started by shague at 15:01:53 UTC (full logs).

Meeting summary

  1. Roll call and agenda bashing (please #info <your-nick>) (shague, 15:02:05)
  2. Review existing action items (shague, 15:02:12)
    1. https://meetings.opendaylight.org/opendaylight-netvirt/2018/netvirt_weekly_04_03_18/opendaylight-netvirt-netvirt_weekly_04_03_18.2018-04-03-15.10.html (shague, 15:02:20)
    2. vpickard (vpickard, 15:02:32)
    3. Sridhar Gaddam (sridharg, 15:03:37)

  3. [WIP] daya_k comment if the vpn snapshot vms can be used for the bgp vpn tests (shague, 15:03:54)
    1. ACTION: [WIP] daya_k comment if the vpn snapshot vms can be used for the bgp vpn tests (shague, 15:04:12)

  4. https://trello.com/c/bot8QzRm/48-fluorine-release-planning (shague, 15:04:26)
    1. main activity is to do the odlparent bump and build the initial autorelease build (shague, 15:06:25)
    2. Fluorine version bump complete by 4/21/18 (shague, 15:07:43)
    3. Fluorine specs completed by 5/7/18 (shague, 15:07:52)
    4. https://git.opendaylight.org/gerrit/#/c/69526/13/docs/specs/l3vpn-robustness.rst (shague, 15:10:01)
    5. add a 30m call to discuss the l3vpn-robustness spec (shague, 15:11:29)
    6. ACTION: daya to work with vivek on setting up a call to discuss spec (shague, 15:12:55)

  5. migrating mdsalutils to datastoreutils: odl-genius-tools [thread](https://lists.opendaylight.org/pipermail/netvirt-dev/2018-April/006632.html) (shague, 15:13:45)
    1. initial patch in genius has been merged (shague, 15:15:06)
    2. old tools are still there (shague, 15:15:17)
    3. faseela is starting to push patches to migrate existing users (shague, 15:15:46)

  6. start adding Issue: NETVIRT-12345 in commit message footers: [example jira](https://jira.opendaylight.org/browse/NETVIRT-1204) (shague, 15:16:20)
  7. Bug processing, cleanup (shague, 15:19:35)
  8. clustering issues (shague, 15:27:37)
    1. skitt mentions managed tx should be fixed first (shague, 15:27:56)
    2. https://jira.opendaylight.org/browse/NETVIRT-996 (shague, 15:28:32)
    3. need to identify devs to work in areas (shague, 15:28:56)
    4. daya mentions faseelak can help (shague, 15:29:24)
    5. ACTION: skitt to add issues to the clustering epic (shague, 15:31:11)
    6. jamoluhrsen (jamoluhrsen, 15:31:33)
    7. ACTION: jamoluhrsen to create two new jobs for fluorine/queens that will run 3node. 1) will run just our normal (non - ha operations) and 2) will only run the suites that do ha stuff (jamoluhrsen, 15:38:16)
    8. ACTION: jamoluhrsen to create lightweight csit jobs (shague, 15:38:56)
    9. daya mentions to start using the diag status to know service status (shague, 15:40:03)
    10. ACTION: jamoluhrsen to look to add the diagstatus stuff to 3node jobs to hopefully be make things more resilient (jamoluhrsen, 15:43:25)
    11. https://jenkins.opendaylight.org/releng/view/controller/job/controller-csit-3node-clustering-all-fluorine/ <-- controller clustering job to see that they have failures (jamoluhrsen, 15:57:52)
    12. https://git.opendaylight.org/gerrit/#/c/70498/ (jamoluhrsen, 16:19:33)
    13. scale in, scale out suites: (jamoluhrsen, 16:21:51)


Meeting ended at 16:33:37 UTC (full logs).

Action items

  1. [WIP] daya_k comment if the vpn snapshot vms can be used for the bgp vpn tests
  2. daya to work with vivek on setting up a call to discuss spec
  3. skitt to add issues to the clustering epic
  4. jamoluhrsen to create two new jobs for fluorine/queens that will run 3node. 1) will run just our normal (non - ha operations) and 2) will only run the suites that do ha stuff
  5. jamoluhrsen to create lightweight csit jobs
  6. jamoluhrsen to look to add the diagstatus stuff to 3node jobs to hopefully be make things more resilient


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to create two new jobs for fluorine/queens that will run 3node. 1) will run just our normal (non - ha operations) and 2) will only run the suites that do ha stuff
    2. jamoluhrsen to create lightweight csit jobs
    3. jamoluhrsen to look to add the diagstatus stuff to 3node jobs to hopefully be make things more resilient
  2. UNASSIGNED
    1. [WIP] daya_k comment if the vpn snapshot vms can be used for the bgp vpn tests
    2. daya to work with vivek on setting up a call to discuss spec
    3. skitt to add issues to the clustering epic


People present (lines said)

  1. shague (30)
  2. jamoluhrsen (9)
  3. odl_meetbot (4)
  4. vpickard (1)
  5. sridharg (1)
  6. faseelak (1)
  7. afredette (1)


Generated by MeetBot 0.1.4.