#opendaylight-netvirt: NetVirt Weekly 05/15/18

Meeting started by shague at 15:02:41 UTC (full logs).

Meeting summary

  1. Roll call and agenda bashing (please #info <your-nick>) (shague, 15:02:58)
    1. Vishal (vthapar, 15:03:03)
    2. vpickard (vpickard, 15:03:06)
    3. skitt (skitt, 15:03:12)
    4. https://meetings.opendaylight.org/opendaylight-netvirt/2018/netvirt_weekly_05_08_18/opendaylight-netvirt-netvirt_weekly_05_08_18.2018-05-08-14.59.html (shague, 15:03:16)
    5. daya_k (daya_k, 15:03:51)

  2. [WIP] shague to identify date, if any, for API freeze related to yang changes (shague, 15:04:31)
    1. Sridhar Gaddam (sridharg, 15:04:37)
    2. Aswin (aswinsuryan, 15:06:43)
    3. use the Fluorine Middle Checkpoint as a soft date for the api freeze, 7/5/18 (shague, 15:11:45)
    4. soft date means that is the target to get the yang changes in, but updates can still go in (shague, 15:12:26)
    5. vthapar mentions it would be good to have code committed for the yang changes earlier than the impl (shague, 15:14:05)
    6. devs should attempt to push yang, pipeline and service type changes earlier (shague, 15:15:47)
    7. use 6/7/18 as the target for these api changes (shague, 15:16:03)

  3. [WIP] vishal to add comments to specs to take yang changes into consideration and update troubleshooting tool (shague, 15:17:21)
    1. ACTION: vthapar and shague to discusss how to update specs for odltools (shague, 15:17:55)
    2. jamoluhrsen update on odltools project proposal (shague, 15:18:38)
    3. ACTION: shague to clarify license issue, start with apache (shague, 15:23:36)

  4. https://trello.com/c/bot8QzRm/48-fluorine-release-planning - csit 5/7/18 - looking good. (shague, 15:23:53)
    1. need to look again into the snat-conntrack failures so the default can be changed (shague, 15:25:26)
    2. daya mentions e/// woudl need some ha issues fixed before switching to snat-conntrack as default (shague, 15:27:38)

  5. specs https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10304# (shague, 15:28:55)
    1. how to ensure pipeline changes are consistent - e.g. need genius reviewers (shague, 15:34:23)
    2. vivekn has been checking the pipeline changes so this area is covered (shague, 15:35:01)
    3. Ariel (aadam, 15:35:24)
    4. the pipeline doc should be updated (shague, 15:36:16)
    5. ACTION: vivekn to request devs to update pipeline.rst (shague, 15:37:45)
    6. vivekn: pipeline.rst needs to have the l3 pipeline included (shague, 15:38:22)
    7. vthapar: in the meantime, devs should push patches to genius with the NWConstants changes (shague, 15:39:09)
    8. https://docs.google.com/presentation/d/15h4ZjPxblI5Pz9VWIYnzfyRcQrXYxA1uUoqJsgA53KM/edit#slide=id.g1c73ae9953_2_0 (shague, 15:41:45)

  6. running upstream csit with dpdk (shague, 15:44:15)
    1. team would like to have dpdk in the deployment (shague, 15:52:21)
    2. need to add the deployment support in csit (shague, 15:52:35)
    3. possibly the snapshot vms will have the dpdk support already (shague, 15:52:48)


Meeting ended at 15:53:13 UTC (full logs).

Action items

  1. vthapar and shague to discusss how to update specs for odltools
  2. shague to clarify license issue, start with apache
  3. vivekn to request devs to update pipeline.rst


Action items, by person

  1. shague
    1. vthapar and shague to discusss how to update specs for odltools
    2. shague to clarify license issue, start with apache
  2. vthapar
    1. vthapar and shague to discusss how to update specs for odltools


People present (lines said)

  1. shague (29)
  2. odl_meetbot (3)
  3. vpickard (1)
  4. vthapar (1)
  5. skitt (1)
  6. daya_k (1)
  7. aswinsuryan (1)
  8. sridharg (1)
  9. aadam (1)


Generated by MeetBot 0.1.4.