#opendaylight-netvirt: NetVirt Weekly 05/29/18

Meeting started by shague at 15:02:16 UTC (full logs).

Meeting summary

  1. Roll call and agenda bashing (please #info <your-nick>) (shague, 15:02:27)
    1. https://meetings.opendaylight.org/opendaylight-netvirt/2018/netvirt_weekly_5_22_2018/opendaylight-netvirt-netvirt_weekly_5_22_2018.2018-05-22-15.01.html (shague, 15:02:38)
    2. skitt (skitt, 15:02:56)

  2. Review existing action items (shague, 15:03:06)
    1. vpickard (vpickard, 15:03:55)
    2. jamoluhrsen (jamoluhrsen, 15:04:30)

  3. [DONE] jamoluhrsen to respond to viveks email about an idea to run tempest.api.network tests one at a time with the extra ROBOT log in karaf.log (shague, 15:04:33)
  4. [DONE] jamoluhrsen to add a gerrit comment about how to simulate mcast query (i.e., how to test router sourced mcast traffic) (shague, 15:05:47)
  5. https://trello.com/c/bot8QzRm/48-fluorine-release-planning - looking good. Next date is the middle checkpoint 7/5/18 - [Release Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10403) - [Fluorine Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10400) (shague, 15:06:07)
  6. specs: [NetVirt Team Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10304#) (shague, 15:06:42)
    1. mtu spec, scope is being reduced (shague, 15:07:37)
    2. igmp spec - viveknarasimhan to review this week (shague, 15:07:47)
    3. qos spec: review still ongoing (shague, 15:08:00)
    4. robustness spec: need a final cleanup then can final review (shague, 15:08:55)

  7. module point of contacts: [thread](https://lists.opendaylight.org/pipermail/netvirt-dev/2018-May/006879.html) (shague, 15:09:26)
    1. add aswin to natservice for snat_conntrack (shague, 15:10:31)
    2. dhcpmanager, kency not involved, add Ankit J (shague, 15:10:57)
    3. remove Kency from dhcpservice (vpickard, 15:10:57)
    4. Ashwin B C (viveknarasimhan, 15:11:32)
    5. jhershbe_ (jhershbe_, 15:11:38)
    6. viveknarasimhan (viveknarasimhan, 15:11:47)
    7. Andre Fredette (afredette, 15:11:49)
    8. add Ankit Jain for dhcp (vpickard, 15:11:56)
    9. daya_k (daya_k, 15:12:05)
    10. Vishal (vthapar, 15:12:07)
    11. move karthikeyan to ipv6 from nat (vpickard, 15:14:21)
    12. remove Ashvin L from ipv6 (vpickard, 15:14:28)
    13. remove kency and add ankit jain for dhcp default owner (daya_k, 15:14:49)

  8. refactored exception checker [example job](https://jenkins.opendaylight.org/releng/view/netvirt-csit/job/netvirt-csit-1node-openstack-queens-upstream-stateful-fluorine/539/) (shague, 15:15:27)
  9. [NETVIRT-1284](https://jira.opendaylight.org/browse/NETVIRT-1284) - elan-dpn-interfaces exception (shague, 15:32:12)
    1. possibly the elan tx patch was the issue (shague, 15:32:22)
    2. revert patch pushed and testing (shague, 15:32:29)

  10. [TSC-101](https://jira.opendaylight.org/browse/TSC-101) [topic](https://git.opendaylight.org/gerrit/#/q/topic:binding-tlc-getkey) - weather item for getKey() changes. That will be next to go in once the multipatch and csit passes. This patch will conflict heavily with everything. The change is simple but it touches most files. (shague, 15:34:05)
    1. we should keep moving forward on patch, merge when csit mutlipatch-build passes (shague, 15:35:26)

  11. Uncaught IAE in SNAT - https://git.opendaylight.org/gerrit/71872 (shague, 15:37:04)
    1. vthapar gw notifications coming in different order (shague, 15:37:35)
    2. viveknarasimhan cornercase with gw delete with interfaces still present should be verified (shague, 15:41:26)
    3. ACTION: viveknarasimhan to review patch (shague, 15:44:00)

  12. karaf warnings and logs (shague, 15:47:31)
    1. viveknarasimhan many logs are there for debugging help (shague, 15:47:45)
    2. viveknarasimhan should cleanup be done at end of cycle (shague, 15:49:14)
    3. shague but should some logs be cleaned now, or moved from error to warn for example (shague, 15:49:47)
    4. ACTION: shague to create jira tracking issue, might already be a jira (shague, 15:52:07)
    5. ACTION: viveknarasimhan and shague to begin working the jira (shague, 15:52:21)
    6. ACTION: shague to create a genius jira also (shague, 15:52:33)

  13. tsc-101 - need mdsal and yangtools patches. then can work on netvirt patches (shague, 15:54:30)
    1. skitt will write patch for netvirt (shague, 15:54:53)

  14. ovs 2.9.x (shague, 15:56:23)
    1. daya_k l3vpn needs ovs 2.9 (shague, 15:57:20)
    2. ACTION: jamoluhrsen remove the version lock in builder and check if the patch is released (shague, 16:00:27)

  15. 3node csit (shague, 16:00:33)
    1. bundle-based resync had a failure so it has not been enabled (shague, 16:01:47)
    2. daya_k will the SND framework help (shague, 16:03:23)
    3. ACTION: jamoluhrsen to check if snd has been enabled (shague, 16:03:32)


Meeting ended at 16:05:16 UTC (full logs).

Action items

  1. viveknarasimhan to review patch
  2. shague to create jira tracking issue, might already be a jira
  3. viveknarasimhan and shague to begin working the jira
  4. shague to create a genius jira also
  5. jamoluhrsen remove the version lock in builder and check if the patch is released
  6. jamoluhrsen to check if snd has been enabled


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen remove the version lock in builder and check if the patch is released
    2. jamoluhrsen to check if snd has been enabled
  2. shague
    1. shague to create jira tracking issue, might already be a jira
    2. viveknarasimhan and shague to begin working the jira
    3. shague to create a genius jira also
  3. viveknarasimhan
    1. viveknarasimhan to review patch
    2. viveknarasimhan and shague to begin working the jira


People present (lines said)

  1. shague (50)
  2. vpickard (8)
  3. odl_meetbot (6)
  4. viveknarasimhan (5)
  5. jamoluhrsen (5)
  6. daya_k (2)
  7. vthapar (1)
  8. afredette (1)
  9. skitt (1)
  10. jhershbe_ (1)


Generated by MeetBot 0.1.4.