#opendaylight-netvirt: NetVirt Weekly 06/05/18

Meeting started by shague at 15:03:20 UTC (full logs).

Meeting summary

  1. Roll call and agenda bashing (please #info <your-nick>) (shague, 15:03:31)
    1. https://meetings.opendaylight.org/opendaylight-netvirt/2018/netvirt_weekly_05_29_18/opendaylight-netvirt-netvirt_weekly_05_29_18.2018-05-29-15.02.html (shague, 15:03:59)
    2. Andre Fredette (afredette, 15:05:16)

  2. [DONE] viveknarasimhan to review patch - [71872 uncaught IAE](https://git.opendaylight.org/gerrit/71872) (shague, 15:05:45)
    1. vpickard (vpickard, 15:05:45)

  3. [DONE] shague to create jira tracking logging cleanup, might already be a jira - [NETVIRT-1299](https://jira.opendaylight.org/browse/NETVIRT-1299) (shague, 15:06:06)
  4. [DONE] shague to create a genius jira also for the logging cleanup - [GENIUS-162](https://jira.opendaylight.org/browse/GENIUS-162) (shague, 15:07:47)
  5. [DONE] jamoluhrsen remove the version lock in builder and check if the patch is released. Need ovs 2.9.x [NETVIRT-1212](https://jira.opendaylight.org/browse/NETVIRT-1212). Upstream patches are not released in packages yet on RDO. (shague, 15:07:59)
    1. waiting on the upstream RDo patch to merge (shague, 15:08:32)

  6. [DONE] jamoluhrsen to check if snd has been enabled. SnD is not enabled (shague, 15:10:38)
    1. jamoluhrsen tried the code, it did not help (shague, 15:11:07)
    2. https://git.opendaylight.org/gerrit/#/c/71598/ <-- patch to check SnD in cluster tests (jamoluhrsen, 15:11:33)
    3. ACTION: jamoluhrsen will look to add the code permanently (shague, 15:11:39)

  7. https://trello.com/c/bot8QzRm/48-fluorine-release-planning - looking good. Next date is the middle checkpoint 7/5/18 - [Release Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10403) - [Fluorine Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10400) (shague, 15:11:56)
  8. [TSC-101](https://jira.opendaylight.org/browse/TSC-101) [topic](https://git.opendaylight.org/gerrit/#/q/topic:binding-tlc-getkey) - weather item for getKey() changes. Merged. Patches need to be rebased to pick up the changes. (shague, 15:12:32)
    1. all patches need to be rebased (shague, 15:13:19)
    2. getAugmenation(), getKey() is not key(), setKey() is now withKey() (shague, 15:13:56)
    3. getAugmentation() -> augmentation(), getKey() -> key(), setKey() -> withKey() (skitt, 15:14:20)
    4. exmple patch: https://git.opendaylight.org/gerrit/#/c/71872/9..10/neutronvpn/impl/src/main/java/org/opendaylight/netvirt/neutronvpn/NeutronvpnUtils.java (shague, 15:14:41)

  9. specs: [NetVirt Team Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10304#) (shague, 15:15:16)
    1. igmp spec still deciding on if it will make fluorine (shague, 15:16:19)

  10. TX leaks - [NETVIRT-1296](https://jira.opendaylight.org/browse/NETVIRT-1295), [NETVIRT-1296](https://jira.opendaylight.org/browse/NETVIRT-1296), [NETVIRT-1089](https://jira.opendaylight.org/browse/NETVIRT-1089), [68980](https://git.opendaylight.org/gerrit/#/c/68980/) (shague, 15:18:35)
    1. skitt managedtx are now enforced in most netvirt modules (shague, 15:20:32)
    2. https://git.opendaylight.org/gerrit/#/c/71772/5/elanmanager/impl/src/main/java/org/opendaylight/netvirt/elan/internal/ElanInstanceManager.java example (shague, 15:21:34)
    3. elanmanager was reverted (shague, 15:22:59)

  11. [Vic] SRIOV port - can't ping neutron router interface (shague, 15:24:03)
    1. https://lists.opendaylight.org/pipermail/netvirt-dev/2018-June/006978.html (shague, 15:24:56)
    2. daya mentions some missing pieces needed to get learned macs and interfaces (shague, 15:26:56)
    3. https://bugzilla.redhat.com/show_bug.cgi?id=1583541 downstream bug (shague, 15:27:22)
    4. vpickard to work offline on a solution (shague, 15:30:38)


Meeting ended at 15:34:33 UTC (full logs).

Action items

  1. jamoluhrsen will look to add the code permanently


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen will look to add the code permanently


People present (lines said)

  1. shague (28)
  2. odl_meetbot (3)
  3. vpickard (1)
  4. skitt (1)
  5. afredette (1)
  6. jamoluhrsen (1)


Generated by MeetBot 0.1.4.