#opendaylight-netvirt: NetVirt Weekly 06/19/18

Meeting started by shague at 15:01:26 UTC (full logs).

Meeting summary

  1. Roll call and agenda bashing (please #info <your-nick>) (shague, 15:01:41)
    1. Vishal (vthapar, 15:01:47)
    2. jamoluhrsen (jamoluhrsen, 15:01:57)
    3. https://meetings.opendaylight.org/opendaylight-netvirt/2018/netvirt_weekly_06_12_18/opendaylight-netvirt-netvirt_weekly_06_12_18.2018-06-12-15.02.html (shague, 15:02:00)
    4. Sridhar (sridharg, 15:02:00)
    5. vorburger (vorburger, 15:02:29)
    6. vpickard (vpickard, 15:03:35)

  2. [WIP] jamoluhrsen continue work on patch for SnD (shague, 15:03:42)
  3. [WIP] skitt: create a jira and subtasks for tracking the fixes for the suggested best practices for handling error cases and exceptions (shague, 15:04:01)
  4. [DONE] shague send copy-logs instructions - [thread](https://lists.opendaylight.org/pipermail/netvirt-dev/2018-June/007030.html) (shague, 15:04:20)
  5. https://trello.com/c/bot8QzRm/48-fluorine-release-planning - looking good. Next date is the middle checkpoint 7/5/18 - [Release Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10403) - [Fluorine Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10400) (shague, 15:04:31)
    1. 1node csit looking good (shague, 15:05:38)
    2. one blocker: https://jira.opendaylight.org/browse/NETVIRT-1307 (shague, 15:06:06)
    3. karthikeyan is working the bug, patches under review (shague, 15:06:34)
    4. aswinsuryan snat-conntrack (shague, 15:07:11)
    5. https://jira.opendaylight.org/browse/NETVIRT-1304 seen (shague, 15:07:27)
    6. https://jira.opendaylight.org/browse/NETVIRT-1040 seen (shague, 15:08:07)
    7. https://jira.opendaylight.org/browse/NETVIRT-1270 also seens (shague, 15:08:58)
    8. need +1 on https://git.opendaylight.org/gerrit/#/c/71872/ (shague, 15:11:29)
    9. aswinsuryan has patches for 1304 and 1270 (shague, 15:11:34)
    10. aswinsuryan mentions new pnf failures are occurring, will looko at after these patches are in (shague, 15:12:30)
    11. after all issues fixed, reevaluate when to switch to snat-conntrack as default (shague, 15:13:20)

  6. clustering hit team - discuss current ideas - [73041 - ds-constrained txs](https://git.opendaylight.org/gerrit/#/c/73041/) (shague, 15:13:54)
    1. tomp: working on clustering deadlock issues (shague, 15:15:43)
    2. skitt: debugging clustering is very difficult (shague, 15:15:59)
    3. Netvirt 1304 - https://git.opendaylight.org/gerrit/#/c/71495/ (aswinsuryan, 15:16:30)
    4. skitt: applications burdened with clustering details (shague, 15:16:32)
    5. vorburger: there is existing logging to include stacktraces for tx's (shague, 15:17:35)
    6. skitt: use managedTx at higher level, already made some changes (shague, 15:18:42)
    7. tomp mentions maybe txchains could be used (shague, 15:19:51)
    8. action skitt to file jiras and subtasks (shague, 15:22:20)
    9. action skitt jamoluhrsen checking extra logging in csit (shague, 15:24:28)
    10. https://git.opendaylight.org/gerrit/#/c/73147/ <-- patch to enable extra logging (jamoluhrsen, 15:25:41)
    11. skitt most are the update of deleted node errors, OLFE, two writeers (shague, 15:25:44)
    12. https://jenkins.opendaylight.org/sandbox/job/jamo-netvirt-csit-3node-openstack-queens-upstream-stateful-oxygen/2/ <-- job jamoluhrsen needs someone to confirm if extra logging is there or not (jamoluhrsen, 15:26:11)
    13. ACTION: skitt jamoluhrsen checking extra logging in csit (shague, 15:36:14)
    14. ACTION: skitt to file jiras and subtasks (shague, 15:36:22)
    15. tomp mentioned akka version has been updated (shague, 15:40:22)
    16. need to find a time to have regular clustering call (shague, 15:44:32)
    17. ACTION: jamoluhrsen to drive working on the controller jobs (shague, 15:46:10)
    18. daya_k: mentions https://jenkins.opendaylight.org/releng/view/openflowplugin/job/openflowplugin-csit-3node-clustering-bulkomatic-only-oxygen/ (shague, 15:46:49)
    19. ofp would be next after controller jobs (shague, 15:47:02)
    20. https://jenkins.opendaylight.org/releng/view/controller/job/controller-csit-3node-rest-clust-cars-perf-only-fluorine/120/robot/ <-- cars and people (jamoluhrsen, 15:48:22)
    21. https://git.opendaylight.org/gerrit/#/c/72871/ (vorburger, 15:48:48)
    22. ACTION: daya_k check with team about 72871 - why is this patch being done? (shague, 15:58:06)
    23. is there a real need to separate txs as in the patch (shague, 15:58:37)


Meeting ended at 16:07:34 UTC (full logs).

Action items

  1. skitt jamoluhrsen checking extra logging in csit
  2. skitt to file jiras and subtasks
  3. jamoluhrsen to drive working on the controller jobs
  4. daya_k check with team about 72871 - why is this patch being done?


Action items, by person

  1. jamoluhrsen
    1. skitt jamoluhrsen checking extra logging in csit
    2. jamoluhrsen to drive working on the controller jobs
  2. skitt
    1. skitt jamoluhrsen checking extra logging in csit
    2. skitt to file jiras and subtasks


People present (lines said)

  1. shague (39)
  2. jamoluhrsen (9)
  3. vorburger (3)
  4. odl_meetbot (3)
  5. aswinsuryan (2)
  6. vpickard (1)
  7. sridharg (1)
  8. skitt (1)
  9. vthapar (1)


Generated by MeetBot 0.1.4.