#opendaylight-netvirt: NetVirt Weekly 06/26/18

Meeting started by shague at 15:02:43 UTC (full logs).

Meeting summary

  1. Roll call and agenda bashing (please #info <your-nick>) (shague, 15:02:50)
    1. https://meetings.opendaylight.org/opendaylight-netvirt/2018/netvirt_weekly_06_19_18/opendaylight-netvirt-netvirt_weekly_06_19_18.2018-06-19-15.01.html (shague, 15:03:09)
    2. Vishal (vthapar, 15:03:15)
    3. jhershbe (jhershbe, 15:03:34)
    4. Sridhar Gaddam (sridharg, 15:03:36)

  2. [DONE] skitt jamoluhrsen checking extra logging in csit - transaction-debug-context-enabled=true in HA jobs [73147](https://git.opendaylight.org/gerrit/#/c/73147/) (shague, 15:03:54)
  3. [DONE] skitt to file jiras and subtasks - [NETVIRT-1318](https://jira.opendaylight.org/browse/NETVIRT-1318) (shague, 15:04:12)
    1. need to add genius tasks also (shague, 15:04:28)

  4. [DONE] jamoluhrsen to drive working on the controller jobs - [NETVIT-1315](https://jira.opendaylight.org/browse/NETVIRT-1315) (shague, 15:04:45)
  5. [WIP] daya_k check with team about (72871)[https://git.opendaylight.org/gerrit/#/c/72871/] - why is this patch being done? (shague, 15:05:04)
    1. daya_k atomicity is wanted so tx chaining is being used (shague, 15:05:49)
    2. tomp mentions you will lose atomicity (shague, 15:07:06)
    3. daya_k says tx chaining will be used (shague, 15:07:24)
    4. manu asks for suggestions on which tx chain api to use, e.g. ping-pong broker, etc (shague, 15:08:12)
    5. skitt need to add rollback handler (shague, 15:10:25)

  6. https://trello.com/c/bot8QzRm/48-fluorine-release-planning - looking good. Next date is the middle checkpoint 7/5/18 - [Release Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10403) - [Fluorine Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10400) (shague, 15:10:34)
    1. specs to be complete by mid checkpoint (shague, 15:11:24)
    2. daya_k asks about ovs 2.9.2 (shague, 15:13:11)
    3. ACTION: jamoluhrsen work with therbert to get rpm (shague, 15:13:50)

  7. skitt: [NETVIRT-1318](https://jira.opendaylight.org/browse/NETVIRT-1318) - MDSAL Best Practices (shague, 15:14:17)
    1. https://git.opendaylight.org/gerrit/#/c/73440/ (shague, 15:15:28)
    2. skitt reviewing https://git.opendaylight.org/gerrit/#/c/73440/ (shague, 15:15:38)
    3. tx's can now be constrained (shague, 15:16:16)
    4. what deadline should be set to finish NETVIT-1318? (shague, 15:33:06)
    5. deadline set for next week project meeting, 7/3/18 (shague, 15:34:10)
    6. want these patches in so current feature and spec work can be rebased on the patches (shague, 15:34:36)
    7. daya_k: should reads have automatic retries? (shague, 15:37:42)
    8. skitt: new managed runner is rerunning the code, not the operation (shague, 15:38:47)
    9. skitt: so reads should be merged with rw tx's (shague, 15:39:25)
    10. daya_k: caches being used in between operations could complicate skitt's plan (shague, 15:40:32)
    11. : kiran: thinks it should be possible (shague, 15:40:48)
    12. faseelak (faseelak, 15:43:04)

  8. cluster reboots, mdsal rebuilds db (shague, 15:43:54)
    1. daya_k: how is this done? is it per shard or across all ? (shague, 15:44:22)
    2. daya_k: block listener registrations until all is ready (shague, 15:46:23)
    3. jhershbe: the controller code is not the right place to do this (shague, 15:46:47)
    4. : jhershbe: better would be to make code reentrant (shague, 15:47:09)
    5. jhershbe: add tests to find these conditions (shague, 15:47:38)
    6. faseelak: tomp says bundles will only come up after elections are done (shague, 15:48:41)
    7. daya_k: has doubts, boron tests still have issues (shague, 15:49:15)
    8. daya_K if tom's statement is right, then problem could be solved. But need to verify with tests. (shague, 15:51:03)

  9. rollback tx's (shague, 15:53:02)
    1. kiran: asks for suggestions (shague, 15:53:10)
    2. check in next call when experts are there (shague, 15:53:19)

  10. jluhrsen: [NETVIRT-1315](https://jira.opendaylight.org/browse/NETVIRT-1315) - Troubleshooting Controller CSIT (shague, 15:54:29)
    1. https://jira.opendaylight.org/browse/CONTROLLER-1838 (shague, 15:55:00)
    2. https://jenkins.opendaylight.org/releng/user/jluhrsen/my-views/view/controller%203node/job/controller-csit-3node-clustering-all-oxygen (shague, 15:57:16)
    3. that job is the high-priority job that we need to get 100% passing (shague, 15:57:47)
    4. vpickard and jamoluhrsen looking at job now (shague, 15:58:08)


Meeting ended at 16:03:09 UTC (full logs).

Action items

  1. jamoluhrsen work with therbert to get rpm


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen work with therbert to get rpm


People present (lines said)

  1. shague (47)
  2. odl_meetbot (3)
  3. vthapar (1)
  4. sridharg (1)
  5. jhershbe (1)
  6. odp-gerritbot (1)
  7. faseelak (1)
  8. jamoluhrsen (1)


Generated by MeetBot 0.1.4.