#opendaylight-netvirt: NetVirt Weekly 07/03/18

Meeting started by shague at 15:01:11 UTC (full logs).

Meeting summary

  1. Roll call and agenda bashing (please #info <your-nick>) (shague, 15:01:20)
    1. Hanamantagoud (Hanamantagoud, 15:01:34)

  2. Review existing action items (shague, 15:02:12)
    1. https://meetings.opendaylight.org/opendaylight-netvirt/2018/netvirt_weekly_06_26_18/opendaylight-netvirt-netvirt_weekly_06_26_18.2018-06-26-15.02.html (shague, 15:04:25)

  3. [WIP] jamoluhrsen work with therbert to get ovs rpm to sideload in upstream csit (shague, 15:04:36)
  4. https://trello.com/c/bot8QzRm/48-fluorine-release-planning - looking good. Next date is the middle checkpoint 7/5/18 - [Release Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10403) - [Fluorine Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10400) (shague, 15:05:30)
  5. Middle checkpoint - 4 weeks before code freeze (shague, 15:07:11)
    1. robustness spec: kiran: vivekn wants to update spec one more time (shague, 15:08:04)
    2. kiran will push more reviews (shague, 15:08:14)
    3. ACTION: kiran to check with vivekn on spec and patches (shague, 15:08:38)
    4. vpickard igmp snooping likely push out to neon (shague, 15:09:11)
    5. ACTION: : shague: to followup with spec owners for remaining impl patches (shague, 15:11:59)

  6. https://trello.com/c/BTurOwXh/42-oxygen-release-planning - Oxygen SR3: 08/07/18: Cherry-pick bug fixes (shague, 15:13:24)
  7. jira: Severity field removed, use only priority, highest indicates blocker (shague, 15:16:18)
  8. QoS spec (shague, 15:20:15)
    1. https://git.opendaylight.org/gerrit/#/c/71820/ (shague, 15:20:17)
    2. need final review from Arun Sharma (shague, 15:20:31)
    3. daya: driver issues? (shague, 15:20:47)
    4. vthapar: should be OK as driver is good (shague, 15:21:05)
    5. vthapar: need Rajesh's n-odl patch to be merged to continue testing (shague, 15:21:33)

  9. ovsdb patches (shague, 15:23:31)
    1. looks like patch is causing failures, need to debug (shague, 15:24:29)
    2. https://git.opendaylight.org/gerrit/#/c/73348/ (shague, 15:24:38)
    3. https://git.opendaylight.org/gerrit/71303 (shague, 15:25:55)
    4. vthapar: reparent https://git.opendaylight.org/gerrit/#/c/73348/ on https://git.opendaylight.org/gerrit/71303 (shague, 15:26:49)

  10. tempest broken out from csit (shague, 15:29:02)
  11. skitt: [NETVIRT-1318](https://jira.opendaylight.org/browse/NETVIRT-1318) - MDSAL Best Practices (shague, 15:31:41)
    1. patches for constrained tx patches wip (shague, 15:34:39)
    2. faseelak: what to do with reads on operational (shague, 15:35:31)
    3. skitt: should be able to add a new transaction (shague, 15:35:47)
    4. skitt: there are additional different types of transactions that need to be fixed next (shague, 15:36:40)
    5. skitt finish constraned tx's then look at next cases (shague, 15:37:25)
    6. Better transaction debugging: https://git.opendaylight.org/gerrit/62224 (skitt, 15:38:54)
    7. skitt: better logging and troubleshooting (shague, 15:38:59)
    8. skitt genius mdsal api changes are merged, can remove tx adapter code now (shague, 15:40:31)
    9. daya: problems that need retries on read's (shague, 15:41:13)
    10. skitt: retryManagedTxRunner onyl retries on OLFE's currently, needs more exceptions (shague, 15:42:09)
    11. ACTION: daya to send list of exceptions to genius list (shague, 15:42:34)
    12. daya: during cluster reboot, 600ms window where all tx's (r and w) will fail (shague, 15:43:43)
    13. daya: everything comes up, then a reelection looks to be happening (shague, 15:46:29)
    14. work with Jamo on adding SND in csit (shague, 15:49:46)
    15. vthapar different use for SND to add app hooks (shague, 15:50:10)

  12. Port the constrained-datastore patches to Oxygen? Other clustering fixes? (shague, 15:53:01)
    1. skitt: wait until we see benefits on flourine csit before backporting to oxygen (shague, 15:54:07)

  13. jluhrsen: [NETVIRT-1315](https://jira.opendaylight.org/browse/NETVIRT-1315) - Troubleshooting Controller CSIT (shague, 15:57:34)
    1. https://shipilev.net/blog/2014/exceptional-performance/#_conclusion (rovarga, 16:00:08)
    2. https://zoom.us/j/664690256 (vpickard, 16:01:01)


Meeting ended at 16:01:23 UTC (full logs).

Action items

  1. kiran to check with vivekn on spec and patches
  2. : shague: to followup with spec owners for remaining impl patches
  3. daya to send list of exceptions to genius list


Action items, by person

  1. shague
    1. : shague: to followup with spec owners for remaining impl patches
  2. UNASSIGNED
    1. kiran to check with vivekn on spec and patches
    2. daya to send list of exceptions to genius list


People present (lines said)

  1. shague (45)
  2. rovarga (7)
  3. odp-gerritbot (7)
  4. skitt (5)
  5. odl_meetbot (3)
  6. vorburger (2)
  7. vpickard (1)
  8. Hanamantagoud (1)


Generated by MeetBot 0.1.4.