#opendaylight-netvirt: NetVirt Weekly 07/10/18

Meeting started by shague at 15:01:30 UTC (full logs).

Meeting summary

  1. Roll call and agenda bashing (please #info <your-nick>) (shague, 15:01:38)
    1. https://meetings.opendaylight.org/opendaylight-netvirt/2018/netvirt_weekly_07_03_18/opendaylight-netvirt-netvirt_weekly_07_03_18.2018-07-03-15.01.html (shague, 15:01:55)
    2. jamoluhrsen (jamoluhrsen, 15:01:57)
    3. Vishal (vthapar, 15:02:35)
    4. Sridhar Gaddam (sridharg, 15:03:26)
    5. vpickard (vpickard, 15:04:28)

  2. [WIP] kiran to check with vivekn on spec and patches - [NETVIRT-1204 - robustness spec](https://jira.opendaylight.org/browse/NETVIRT-1204) (shague, 15:05:08)
    1. kiran spec updates will come in this week (shague, 15:05:54)
    2. kiran will work to finish as many items as possible before 8/718 (shague, 15:06:14)

  3. [DONE] shague: to followup with spec owners for remaining impl patches - [thread](https://lists.opendaylight.org/pipermail/netvirt-dev/2018-July/007230.html) (shague, 15:06:29)
  4. [WIP] daya to send list of exceptions during cluster reboots to genius list (shague, 15:11:36)
    1. daya issues have been triaged, now working on how to fix (shague, 15:12:14)

  5. https://trello.com/c/bot8QzRm/48-fluorine-release-planning - Code Feeze: 8/7/18 - [Release Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10403) - [Fluorine Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10400) (shague, 15:12:55)
  6. https://trello.com/c/BTurOwXh/42-oxygen-release-planning - Oxygen SR3: 08/07/18: Cherry-pick bug fixes (shague, 15:13:29)
  7. [OPNFLWPLUG-1023](https://jira.opendaylight.org/browse/OPNFLWPLUG-1023) - failures with ovs 2.8.x and 2.9.x (shague, 15:14:59)
    1. [TSC-114](https://jira.opendaylight.org/browse/TSC-114) - Support OVS 2.9 NSH implementation, drop OVS 2.6 out-of-branch NSH support. (shague, 15:16:29)
    2. spec is reviewed (shague, 15:16:40)

  8. [OPNFLOWPLUG-1007](https://jira.opendaylight.org/browse/OPNFLWPLUG-1007) - Future (eventually) failed: addFlow -and- transmitPacket - two parts: lldp features causing issues and clustering problems. Also mention of setting inactivity-probe higher to 30s. (shague, 15:20:03)
    1. change inactivity_probe from 5s to 30s (shague, 15:22:15)
    2. theory: during up/down odl transitions, 5s is not long enough (shague, 15:24:53)
    3. daya: gobinath have moved echo/response logic down lower (shague, 15:25:32)
    4. ACTION: daya: to check if the patches can be upstreamed to openflowplugin (shague, 15:26:39)
    5. daya jfr could add value to profile java stats (shague, 15:31:14)
    6. should we add the tool to csit? (shague, 15:31:22)
    7. ACTION: faseelak to pass along downstream jfr script (shague, 15:32:50)
    8. for the lldp feature reduction, anil will see if we can use the existing features or a new one (shague, 15:38:59)

  9. run snat-conntrack csit along with basic upstream csit. We need to transition to snat-conntrack as the default so tests need to pass. (shague, 15:39:22)
    1. jamoluhrsen should we just add snat-conntrack to the test-netvirt-current trigger? (shague, 15:41:33)
    2. whitelist should be updated for the existing snat-conntrack job (shague, 15:42:02)
    3. ACTION: jamoluhrsen and shague to look at updating the test-netvirt-current (shague, 15:46:03)

  10. [single shard patch for 3node 72955](https://git.opendaylight.org/gerrit/#/c/72955/) - merged - shague to add patch for 1node (shague, 15:46:09)
    1. ACTION: shague to push a patch to update the 1node also (shague, 15:46:40)

  11. jluhrsen: [NETVIRT-1315](https://jira.opendaylight.org/browse/NETVIRT-1315) - Troubleshooting Controller CSIT (shague, 15:47:16)
    1. vpickard found new bug: https://jira.opendaylight.org/browse/MDSAL-362 (shague, 15:48:57)
    2. https://jira.opendaylight.org/browse/MDSAL-362 (shague, 15:49:09)
    3. vthapar openflowplugin uses ClusteredSingleton (shague, 15:56:23)
    4. jira vpickard filed is in a bgpcep CSIT and not netvirt (shague, 15:57:12)
    5. vpickard only looked at one netvirt csit so far and it did not have the error signature, need to look at more jobs to see if the issue does happen (shague, 15:59:17)


Meeting ended at 16:01:42 UTC (full logs).

Action items

  1. daya: to check if the patches can be upstreamed to openflowplugin
  2. faseelak to pass along downstream jfr script
  3. jamoluhrsen and shague to look at updating the test-netvirt-current
  4. shague to push a patch to update the 1node also


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen and shague to look at updating the test-netvirt-current
  2. shague
    1. jamoluhrsen and shague to look at updating the test-netvirt-current
    2. shague to push a patch to update the 1node also
  3. UNASSIGNED
    1. daya: to check if the patches can be upstreamed to openflowplugin
    2. faseelak to pass along downstream jfr script


People present (lines said)

  1. shague (38)
  2. odl_meetbot (3)
  3. jamoluhrsen (2)
  4. vpickard (1)
  5. vthapar (1)
  6. sridharg (1)
  7. odp-gerritbot (1)
  8. zychen (1)


Generated by MeetBot 0.1.4.