#opendaylight-netvirt: NetVirt Weekly 07/17/18

Meeting started by shague at 15:02:26 UTC (full logs).

Meeting summary

  1. Roll call and agenda bashing (please #info <your-nick>) (shague, 15:02:33)
    1. https://meetings.opendaylight.org/opendaylight-netvirt/2018/netvirt_weekly_07_10_18/opendaylight-netvirt-netvirt_weekly_07_10_18.2018-07-10-15.01.html (shague, 15:02:48)

  2. Review existing action items (shague, 15:03:35)
    1. VIshal (vthapar, 15:04:15)
    2. josh (jhershbe, 15:04:41)
    3. Aswin S (aswins, 15:04:47)
    4. jamoluhrsen (jamoluhrsen, 15:04:58)

  3. [DONE] daya: to check if the patches can be upstreamed to openflowplugin - patches from gobinath that move echo/response logic down lower (shague, 15:05:20)
    1. ofp code is already upstreamed (shague, 15:07:40)
    2. do we want similar for ovsdb (shague, 15:07:51)
    3. HELP: need someone to work on the doing the same in ovsdb (shague, 15:09:03)
    4. ACTION: vthapar to look into priority if this is reproducible (shague, 15:09:34)

  4. [WIP] faseelak to pass along downstream jfr script (shague, 15:11:18)
    1. jfr will be free in an upcoming openjdk, so maybe we can wait till then (shague, 15:12:39)
    2. faseelak mentions yourkit can be used in it's place (shague, 15:13:14)
    3. need to look into if it can be used (shague, 15:13:29)
    4. faseelak jstack might be enough (shague, 15:14:33)
    5. faseelak either tool should only be ran for small durations (shague, 15:15:14)

  5. [WIP] jamoluhrsen and shague to look at updating the test-netvirt-current (shague, 15:17:30)
    1. https://git.opendaylight.org/gerrit/#/c/74129/ added snat-conntrack to patch tests (jamoluhrsen, 15:17:38)

  6. [DONE] shague to push a patch to update the 1node also to use [72955](https://git.opendaylight.org/gerrit/#/c/72955/) - [73956](https://git.opendaylight.org/gerrit/#/c/73956/) (shague, 15:18:06)
  7. https://trello.com/c/bot8QzRm/48-fluorine-release-planning - Code Feeze: 8/7/18 - [Release Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10403) - [Fluorine Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10400) - [NetVirt Team Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10304) (shague, 15:18:32)
    1. ACTION: daya to look into csits for new features (shague, 15:22:12)

  8. https://trello.com/c/BTurOwXh/42-oxygen-release-planning - Oxygen SR3: 08/07/18: Cherry-pick bug fixes (shague, 15:23:55)
  9. Ordering issues between group_mod and flow_mod https://git.opendaylight.org/gerrit/#/c/74029/ OFPlugin Bug ->https://jira.opendaylight.org/browse/OPNFLWPLUG-991 (shague, 15:24:17)
    1. aswins flows fail to install when required groups are not present (shague, 15:25:01)
    2. aswins ofp has a bug to ensure groups are present before flows are programmed (shague, 15:25:34)
    3. aswins other solution is to read config for group before programming flow (shague, 15:26:10)
    4. daya group caching code will ensure group is added before flow is programmed (shague, 15:27:21)
    5. need to know if the code is upstreamed (shague, 15:27:39)
    6. ACTION: daya to check code status with Gobinath (shague, 15:28:14)
    7. aswin to rework patch to use ofp feature, but the patch can still go in independently (shague, 15:31:26)

  10. [74025](https://git.opendaylight.org/gerrit/74025) - csit jobs renamed to this format: netvirt-csit-1node-0cmb-1ctl-2cmp-openstack-queens-upstream-stateful-fluorine - [thread](https://lists.opendaylight.org/pipermail/netvirt-dev/2018-July/007264.html) (shague, 15:32:29)
  11. clustering tools - [NETVIRT-1002](https://jira.opendaylight.org/browse/NETVIRT-1002) (shague, 15:36:04)
    1. monitor tool needs to be adapted to run via cli and capture output to log (shague, 15:37:32)
    2. ACTION: skitt remove original monitor tool from int/test (shague, 15:38:27)
    3. tomp request to not append karaf logs when nodes restarted (shague, 15:38:57)
    4. https://jira.opendaylight.org/browse/OPNFLWPLUG-991 (aswins, 15:40:37)
    5. jhershbe request to log all admin commands in karaf (shague, 15:42:04)
    6. jhershbe at least for drastic admin commands like restartign nodes (shague, 15:45:55)
    7. request to break log into test#.log chunks (shague, 15:46:57)
    8. https://jira.opendaylight.org/projects/ODLTOOLS/issues/ODLTOOLS-13?filter=allopenissues (shague, 15:50:07)
    9. add jiras to odltools for new features (shague, 15:50:35)

  12. clustering issue with vlan tests (shague, 15:51:48)
    1. https://jenkins.opendaylight.org/sandbox/job/faseela-l2-netvirt-csit-3node-openstack-queens-upstream-stateful-fluorine/ (faseelak, 15:51:59)
    2. faseelak running l2 suite (shague, 15:52:05)
    3. faseelak mentions seeing missing vm dhcp ips due to different reasons (shague, 15:53:36)
    4. aswins menations the table 43 case, but that is just one reason (shague, 15:53:59)
    5. faseelak only happens with the vlan provider (shague, 15:54:19)
    6. faseelak other vlan issues have been fixed (shague, 15:57:32)
    7. faseelak_ arun mentions maybe role status changes are involved (shague, 16:00:29)


Meeting ended at 16:02:45 UTC (full logs).

Action items

  1. vthapar to look into priority if this is reproducible
  2. daya to look into csits for new features
  3. daya to check code status with Gobinath
  4. skitt remove original monitor tool from int/test


Action items, by person

  1. skitt
    1. skitt remove original monitor tool from int/test
  2. vthapar
    1. vthapar to look into priority if this is reproducible
  3. UNASSIGNED
    1. daya to look into csits for new features
    2. daya to check code status with Gobinath


People present (lines said)

  1. shague (47)
  2. jamoluhrsen (4)
  3. odl_meetbot (3)
  4. skitt (3)
  5. jhershbe (2)
  6. faseelak (2)
  7. aswins (2)
  8. vthapar (1)


Generated by MeetBot 0.1.4.