#opendaylight-netvirt: NetVirt Weekly 07/24/18

Meeting started by shague at 15:01:49 UTC (full logs).

Meeting summary

  1. Roll call and agenda bashing (please #info <your-nick>) (shague, 15:01:57)
    1. Vishal (vthapar, 15:02:39)
    2. https://meetings.opendaylight.org/opendaylight-netvirt/2018/netvirt_weekly_07_17_18/opendaylight-netvirt-netvirt_weekly_07_17_18.2018-07-17-15.02.html (shague, 15:03:00)

  2. Review existing action items (shague, 15:03:56)
  3. [WIP] vthapar to look into priority if this is reproducible - should ovsdb add similar lower layer hooks for echo request and response handling as ofp implemented. (shague, 15:04:37)
    1. vthapar still looking (shague, 15:04:59)

  4. [WIP] daya to look into csits for new features (shague, 15:05:14)
    1. daya still checking (shague, 15:06:11)

  5. [DONE] daya to check code status with Gobinath for ofp code that ensures groups are programmed before flows using those groups - [73531](https://git.opendaylight.org/gerrit/#/c/73531/) (shague, 15:06:28)
    1. patch is pushed, gates passed (shague, 15:07:49)
    2. discussion on how to verify the patch, since netvirt has code to workaround the issue (shague, 15:10:04)
    3. can a marker log be included on the patch to show when the condition hits (shague, 15:10:31)

  6. [DONE] skitt remove original monitor tool from int/test - [74132](https://git.opendaylight.org/gerrit/#/c/74132/) (shague, 15:10:49)
  7. https://trello.com/c/bot8QzRm/48-fluorine-release-planning - Code Feeze: 8/7/18 - [Release Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10403) - [Fluorine Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10400) - [NetVirt Team Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10304) - [fluorine patches](https://git.opendaylight.org/gerrit/#/q/project: (shague, 15:11:03)
    1. some tx patches not in yet, fibmanager and elanmanager, failing some csit's (shague, 15:16:36)
    2. may not make it by 8/7/18 (shague, 15:18:17)
    3. skitt to possibly enable the checker restriction for modules that have the changes already (shague, 15:18:39)

  8. https://trello.com/c/BTurOwXh/42-oxygen-release-planning - Oxygen SR3: 08/07/18: Cherry-pick bug fixes - [oxygen patches](https://git.opendaylight.org/gerrit/#/q/project:netvirt+status:open+branch:stable/oxygen) (shague, 15:20:00)
  9. OVS 2.9.2 and kernel modules (shague, 15:23:14)
    1. will still need kernel modules evne if we have the userspace ovs 2.9.2 packages (shague, 15:26:16)
    2. venkat working on building ovs (shague, 15:28:25)

  10. daya: ovsdb design around transaction chains and event queues - [thread](https://lists.opendaylight.org/pipermail/netvirt-dev/2018-July/007280.html) (shague, 15:28:45)
    1. daya downstream investigations finding performance issues in ovsdb southbound (shague, 15:29:42)
    2. three main issues found: (shague, 15:30:24)
    3. 1. Single queue mechanism for both config and event processing (shague, 15:30:42)
    4. 2. Use of a single long running transaction chain causing huge heap allocations (shague, 15:30:51)
    5. 3. Full serialization via the single queue, vs using node id based serialization (shague, 15:31:00)
    6. muthu mentioned same design is used in ofp (shague, 15:31:41)
    7. leads to large and long gc latencies (shague, 15:32:22)
    8. muthu - but ofp does not see the same problems (shague, 15:33:28)
    9. single queue backing up because of initial node reads (shague, 15:38:10)
    10. vthapar: could use a cache for the node data (shague, 15:38:29)
    11. daya: use cluster listeners to help (shague, 15:38:53)
    12. clarify single queue - currently there is a dual queue, but single queue could help (shague, 15:41:18)
    13. vthapar seperate queues per switch and optimize per odl node (shague, 15:43:57)
    14. desire to get this into Fluorine sr1 (shague, 15:48:55)
    15. need to get started on this if we want it in (shague, 15:49:21)
    16. ACTION: daya to look into scheduling fixes (shague, 15:53:22)

  11. clustering (shague, 15:53:39)
    1. jamoluhrsen received some akka debugging instructions from akka team (shague, 15:54:02)
    2. vpickard thought he found a new bug. after multiple restarts bundles fail to start (shague, 15:54:44)
    3. seed node could not rejoin cluster, causes blueprint to fail (shague, 15:55:07)
    4. tomp thinks it is an akka bug (shague, 15:57:47)
    5. jamoluhrsen is collecting debug to send to akka (shague, 15:58:13)


Meeting ended at 16:00:38 UTC (full logs).

Action items

  1. daya to look into scheduling fixes


People present (lines said)

  1. shague (50)
  2. odl_meetbot (5)
  3. vthapar (1)


Generated by MeetBot 0.1.4.