#opendaylight-netvirt: NetVirt Weekly 07/31/18

Meeting started by shague at 15:01:37 UTC (full logs).

Meeting summary

    1. jamoluhrsen (jamoluhrsen, 15:01:46)

  1. Roll call and agenda bashing (please #info <your-nick>) (shague, 15:01:47)
    1. Vishal (vthapar, 15:01:49)
    2. https://meetings.opendaylight.org/opendaylight-netvirt/2018/netvirt_weekly_07_24_18/opendaylight-netvirt-netvirt_weekly_07_24_18.2018-07-24-15.01.html (shague, 15:02:03)
    3. faseelak (faseelak, 15:04:25)

  2. [WIP] daya to look into scheduling fixes for ovsdb design around transaction chains and event queues (shague, 15:06:17)
    1. daya more observations are being found (shague, 15:06:34)
    2. daya more debugging underway (shague, 15:06:49)
    3. daya sill looking, as issues pop up will look to push patches (shague, 15:07:49)
    4. action daya suneelu to create jira to track issues (shague, 15:08:13)
    5. Sridhar Gaddam (sridharg, 15:09:49)
    6. chetan has a few nat patches to push (shague, 15:09:57)

  3. https://trello.com/c/BTurOwXh/42-oxygen-release-planning - Oxygen SR3: 08/07/18: Cherry-pick bug fixes - [oxygen patches](https://git.opendaylight.org/gerrit/#/q/project:netvirt+status:open+branch:stable/oxygen) (shague, 15:10:36)
  4. Enforce constrained tx's in some modules? If so, how to enable selectively for those modules that have been converted to constrained? (shague, 15:14:27)
    1. skitt there is an issue in checkstyle patch itself: https://git.opendaylight.org/gerrit/#/c/73686/ (shague, 15:15:48)
    2. vorburger: https://jira.opendaylight.org/browse/GENIUS-176 - need to keep working on jira (shague, 15:19:36)
    3. faseelak looking to find owners for the genius jira's (shague, 15:20:27)
    4. vorburger we need this jira in to enforce the managed transactions (shague, 15:21:21)

  5. [OPNFLWPLUG-991](https://jira.opendaylight.org/browse/OPNFLWPLUG-991) : FRM: Flow Group Dependency support - [73531](https://git.opendaylight.org/gerrit/73531) (shague, 15:23:07)
    1. daya downstream sees the failure in restart tests (shague, 15:25:31)
    2. how can we verify the bug (shague, 15:25:39)
    3. vthapar should add a log when the ordering issue is hit (shague, 15:26:48)
    4. vthapar need help from ofp team to create test case that takes down node that is owner (shague, 15:28:14)
    5. aswins snat-conntrack would hit the issue more often (shague, 15:28:59)
    6. https://jenkins.opendaylight.org/releng/job/netvirt-csit-1node-0cmb-1ctl-2cmp-openstack-queens-upstream-stateful-snat-conntrack-fluorine/9/robot/ (aswins, 15:28:59)
    7. aswins revert the patch to help increase likelikhood of hitting issue (shague, 15:30:05)

  6. vorburger: Neutron SPEC dependency checks - [google doc](https://docs.google.com/document/d/1NrN9r_3O1yJKyS2o_MapurNqvUwyPxJANSfvAOvkXUg/edit) (shague, 15:30:21)
    1. vorburger neutron blindly returns 200 ok to neutron requests (shague, 15:31:10)
    2. no checks if the resources are actually created (shague, 15:31:23)
    3. HELP: vorburger looking for help and input on creating spec for the feature (shague, 15:32:30)
    4. https://jenkins.opendaylight.org/releng/job/netvirt-csit-1node-0cmb-1ctl-2cmp-openstack-queens-upstream-stateful-snat-conntrack-fluorine/9/robot/ - snat-conntrack ofp groups bug (shague, 15:32:57)
    5. daya asks if websockets updates will be part of the effort (shague, 15:33:27)
    6. vorburger needs help understanding the dependency map (shague, 15:38:10)
    7. vthapar create a jira with subtask's per each resource that owners can start adding the dependency tree (shague, 15:39:55)
    8. ACTION: vorburger to create jira with subtasks (shague, 15:40:22)
    9. ACTION: daya to help identify resources to help update the subtasks (shague, 15:40:38)
    10. daya solve problem in different groups, such as l2gw may not fit this model because of assumptions in the code (shague, 15:44:14)
    11. daya need to understand the driver architecture also (shague, 15:46:04)
    12. vthapar those updating the jiras should document if the driver needs work (shague, 15:48:25)


Meeting ended at 15:50:11 UTC (full logs).

Action items

  1. vorburger to create jira with subtasks
  2. daya to help identify resources to help update the subtasks


Action items, by person

  1. vorburger
    1. vorburger to create jira with subtasks


People present (lines said)

  1. shague (39)
  2. odl_meetbot (3)
  3. odp-gerritbot (2)
  4. vthapar (1)
  5. skitt (1)
  6. vorburger (1)
  7. faseelak (1)
  8. jamoluhrsen (1)
  9. sridharg (1)
  10. aswins (1)


Generated by MeetBot 0.1.4.