#opendaylight-netvirt: NetVirt Weekly 08/07/18

Meeting started by shague at 15:03:30 UTC (full logs).

Meeting summary

  1. Roll call and agenda bashing (please #info <your-nick>) (shague, 15:04:10)
    1. vishal (vthapar, 15:04:20)
    2. https://meetings.opendaylight.org/opendaylight-netvirt/2018/netvirt_weekly_07_31_18/opendaylight-netvirt-netvirt_weekly_07_31_18.2018-07-31-15.01.html (shague, 15:04:22)

  2. Review existing action items (shague, 15:04:41)
  3. [DONE] vorburger to create jira with subtasks for Neutron SPEC dependency checks - [NEUTRON-158](https://jira.opendaylight.org/browse/NEUTRON-158) (shague, 15:05:18)
    1. vthapar has pushed a patch for ports, will continue pushing other patches (shague, 15:06:34)
    2. HELP: others to help review the patches (shague, 15:06:43)
    3. review the n-odl current dependencies added to JIRAs, add any other dependencies that are not captured in n-odl yet (vthapar, 15:09:35)
    4. jhershbe_ tbd on dependency checks since n-odl does the checking, so no way to verify patches (shague, 15:09:53)

  4. https://trello.com/c/bot8QzRm/48-fluorine-release-planning - Code Feeze: 8/7/18 - [Release Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10403) - [Fluorine Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10400) - [NetVirt Team Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10304) - [fluorine patches](https://git.opendaylight.org/gerrit/#/q/project: (shague, 15:10:09)
  5. https://trello.com/c/BTurOwXh/42-oxygen-release-planning - Oxygen SR3: 08/07/18: Cherry-pick bug fixes - [oxygen patches](https://git.opendaylight.org/gerrit/#/q/project:netvirt+status:open+branch:stable/oxygen) - [SR3 Signoff](https://docs.google.com/spreadsheets/d/1dYOY99twqHV_Q0YorAOOxmL0aFc3icNXg8qA_zGwKyA/edit#gid=392785629) (shague, 15:11:30)
    1. ACTION: shague jamoluhrsen to look at the signoff sheet (shague, 15:11:53)

  6. Fluorine code freeze, branching workflow (shague, 15:13:25)
    1. faseelak (faseelak, 15:14:33)
    2. once branch cut is done, continue working on master, and cherry-pick patches as relevent to stable/fluorine (faseelak, 15:15:14)

  7. Fluorine blocker bugs (shague, 15:16:17)
    1. https://jira.opendaylight.org/browse/OPNFLWPLUG-1028 is a potential blocker bug (shague, 15:17:09)

  8. skitt: [NETVIRT-1318](https://jira.opendaylight.org/browse/NETVIRT-1318) - MDSAL Best Practices (shague, 15:23:24)
    1. vthapar https://git.opendaylight.org/gerrit/#/c/74026/ broken ut (shague, 15:25:12)
    2. vthapar stll working on patch (shague, 15:25:27)
    3. patches are nto blockers (shague, 15:26:11)

  9. [NETVIRT-1015](https://jira.opendaylight.org/browse/NETVIRT-1015) - leader down, nodes quarantined, cluster in bad shape so reads fails - what should the applications do? (shague, 15:26:29)
    1. the cluster is in a bad state so all ds operations fail (shague, 15:29:12)
    2. tomp mentions this might be a dup of CONTROLLER-1849 (shague, 15:31:56)
    3. tomp - need to characterize what the test is doing, what node is restarted, which shard is in use (shague, 15:32:41)
    4. can tooling be developed that can show the requested information (shague, 15:33:35)
    5. jhershbe_ says skitt has started a tool (shague, 15:33:46)
    6. daya_k do these exceptions matter if the datapath is still working (shague, 15:37:54)
    7. the script can be used in csit to know the test state (shague, 15:47:59)
    8. daya_k does a quarantined node mean the other two nodes are still connected? (shague, 15:50:37)
    9. daya_k should add more checks in tests to verify the cluster is good, otherwise just fail tests (shague, 16:04:05)
    10. would need to adapt for scale (shague, 16:04:26)


Meeting ended at 16:07:22 UTC (full logs).

Action items

  1. shague jamoluhrsen to look at the signoff sheet


Action items, by person

  1. shague
    1. shague jamoluhrsen to look at the signoff sheet


People present (lines said)

  1. shague (36)
  2. vthapar (4)
  3. odl_meetbot (3)
  4. faseelak (2)
  5. rovarga_ (2)
  6. vorburger (1)
  7. odp-gerritbot (1)
  8. jhershbe_ (1)


Generated by MeetBot 0.1.4.