#opendaylight-netvirt: NetVirt Weekly 08/14/18

Meeting started by shague at 15:02:19 UTC (full logs).

Meeting summary

  1. Roll call and agenda bashing (please #info <your-nick>) (shague, 15:02:25)
    1. https://meetings.opendaylight.org/opendaylight-netvirt/2018/netvirt_weekly_08_07_18/opendaylight-netvirt-netvirt_weekly_08_07_18.2018-08-07-15.03.html (shague, 15:02:40)

  2. Review existing action items (shague, 15:02:56)
    1. faseelak (faseelak, 15:03:07)
    2. jhershbe__ (jhershbe__, 15:04:27)
    3. Vishal (vthapar, 15:05:14)

  3. https://trello.com/c/bot8QzRm/48-fluorine-release-planning - final Checkpoint: 8/23/18 - [Release Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10403) - [Fluorine Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10400) - [NetVirt Team Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10304) - [fluorine patches](https://git.opendaylight.org/gerrit/#/q/ (shague, 15:05:50)
    1. when are release candidate builds (shague, 15:07:12)
    2. jamoluhrsen (jamoluhrsen, 15:07:16)
    3. ACTION: shague jamoluhrsen find out info on release candidates (shague, 15:08:31)
    4. are there any blocker bugs? (shague, 15:09:04)
    5. https://jira.opendaylight.org/browse/OPNFLWPLUG-1028 is marked as blocker (shague, 15:10:16)

  4. FIPs and Octavia [Josh] (shague, 15:11:54)
    1. octavia is replacement for openstack lbaas (shague, 15:12:30)
    2. aswin asks about garps? (shague, 15:16:03)
    3. jhershbe__ octavia handles the garps (shague, 15:16:24)
    4. kiran: is the garp going to be used to find the fip for the vip? (shague, 15:17:26)
    5. jhershbe__ yes (shague, 15:17:33)
    6. octavia vms get normal neutron ports and ips, and fips. but the vip is a port with no southbound state (shague, 15:19:24)
    7. kiran garps are processed and throttled. same garps are ignored and only garps that changed the learned port are processed (shague, 15:21:29)
    8. jhershbe__: how are flows cleaned up when switching to new fips? (shague, 15:22:56)

  5. l3vpn and dcgw CSIT - [59457](https://git.opendaylight.org/gerrit/#/c/59457/) - how to structure the suites for the extra tools vms needed for dcgw's? (shague, 15:35:00)
    1. jamoluhrsen opinion is that we should test everything (shague, 15:36:36)
    2. current tests are not testing the datapath so dcgw is not used currently (shague, 15:37:59)
    3. sridharg feels the dcgw should be included (shague, 15:38:57)
    4. when using snapshots, does this dcgw-setup.sh take long to install? (shague, 15:39:46)
    5. should we just move the dcgw-setup into the tools vms? (shague, 15:40:35)
    6. or create a different gate job for external projects to netvirt - those would not run the l3vpn tests (shague, 15:42:26)
    7. ACTION: ask patch writer how long the quagga takes to install or should this bake into the tools vms (shague, 15:46:12)
    8. shague and faseela to ask mohammad to add quagga install to packer (shague, 15:49:35)

  6. faseelak bug found in l2 vlan provider code (shague, 15:50:19)
    1. https://jira.opendaylight.org/browse/NETVIRT-1395 (faseelak, 15:50:41)
    2. timing error, if vlan interface is not present when vms are spawned, then flows are not installed (shague, 15:52:20)
    3. elan expects the vlan interface to be present before adding vm flows (shague, 15:53:06)
    4. vlan provider networks are not miggrated to the full fesh setup as 0 day configuration (shague, 15:57:51)
    5. ACTION: aswin to work on patch (shague, 16:01:49)

  7. flow documentation (shague, 16:02:44)
    1. HELP: faseelak askes everyone to review patches (shague, 16:02:54)
    2. https://git.opendaylight.org/gerrit/#/c/74808/ (shague, 16:04:11)


Meeting ended at 16:04:18 UTC (full logs).

Action items

  1. shague jamoluhrsen find out info on release candidates
  2. ask patch writer how long the quagga takes to install or should this bake into the tools vms
  3. aswin to work on patch


Action items, by person

  1. jamoluhrsen
    1. shague jamoluhrsen find out info on release candidates
  2. shague
    1. shague jamoluhrsen find out info on release candidates
  3. UNASSIGNED
    1. ask patch writer how long the quagga takes to install or should this bake into the tools vms
    2. aswin to work on patch


People present (lines said)

  1. shague (40)
  2. odl_meetbot (4)
  3. faseelak (2)
  4. jhershbe__ (1)
  5. vthapar (1)
  6. jamoluhrsen (1)


Generated by MeetBot 0.1.4.