#opendaylight-netvirt: NetVirt Weekly 08/21/18

Meeting started by shague at 15:02:00 UTC (full logs).

Meeting summary

  1. Roll call and agenda bashing (please #info <your-nick>) (shague, 15:02:07)
    1. vpickard (vpickard, 15:02:16)
    2. https://meetings.opendaylight.org/opendaylight-netvirt/2018/netvirt_weekly_08_14_18/opendaylight-netvirt-netvirt_weekly_08_14_18.2018-08-14-15.02.html (shague, 15:02:18)
    3. skitt (skitt, 15:02:20)
    4. Vishal (vthapar, 15:02:21)

  2. Review existing action items (shague, 15:03:21)
    1. jamoluhrsen (jamoluhrsen, 15:06:10)
    2. https://jenkins.opendaylight.org/sandbox/user/thapar/my-views/view/MyView/job/thapar-netvirt-csit-3node-0cmb-1ctl-2cmp-openstack-pike-upstream-stateful-neon/4/consoleFull (shague, 15:06:49)

  3. [DONE] shague jamoluhrsen find out info on release candidates. 8/23/18 is the date the RC should be signed-off (shague, 15:07:21)
  4. [DONE[ ask patch writer how long the quagga takes to install or should this bake into the tools vms. The time is < 1m. Ask was made to move to use packer to also avoid install failures. (shague, 15:08:23)
    1. current plan to install into the packer vms (shague, 15:09:50)

  5. [WIP] aswin to work on patch for https://jira.opendaylight.org/browse/NETVIRT-1395 (shague, 15:10:24)
    1. aswin looking at it after finishing other patches (shague, 15:10:39)

  6. https://trello.com/c/bot8QzRm/48-fluorine-release-planning - final Checkpoint: 8/23/18 - [Release Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10403) - [Fluorine Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10400) - [NetVirt Team Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10304) - [fluorine patches](https://git.opendaylight.org/gerrit/#/q/ (shague, 15:10:51)
  7. upstreaming useful tools, i.e. neutron and odl consistency scripts, flow consistency scripts. Also adding to odltools (shague, 15:11:28)
    1. vthapar odltools has new analysis tools in current version (shague, 15:12:16)
    2. vthapar additions across oxygen, fluorine and neon (shague, 15:12:33)
    3. HELP: vthapar asking for contributors (shague, 15:12:49)
    4. daya asks about shard leader scripting (shague, 15:14:16)
    5. vthapar faseela has already migrated script to odltools (shague, 15:14:27)
    6. vthapar request for flow consistency checks (shague, 15:15:26)
    7. daya could add a flow diff checker for 3node tests (shague, 15:16:18)
    8. vthapar should create jiras on odltools for new features (shague, 15:16:45)
    9. shague keep adding documentation to testing and troubleshooting document (shague, 15:18:52)
    10. https://git.opendaylight.org/gerrit/#/c/74808/ (shague, 15:19:37)

  8. HAProxy configuration should be updated to use diagstatus: [ooo haproxy config](https://github.com/openstack/puppet-tripleo/blob/master/manifests/haproxy.pp#L1531), [downstream patch](https://review.openstack.org/#/c/581790/2/manifests/haproxy.pp), odl uses: [odl haproxy config](https://github.com/opendaylight/releng-builder/blob/master/jjb/integration/integration-deploy-openstack-run-test.sh#L490) (shague, 15:20:46)
    1. downstream uses diagstatus to determine node status (shague, 15:23:05)
    2. this hsould be upstreamed (shague, 15:23:13)
    3. ACTION: shague to look at adding the diagstatus to upstream (shague, 15:24:00)

  9. Adding DPDK to CSIT (shague, 15:24:19)
    1. venkat looking at adding ovs dpdk package to the csit (shague, 15:25:21)
    2. need hostconfig (shague, 15:25:44)
    3. daya also need binding to nic, and other switch configuration (shague, 15:26:10)
    4. need to find way to install dpdk in virtual environment (shague, 15:29:18)
    5. aswin ovs 2.8 and later required for snat-conntrack (shague, 15:31:58)
    6. daya mentions maybe it needs to be at least 2.9.1 (shague, 15:32:09)
    7. daya mentions maybe it needs to be at least 2.9.2 (shague, 15:32:13)
    8. daya gre tunnel impl is in ovs 2.8.1 so it is needed (shague, 15:35:00)
    9. other issues so 2.9.2 is required (shague, 15:35:38)
    10. daya switch restart tests, by default client and server mode has issues, ovs 2.8 has a new client mode (shague, 15:37:36)
    11. daya will send email with versions to adapt the tests (shague, 15:38:59)

  10. skitt: [NETVIRT-1318](https://jira.opendaylight.org/browse/NETVIRT-1318) - MDSAL Best Practices (shague, 15:39:44)
    1. elan and vpn patches are still outstanding for the constrained tx's (shague, 15:40:29)
    2. skitt: adding support for tx chains in managed tx's (shague, 15:46:13)


Meeting ended at 15:54:08 UTC (full logs).

Action items

  1. shague to look at adding the diagstatus to upstream


Action items, by person

  1. shague
    1. shague to look at adding the diagstatus to upstream


People present (lines said)

  1. shague (44)
  2. odl_meetbot (3)
  3. jamoluhrsen (2)
  4. vpickard (1)
  5. vthapar (1)
  6. skitt (1)


Generated by MeetBot 0.1.4.