#opendaylight-netvirt: NetVirt Weekly 09/11/18

Meeting started by shague at 15:01:58 UTC (full logs).

Meeting summary

  1. Roll call and agenda bashing (please #info <your-nick>) (shague, 15:02:05)
    1. https://meetings.opendaylight.org/opendaylight-netvirt/2018/netvirt_weekly_09_04_18/opendaylight-netvirt-netvirt_weekly_09_04_18.2018-09-04-15.03.html (shague, 15:02:19)
    2. Vishal (vthapar, 15:02:45)

  2. Review existing action items (shague, 15:03:33)
  3. [DONE] shague start thread about branching strategy (shague, 15:07:04)
    1. asked tsc to use later date in nov (shague, 15:08:42)
    2. when branch is pulled, branch is still open, but jobs are removed (shague, 15:09:30)
    3. how do we verify that branch is still stable (shague, 15:10:43)

  4. [DONE] kiran to check with somashekar if idea of using ifPresent will solve problem (shague, 15:14:20)
  5. Neon Planning (shague, 15:14:57)
    1. continue using specs (shague, 15:16:13)
    2. some specs already there from fluorine that were pushed to neon (shague, 15:16:43)
    3. ask spec owners to check if approved specs need review (shague, 15:18:48)
    4. open a new neon folder (shague, 15:18:59)
    5. ACTION: shague create new neon folder, port specs, and ping owners (shague, 15:19:18)
    6. use the csit checkpoint for spec completions: 11/1/18 (shague, 15:21:24)
    7. sridhar mentions ipv6 needs mtu values from networking-odl (shague, 15:25:24)
    8. ipv4 relies on dhcp agant so it didn't need the mtu updates (shague, 15:25:51)
    9. version bump, 10/5/18 (shague, 15:27:07)
    10. vote on MRI deliverables on 10/4/18 (shague, 15:28:24)
    11. mockito changes will require netvirt changes (shague, 15:29:23)
    12. patches can only merge in order before netvirt can merge patches (shague, 15:30:28)

  6. Neon DDF [Topics](https://wiki.opendaylight.org/view/Events:Neon_Dev_Forum) (shague, 15:31:11)
    1. looking at ways to support COE more generically (shague, 15:36:24)
    2. need to decouple neutron from the netvirt northbound (shague, 15:36:41)
    3. l2 and l3 are coupled which causes problems (shague, 15:37:13)
    4. daya mentions need resource planning to work on the decoupling (shague, 15:38:15)
    5. might be able to pull odltools if there is time (shague, 15:39:21)
    6. daya says tharun can help with clustering analysis. chetan and shashi will guide him (shague, 15:42:29)

  7. clustering (shague, 15:44:35)
    1. jamoluhrsen mentions the artery changes are helping (shague, 15:44:54)
    2. tomp switching to artery will first require getting tell-based working since it uses the chunking (shague, 15:51:38)


Meeting ended at 15:51:41 UTC (full logs).

Action items

  1. shague create new neon folder, port specs, and ping owners


Action items, by person

  1. shague
    1. shague create new neon folder, port specs, and ping owners


People present (lines said)

  1. shague (33)
  2. odl_meetbot (3)
  3. vthapar (1)


Generated by MeetBot 0.1.4.