#opendaylight-netvirt: NetVirt Weekly 10/09/18

Meeting started by vthapar at 15:01:40 UTC (full logs).

Meeting summary

  1. Roll call and agenda bashing (please #info <your-nick>) (vthapar, 15:01:51)
    1. Vishal (vthapar, 15:03:44)
    2. skitt (skitt, 15:03:55)
    3. vpickard (vpickard, 15:03:58)
    4. jamoluhrsen (jamoluhrsen, 15:04:02)
    5. jhershbe_ (jhershbe_, 15:04:03)
    6. https://trello.com/c/O9x0EXaZ/44-2018-netvirt-project-meeting-details-agenda-and-previous-meetings Trello board (vthapar, 15:04:10)
    7. Hanamantagoud (Hanamantagoud, 15:05:52)
    8. Aswin (aswins, 15:06:34)

  2. review previous action items (vthapar, 15:06:44)
    1. vorburger (vorburger, 15:06:53)
    2. Sridhar Gaddam (sridharg, 15:08:05)
    3. aswins says conntrack jobs failing sporadic and failures don't seem to be conntrack specific though more frequent in conntrack suite (vthapar, 15:08:28)
    4. https://jenkins.opendaylight.org/releng/user/jluhrsen/my-views/view/netvirt%20csit/job/netvirt-csit-1node-0cmb-1ctl-2cmp-openstack-queens-upstream-stateful-snat-conntrack-oxygen/79/robot/ (jamoluhrsen, 15:08:50)
    5. Hanamantagoud (Hanamantagoud_, 15:09:19)
    6. ACTION: jamoluhrsen to share list of all failures (vthapar, 15:09:34)
    7. ACTION: aswins to review the failures (vthapar, 15:09:38)

  3. Neon Release planning (vthapar, 15:10:31)
    1. https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10304# (vthapar, 15:10:50)

  4. Neon DDF Recap (vthapar, 15:15:15)
    1. ACTION: daya to send out list of DDF notes (vthapar, 15:15:41)
    2. refactoring yang models in netvirt to reduce internal models (vthapar, 15:19:58)
    3. #improve code coverage for netvirt by adding more UTs (vthapar, 15:20:27)
    4. Netvirt gate jobs for auto gating all merges (vthapar, 15:20:47)

  5. Neon MRI bump status (vthapar, 15:21:14)
    1. skitt netvirt should be good to go, had to disable 3 UTs. (vthapar, 15:21:55)
    2. one of them about yangtools being more strict which caused issues with genius (vthapar, 15:22:11)
    3. vorburger says genius was building fully locally (vthapar, 15:23:58)
    4. quick multipatch now passes (vthapar, 15:24:22)
    5. https://jenkins.opendaylight.org/releng/view/integration/job/integration-multipatch-test-neon/62/ (vorburger, 15:25:42)
    6. there are failures in netvirt jobs (vthapar, 15:27:07)
    7. ACTION: jamoluhrsen to look into failures (vthapar, 15:27:18)
    8. full multipatch needs to pass before we start merging (vthapar, 15:30:04)
    9. ACTION: vorburger to send mail on csit status on mri patch (vthapar, 15:35:42)

  6. CSIT sporadic failures (vthapar, 15:36:31)
    1. https://jira.opendaylight.org/browse/OPNFLWPLUG-1039 (vthapar, 15:36:48)
    2. https://jira.opendaylight.org/browse/NETVIRT-1441 (vthapar, 15:37:03)
    3. https://jira.opendaylight.org/browse/NETVIRT-1372 (vthapar, 15:37:13)
    4. Karthik and som looking into NETVIRT-1441 and NETVIRT-1372 (vthapar, 15:37:30)

  7. Netvirt automated gate status (vthapar, 15:41:59)
    1. job in sandbox is already working, currently taking 45 minutes (vthapar, 15:42:21)
    2. this job is currently running l2 and external with a few tests skipped (vthapar, 15:43:06)
    3. ACTION: jamoluhrsen to send mail with link to robot results for gatejob runs in sandbox so all can review the tests that are part of it (vthapar, 15:45:16)

  8. jumbo frames (vthapar, 15:46:01)
    1. vpickard tested ping across VMs in same network and across different networks, it worked (vthapar, 15:47:08)
    2. vpickard found that ping to external network interface didn't work (vthapar, 15:48:15)
    3. how to handle jumbo frames? return supported mtu size through ICMP to reconfigure through pmtu discovery, or configure higher mtu on external interface? (vthapar, 15:55:39)
    4. would be good if we can give appropriate icmp message (vthapar, 15:59:35)
    5. ACTION: vpickard to check with OVN team on how they're looking to solve this. (vthapar, 16:02:33)


Meeting ended at 16:03:01 UTC (full logs).

Action items

  1. jamoluhrsen to share list of all failures
  2. aswins to review the failures
  3. daya to send out list of DDF notes
  4. jamoluhrsen to look into failures
  5. vorburger to send mail on csit status on mri patch
  6. jamoluhrsen to send mail with link to robot results for gatejob runs in sandbox so all can review the tests that are part of it
  7. vpickard to check with OVN team on how they're looking to solve this.


Action items, by person

  1. aswins
    1. aswins to review the failures
  2. jamoluhrsen
    1. jamoluhrsen to share list of all failures
    2. jamoluhrsen to look into failures
    3. jamoluhrsen to send mail with link to robot results for gatejob runs in sandbox so all can review the tests that are part of it
  3. vorburger
    1. vorburger to send mail on csit status on mri patch
  4. vpickard
    1. vpickard to check with OVN team on how they're looking to solve this.


People present (lines said)

  1. vthapar (43)
  2. odl_meetbot (4)
  3. jamoluhrsen (3)
  4. vorburger (2)
  5. vpickard (1)
  6. Hanamantagoud_ (1)
  7. sridharg (1)
  8. skitt (1)
  9. Hanamantagoud (1)
  10. jhershbe_ (1)
  11. aswins (1)


Generated by MeetBot 0.1.4.