#opendaylight-netvirt: NetVirt Weekly 5/22/2018

Meeting started by vpickard at 15:01:58 UTC (full logs).

Meeting summary

  1. Roll call and agenda bashing (please #info <your-nick>) (vpickard, 15:02:14)
    1. https://trello.com/c/O9x0EXaZ/44-2018-netvirt-project-meeting-details-agenda-and-previous-meetings Trello board (vpickard, 15:02:32)
    2. skitt (skitt, 15:03:12)
    3. jhershbe (jhershbe, 15:03:49)
    4. jamoluhrsen (jamoluhrsen, 15:03:58)

  2. [WIP] vthapar and shague to discusss how to update specs for odltools - some initial discussions but nothing concrete yet (vpickard, 15:05:09)
  3. [DONE] shague to clarify license issue, start with apache - Switch to using Eclipse licence use by ODL projects, the RDO team indicates the license is an accepted Fedora license that meets their requirements (vpickard, 15:06:09)
    1. need to circle back with shague about the odltools license task. (jamoluhrsen, 15:06:16)

  4. [DONE] vivekn to request devs to update pipeline.rst with flow updates (vpickard, 15:06:28)
  5. https://trello.com/c/bot8QzRm/48-fluorine-release-planning - looking good. Next date is the middle checkpoint 7/5/18 - [Release Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10403) - [Fluorine Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10400) (vpickard, 15:07:55)
    1. we have no good/automatic way to validate the flow pipeline (.rst, ppt) are kept up to date (jamoluhrsen, 15:08:10)
    2. fluorine seems on track (jamoluhrsen, 15:09:08)

  6. [csit:exception](https://jira.opendaylight.org/issues/?filter=10116) - many exceptions and some random failures came in two weeks ago, so we have been holding off merging patches. Two weeks ago we merged 8 patches. Maybe we should revert and then work our way back slowly. (vpickard, 15:09:11)
    1. fluorine is suffering from new random failures and new exceptions showing up. (jamoluhrsen, 15:10:06)
    2. vivek says the new exceptions and failures are mostly related to the tempest.api.network superset of tests. those run in parallel, but they are hard to debug. (jamoluhrsen, 15:13:49)
    3. tempest api tests run in parallel, making it difficult to debug. (vpickard, 15:15:34)
    4. running 8 threads in tempest api test suite (vpickard, 15:15:59)
    5. ACTION: jamoluhrsen to respond to viveks email about an idea to run tempest.api.network tests one at a time with the extra ROBOT log in karaf.log (jamoluhrsen, 15:17:30)

  7. [TSC-99](https://jira.opendaylight.org/browse/TSC-99) - weather item for rpc changes. Patches are ready - thanks to Tom on NetVirt patch! Likely instability when those start merging soon. (vpickard, 15:18:03)
  8. [TSC-101](https://jira.opendaylight.org/browse/TSC-101) - weather item for getKey() changes. That will be next to go in once the multipatch and csit passes. [72099](https://git.opendaylight.org/gerrit/#/c/72099/) - thanks again to Tom (vpickard, 15:19:26)
  9. specs: [NetVirt Team Dashboard](https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10304#) (vpickard, 15:20:36)
  10. [Vic] Present IGMP Snooping spec (vpickard, 15:24:22)
    1. https://git.opendaylight.org/gerrit/#/c/71179/ <-- igmp snooping spec (jamoluhrsen, 15:34:57)
    2. ACTION: jamoluhrsen to add a gerrit comment about how to simulate mcast query (i.e., how to test router sourced mcast traffic) (jamoluhrsen, 15:46:56)

  11. adding support for evpn rt3 spec review (vpickard, 15:48:05)


Meeting ended at 16:08:41 UTC (full logs).

Action items

  1. jamoluhrsen to respond to viveks email about an idea to run tempest.api.network tests one at a time with the extra ROBOT log in karaf.log
  2. jamoluhrsen to add a gerrit comment about how to simulate mcast query (i.e., how to test router sourced mcast traffic)


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to respond to viveks email about an idea to run tempest.api.network tests one at a time with the extra ROBOT log in karaf.log
    2. jamoluhrsen to add a gerrit comment about how to simulate mcast query (i.e., how to test router sourced mcast traffic)


People present (lines said)

  1. vpickard (16)
  2. jamoluhrsen (9)
  3. odl_meetbot (3)
  4. skitt (1)
  5. jhershbe (1)


Generated by MeetBot 0.1.4.