#opendaylight-netvirt: NetVirt Weekly 01/15/19

Meeting started by shague at 16:09:26 UTC (full logs).

Meeting summary

  1. review previous actions (shague, 16:09:49)
    1. https://meetings.opendaylight.org/opendaylight-netvirt/2019/netvirt_weekly_01_08_19/opendaylight-netvirt-netvirt_weekly_01_08_19.2019-01-08-16.01.html (shague, 16:09:52)
    2. daya: spec status (shague, 16:10:05)
    3. daya: most specs moved to sodium (shague, 16:10:20)
    4. oftunnels spec and l3vpn robustness will likely make it for neon (shague, 16:10:49)
    5. daya: acthuth will be taking up the robustness specs, as well as Arun Sharma (shague, 16:11:26)

  2. open patches (shague, 16:12:18)
    1. https://git.opendaylight.org/gerrit/#/q/project:netvirt+status:open (shague, 16:12:21)
    2. ACTION: daya to reply with update on patches (shague, 16:12:31)

  3. daya to share config changes for pinning to default shard leader and not using round robin (shague, 16:12:56)
    1. daya changes are on boron downstream, so may not make sense on neon (shague, 16:13:35)
    2. daya these are changes to haproxy (shague, 16:13:51)
    3. ACTION: daya to send haproxy changes to netvirt-dev (shague, 16:15:36)

  4. jamoluhrsen look at enabling gate patch on other projects (shague, 16:15:59)
    1. netvirt, ovsdb, genius have patches merged, ofp is waiting until patch is gating (shague, 16:17:25)
    2. jamoluhrsen looking into enabling voting (shague, 16:17:36)

  5. aswinsuryan to look at pnf failure (shague, 16:17:56)
    1. have not seen failure in last 100 checks so difficult to triage (shague, 16:18:15)
    2. going to wait on this bug (shague, 16:18:21)

  6. jamoluhrsen to work with tomp on main issue with netvirt and clustering getting into a bad state when previous test suite takes down all controllers and brings them back (shague, 16:19:32)
    1. default tunnels are down after nodes are restarted (shague, 16:19:56)
    2. no ideas yet (shague, 16:20:02)
    3. odltools is reporting odls down and then fails suite setup (shague, 16:23:27)
    4. https://jira.opendaylight.org/browse/GENIUS-263 (shague, 16:24:16)
    5. https://logs.opendaylight.org/releng/vex-yul-odl-jenkins-1/netvirt-csit-3node-0cmb-1ctl-2cmp-openstack-queens-upstream-stateful-fluorine/168/robot-plugin/log_full.html.gz#s1-s7-k1-k9-k2-k2-k1-k1-k5-k4 (shague, 16:24:36)
    6. shague could add test to odltools ci, take down all three nodes, restart and see if odltools passes (shague, 16:27:35)

  7. Neon Release Planning - NetVirt Team Dashboard (shague, 16:28:44)
  8. Neon Specs. Create "approved" and "review" folders until the feature has actually been reviewed and implemented? (shague, 16:31:41)
    1. agreed to break out the specs to status folders (shague, 16:35:35)

  9. Fluorine Release Planning - NetVirt Team Dashboard (shague, 16:35:53)
    1. SR2 2/7/19 - three weeks (shague, 16:36:05)

  10. clustering (shague, 16:37:51)
    1. daya is tell-based still being investigated (shague, 16:38:12)
    2. jamoluhrsen controller csit runs tell-based and no results are showing any better than the non tell-based csit (shague, 16:38:41)
    3. daya can't move to tell since still on boron, will need master to tests it (shague, 16:41:19)
    4. daya e/// will test in a month or two (shague, 16:41:30)
    5. jamoluhrsen to try tell-based on netvirt upstream csit (shague, 16:41:57)


Meeting ended at 16:44:34 UTC (full logs).

Action items

  1. daya to reply with update on patches
  2. daya to send haproxy changes to netvirt-dev


People present (lines said)

  1. shague (40)
  2. odl_meetbot (3)


Generated by MeetBot 0.1.4.