#opendaylight-neutron: neutron_northbound

Meeting started by regXboi at 15:02:48 UTC (full logs).

Meeting summary

    1. edwarnicke (edwarnicke, 15:03:07)
    2. https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings#Agenda_for_Next_Meeting_.284.2F3.29 agenda (regXboi, 15:03:16)
    3. regXboi (regXboi, 15:03:21)

  1. roll call + agenda bashing (regXboi, 15:03:40)
    1. ACTION: regXboi to put together integration patch (with resource help from dfarrell07|sick) for REST unmarshalling testing of odl-neutron-service with dummy provider. (regXboi, 15:04:08)
    2. ACTION: edwarnicke, flaviof to review current doc patch (regXboi, 15:05:44)
    3. https://git.opendaylight.org/gerrit/#/c/16340/ current documentation patch (regXboi, 15:06:09)
    4. action items 3 and 4 are done (regXboi, 15:06:32)
    5. action item 5 is done (regXboi, 15:06:46)
    6. ACTION: flaviof to work karaf system test for merge, integration, and RC events (regXboi, 15:07:14)
    7. kkoushik (kkoushik_, 15:07:21)
    8. action item 7 is ongoing ... so (regXboi, 15:07:24)
    9. ACTION: Shreshtha_ to put together junit testing for some apis this week (regXboi, 15:07:34)
    10. action item 8 is going to be deferred to after lithium (regXboi, 15:07:51)
    11. ACTION: regXboi to float mini-hackathon trial balloon to mailing list (regXboi, 15:08:17)

  2. M4 status (regXboi, 15:08:41)
    1. M4 deadline was 4/2 and we are currently yellow (regXboi, 15:08:59)
    2. API freeze is done (regXboi, 15:09:32)
    3. documentaiton is 50% done - we need how to write the yang model side (regXboi, 15:09:54)
    4. Maven Central requirements are done - that patch got merged this morning (regXboi, 15:10:12)
    5. integration and system test is the big mess (regXboi, 15:10:21)
    6. current ETA reported for I&ST is 4/10, but regXboi doesn't have much confidence (regXboi, 15:10:53)
    7. https://git.opendaylight.org/gerrit/#/c/17599/ (edwarnicke, 15:15:03)
    8. https://git.opendaylight.org/gerrit/#/c/17599/ patch to act as pattern for karaf testing (regXboi, 15:16:47)
    9. ACTION: edwarnicke to add karaf feature for dummy provider (regXboi, 15:18:38)
    10. ACTION: regXboi to look at karaf testing pattern link (regXboi, 15:18:54)

  3. M5 (regXboi, 15:19:18)
    1. ACTION: regXboi to extend dummy provider to cover new aware interfaces that were added to meet M4 (regXboi, 15:22:55)
    2. northbound classes that need filling in are NeutronMeteringLabelsNorthbound.java, NeutronVPNIKEPoliciesNorthbound.java, NeutronVPNIPSECSiteConnectionsNorthbound.java, NeutronVPNServicesNorthbound.java,NeutronVPNIPSECPoliciesNorthbound.java, and NeutronMeteringLabelRulesNorthbound.java (regXboi, 15:24:58)
    3. transcriber needs to write to the yang models (regXboi, 15:25:17)
    4. volunteers can either step up on the mailing list or (better yet) push code (regXboi, 15:25:40)
    5. AGREED: For M5 the stability branch will need to be cut, but we'll table that for a couple of weeks - do that at the last minute (regXboi, 15:27:51)

  4. open discussion (regXboi, 15:29:35)
    1. ACTION: rather than roll back to the previous action Bhavesh_ and co will take up the karaf testing items (regXboi, 15:35:07)

  5. no ending topic today (regXboi, 15:42:27)


Meeting ended at 15:42:31 UTC (full logs).

Action items

  1. regXboi to put together integration patch (with resource help from dfarrell07|sick) for REST unmarshalling testing of odl-neutron-service with dummy provider.
  2. edwarnicke, flaviof to review current doc patch
  3. flaviof to work karaf system test for merge, integration, and RC events
  4. Shreshtha_ to put together junit testing for some apis this week
  5. regXboi to float mini-hackathon trial balloon to mailing list
  6. edwarnicke to add karaf feature for dummy provider
  7. regXboi to look at karaf testing pattern link
  8. regXboi to extend dummy provider to cover new aware interfaces that were added to meet M4
  9. rather than roll back to the previous action Bhavesh_ and co will take up the karaf testing items


Action items, by person

  1. Bhavesh_
    1. rather than roll back to the previous action Bhavesh_ and co will take up the karaf testing items
  2. edwarnicke
    1. edwarnicke, flaviof to review current doc patch
    2. edwarnicke to add karaf feature for dummy provider
  3. regXboi
    1. regXboi to put together integration patch (with resource help from dfarrell07|sick) for REST unmarshalling testing of odl-neutron-service with dummy provider.
    2. regXboi to float mini-hackathon trial balloon to mailing list
    3. regXboi to look at karaf testing pattern link
    4. regXboi to extend dummy provider to cover new aware interfaces that were added to meet M4
  4. UNASSIGNED
    1. flaviof to work karaf system test for merge, integration, and RC events
    2. Shreshtha_ to put together junit testing for some apis this week


People present (lines said)

  1. regXboi (99)
  2. edwarnicke (43)
  3. Bhavesh_ (14)
  4. odl_meetbot (6)
  5. kkoushik_ (1)


Generated by MeetBot 0.1.4.