#opendaylight-neutron: neutron_northbound

Meeting started by regXboi at 14:59:43 UTC (full logs).

Meeting summary

  1. info in and agenda bashing (regXboi, 14:59:53)
    1. https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings agenda in its usual place (regXboi, 15:00:24)
    2. regXboi (regXboi, 15:00:28)
    3. flaviof (flaviof, 15:03:31)
    4. adetalhouet (adetalhouet, 15:04:46)
    5. Bhavesh (Bhavesh, 15:05:13)
    6. while flaviof didn't review the doc patch, colindixon merged it so we can close action item 1 (regXboi, 15:05:52)
    7. we've seen a bunch of JAXB patches, so action item 2 continues (regXboi, 15:06:15)
    8. action item 2 can be closed, all JAXB unit tests are in (regXboi, 15:07:12)
    9. ACTION: regXboi to float mini-hackathon trial balloon to mailing list (regXboi, 15:08:01)
    10. dummy provider feature-repo still being worked (regXboi, 15:11:45)
    11. ACTION: ALL we still need testing :( (regXboi, 15:11:56)
    12. dummy provider has been updated (regXboi, 15:12:43)
    13. https://git.opendaylight.org/gerrit/#/c/17791/ dummy provider extension patch (regXboi, 15:12:51)

  2. Missing M4 Items (regXboi, 15:13:19)
    1. ACTION: adetalhouet to write documentation for how to write a consumer of the neutron yang model. edwarnicke to provide intel and guidance (regXboi, 15:17:42)

  3. M5 (what needs to be done) (regXboi, 15:18:18)
    1. ACTION: Bhavesh and co to fill in NeutronVPNIPSECSiteConnectionsNorthbound and NeutronVPNServicesNorthbound (regXboi, 15:21:22)
    2. ACTION: edwarnicke (tentatively) to code transcriber to talk to YANG model (regXboi, 15:23:05)

  4. Other Topics (open discussion) (regXboi, 15:24:45)
    1. When I do a "neutron security-group-create" I see nothing in wireshark for REST calls to ODL. (alagalah, 15:26:16)
    2. I have flavio's latest devstack, and set local.conf to pull everything #OFFLINE=True RECLONE=Yes (alagalah, 15:26:46)
    3. It stacks correctly, and I do see REST for net-create, subnet-create (and subsequent port create for the DHCP server) (alagalah, 15:27:20)
    4. regXboi to help alagalah get wireshark into ascii format that all can look at (regXboi, 15:29:23)
    5. http://pastebin.com/ux8Zp0VL alagalah's pcap (regXboi, 15:31:16)
    6. alagalah, I think we need mestery for this one - it looks from this pcap that neutron isn't sending the securitygroups/rules related stuff to ODL (regXboi, 15:32:36)
    7. correct (alagalah, 15:33:05)
    8. https://bugs.launchpad.net/networking-odl launchpad for bugs in networking-odl (flaviof, 15:36:17)

  5. chocolate chip muffins (to be different) (regXboi, 15:39:07)


Meeting ended at 15:39:16 UTC (full logs).

Action items

  1. regXboi to float mini-hackathon trial balloon to mailing list
  2. ALL we still need testing :(
  3. adetalhouet to write documentation for how to write a consumer of the neutron yang model. edwarnicke to provide intel and guidance
  4. Bhavesh and co to fill in NeutronVPNIPSECSiteConnectionsNorthbound and NeutronVPNServicesNorthbound
  5. edwarnicke (tentatively) to code transcriber to talk to YANG model


Action items, by person

  1. adetalhouet
    1. adetalhouet to write documentation for how to write a consumer of the neutron yang model. edwarnicke to provide intel and guidance
  2. Bhavesh
    1. Bhavesh and co to fill in NeutronVPNIPSECSiteConnectionsNorthbound and NeutronVPNServicesNorthbound
  3. regXboi
    1. regXboi to float mini-hackathon trial balloon to mailing list
  4. UNASSIGNED
    1. ALL we still need testing :(
    2. edwarnicke (tentatively) to code transcriber to talk to YANG model


People present (lines said)

  1. regXboi (88)
  2. alagalah (12)
  3. Bhavesh (11)
  4. flaviof (8)
  5. mestery (5)
  6. odl_meetbot (5)
  7. adetalhouet (4)
  8. colindixon (1)


Generated by MeetBot 0.1.4.