#opendaylight-neutron: neutron_northbound

Meeting started by regXboi at 14:59:45 UTC (full logs).

Meeting summary

    1. edwarnicke (edwarnicke, 14:59:52)
    2. regXboi (regXboi, 14:59:58)
    3. flaviof (flaviof, 15:00:00)

  1. agenda bashing (folks can info in) (regXboi, 15:00:12)
    1. https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings agenda in the usual place (regXboi, 15:00:43)
    2. Bhavesh (Bhavesh, 15:00:43)

  2. action items from last meeting (regXboi, 15:02:15)
    1. https://lists.opendaylight.org/pipermail/neutron-dev/2015-April/000110.html (regXboi, 15:02:24)
    2. mestery (mestery, 15:02:32)
    3. above link floated the minihackathon trial balloon (regXboi, 15:02:38)
    4. no takers yet, so I doubt it will happen (regXboi, 15:02:51)
    5. https://git.opendaylight.org/gerrit/#/c/18356/ WIP patch for E2E testing (regXboi, 15:03:14)
    6. jenkins has +1'd it *BUT* see (regXboi, 15:03:25)
    7. http://pastebin.com/vT3hfGhy for why I'm not happy (regXboi, 15:03:38)
    8. we aren't resolving the northbound-api dependencies correctly and I'm struggling with how to make pax exam happy (regXboi, 15:04:02)
    9. adetalhouet (adetalhouet, 15:04:36)
    10. https://jenkins.opendaylight.org/releng/job/neutron-verify-master/jdk=openjdk7,nodes=dynamic_verify/138/consoleFull (regXboi, 15:09:37)
    11. https://jenkins.opendaylight.org/releng/view/neutron/job/neutron-merge-master/77/consoleFull (regXboi, 15:12:07)
    12. ACTION: edwarnicke to figure out where error in http://pastebin.com/vT3hfGhy is coming from (regXboi, 15:14:27)
    13. ACTION: adetalhouet to write documentation for how to write a consumer of the neutron yang model. edwarnicke to provide intel and guidance (regXboi, 15:14:37)
    14. ACTION: edwarnicke to scare up a resource to code transcriber to talk to YANG model (regXboi, 15:16:07)

  3. Trello Board (regXboi, 15:16:33)
    1. we have a trello board at https://trello.com/b/LhIIQ8Z0/odl-neutronnorthbound (regXboi, 15:16:47)
    2. https://trello.com/b/LhIIQ8Z0/odl-neutronnorthbound the new trello board (regXboi, 15:17:10)
    3. send email to regXboi to be added (regXboi, 15:17:27)

  4. Bug Squashing (regXboi, 15:18:02)
    1. https://bugs.opendaylight.org/buglist.cgi?list_id=27656&product=neutron&query_format=advanced&resolution=--- our outstanding bug list (regXboi, 15:18:21)
    2. we have a bunch of Tempest errors from OpenStack - mestery is rerunning them and will update (regXboi, 15:18:40)
    3. ACTION: mestery to update Tempest bugs based on reruns (regXboi, 15:18:50)
    4. some of those may be related to not getting all the neutron objects from the driver... more on that later :) (edwarnicke, 15:19:07)
    5. https://git.opendaylight.org/gerrit/#/c/18268/ patch #1 (regXboi, 15:19:24)
    6. https://git.opendaylight.org/gerrit/#/c/18272/ patch #2 (regXboi, 15:19:38)
    7. the individual bugs have trello cards if folks want to pick them up (regXboi, 15:20:44)

  5. M4 Status (regXboi, 15:21:16)
    1. last time for this topic, we're folding it all over into M5 (regXboi, 15:21:27)

  6. M5 Status (regXboi, 15:21:35)
    1. M5 for us is 4/30! (regXboi, 15:21:45)
    2. we still need the transcriber to work with YANG (thanks to edwarnicke for working with Shreshtha and co to work on that) (regXboi, 15:22:20)
    3. we'll talk about the stability branch next week (regXboi, 15:22:30)
    4. documentation, edwarnicke, I have to look to you to help adetalhouet because I know nothing of writing code to listen to Yang changes (regXboi, 15:23:12)
    5. integration and system test - if we can get the E2E test working, then I think I'm happy with this (regXboi, 15:23:35)

  7. Other Topics (regXboi, 15:23:52)
  8. Broken integration JJB job (regXboi, 15:24:03)
    1. : flaviof manually triggered build #25. I think the issue was external, and has been resolved. (https://jenkins.opendaylight.org/releng/view/neutron/job/neutron-integration-master/) (flaviof, 15:25:06)
    2. https://jenkins.opendaylight.org/releng/view/neutron/job/neutron-integration-master/ neutron integration master jjb (regXboi, 15:25:52)
    3. ACTION: flaviof to set up tempest testing for the dummyprovider to insure we get messages from neutron (regXboi, 15:27:13)

  9. switching from ML2 to plugin for ODL (regXboi, 15:27:29)
    1. ML2 mechanisum driver doesn't provide security group/rule data without mixin (regXboi, 15:27:48)
    2. plugin does (regXboi, 15:27:52)
    3. So... we discovered this week that we were not getting from the neutron ML2 driver: routers, router_interfaces, floatingips, security_groups, security_group_rules (edwarnicke, 15:28:36)
    4. mohnish figured out how to fix routers/floatingips (our L3 driver wasn't being loaded) (edwarnicke, 15:28:54)
    5. regXboi says mestery wasn't against replacement, but is looking for confirmation here :) (regXboi, 15:29:39)
    6. https://review.openstack.org/#/c/174184/ <- Kyle's fix for router_interfaces... which needs to be tested (edwarnicke, 15:30:24)
    7. and we have pointers on how to get SG and SGR working (edwarnicke, 15:30:46)
    8. https://wiki.opendaylight.org/view/Notes_on_fixing_SG_in_OS_Neutron_ML2_Driver <- notes on fixing SG and SGR in our ML2 driver (edwarnicke, 15:32:31)

  10. dark chocolate bars with guiness stout (regXboi, 15:39:24)
    1. yes, the are made by guiness (regXboi, 15:39:32)


Meeting ended at 15:40:45 UTC (full logs).

Action items

  1. edwarnicke to figure out where error in http://pastebin.com/vT3hfGhy is coming from
  2. adetalhouet to write documentation for how to write a consumer of the neutron yang model. edwarnicke to provide intel and guidance
  3. edwarnicke to scare up a resource to code transcriber to talk to YANG model
  4. mestery to update Tempest bugs based on reruns
  5. flaviof to set up tempest testing for the dummyprovider to insure we get messages from neutron


Action items, by person

  1. adetalhouet
    1. adetalhouet to write documentation for how to write a consumer of the neutron yang model. edwarnicke to provide intel and guidance
  2. edwarnicke
    1. edwarnicke to figure out where error in http://pastebin.com/vT3hfGhy is coming from
    2. adetalhouet to write documentation for how to write a consumer of the neutron yang model. edwarnicke to provide intel and guidance
    3. edwarnicke to scare up a resource to code transcriber to talk to YANG model
  3. flaviof
    1. flaviof to set up tempest testing for the dummyprovider to insure we get messages from neutron
  4. mestery
    1. mestery to update Tempest bugs based on reruns


People present (lines said)

  1. regXboi (137)
  2. edwarnicke (49)
  3. flaviof (25)
  4. mestery (15)
  5. odl_meetbot (10)
  6. adetalhouet (8)
  7. Shreshtha (3)
  8. alagalah (3)
  9. odp-gerritbot (2)
  10. Bhavesh (1)


Generated by MeetBot 0.1.4.