#opendaylight-neutron: neutron_northbound

Meeting started by regXboi at 15:00:10 UTC (full logs).

Meeting summary

    1. flaviof (flaviof, 15:00:21)
    2. regXboi (regXboi, 15:00:26)
    3. adetalhouet (adetalhouet, 15:00:29)

  1. agenda bashing (regXboi, 15:01:09)
    1. edwarnicke (edwarnicke, 15:01:32)
    2. agenda is in its usual place (regXboi, 15:01:33)
    3. https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings#Agenda_for_Next_Meeting_.285.2F1.29 meeting agenda (regXboi, 15:01:48)

  2. action items from last meeting (regXboi, 15:06:25)
    1. item 1: reminder that we have a trello board (regXboi, 15:06:43)
    2. https://trello.com/b/LhIIQ8Z0/odl-neutronnorthbound neutron northbound trello board (regXboi, 15:07:12)
    3. we also have a link on the front page with a mailto link for folks who want access (i.e. contanct me) (regXboi, 15:07:41)
    4. item 2: edwarnicke to figure out where error in http://pastebin.com/vT3hfGhy is coming from (regXboi, 15:08:04)
    5. http://pastebin.com/vT3hfGhy CORS error in karaf (regXboi, 15:08:20)
    6. edwarnicke thinks https://git.opendaylight.org/gerrit/#/c/19037/ might address this item (regXboi, 15:09:41)
    7. item 3: adetalhouet to write documentation for how to write a consumer of the neutron yang model. edwarnicke to provide intel and guidance (regXboi, 15:10:08)
    8. ACTION: all reminder that we have a trello board (regXboi, 15:11:37)
    9. ACTION: detalhouet to write documentation for how to write a consumer of the neutron yang model. (regXboi, 15:13:06)
    10. flaviof says in mestery's absense, there are issues with the devstack-ci (regXboi, 15:13:30)
    11. the way we deploy devstack-jenkins needs to mode to nodepool, so changes by the openstack comunity is automatically reflected in the vms used by jenkins (flaviof, 15:14:21)
    12. item 5: regXboi to fix tabs/whitespace on subnet patch and merge (done) (regXboi, 15:15:42)

  3. M5 status (regXboi, 15:16:28)
    1. M5 deadline for us was 4/30 (yesterday), so where are we? (regXboi, 15:16:41)
    2. no patches related to functionality in the open patch list (regXboi, 15:17:00)
    3. https://git.opendaylight.org/gerrit/#/q/status:open+project:neutron open patches (regXboi, 15:17:14)
    4. so have we achieved code freeze? (regXboi, 15:17:32)
    5. https://git.opendaylight.org/gerrit/#/c/19037/ <- appears to have fixed the moxy issue (edwarnicke, 15:18:28)
    6. and there was much rejoicing (regXboi, 15:18:44)
    7. It looks like the moxy issue as caused by controller improperly overriding odlparent for the eclipse.persistence.version (edwarnicke, 15:18:53)
    8. there are still of with classes to cover here https://trello.com/c/cxsEMMyV/5-and-support-for-yang-model-to-transcriber (regXboi, 15:19:19)
    9. we need a volunteer to cut the stable branch (regXboi, 15:20:01)
    10. ACTION: edwarnicke and regXboi to cut the stability branch once the transcriber is 100% coded (regXboi, 15:22:27)
    11. documentation isn't complete, we know that (regXboi, 15:22:46)
    12. integration and system test is also incomplete, but it looks like we may be able to move forward again on getting that done (regXboi, 15:24:06)

  4. bug squashing (regXboi, 15:24:38)
    1. https://bugs.opendaylight.org/buglist.cgi?list_id=27656&product=neutron&query_format=advanced&resolution=--- open bugs (regXboi, 15:24:48)
    2. we're going to need volunteers to help pick up and work on the outstanding bugs, so we'll likely start devoting more time to this going forward (regXboi, 15:25:16)

  5. update on https://jenkins.opendaylight.org/releng/view/neutron/job/neutron-daily-openstack-master/ (openstack CI job) (regXboi, 15:25:38)
    1. AndyG is looking into adding pip to devstack and that will hopefully fix the issue, for now (flaviof, 15:26:07)
    2. https://git.opendaylight.org/gerrit/#/c/19434/ adding pip to devstack slave in Jenkins (flaviof, 15:26:17)
    3. real fix is to use nodepool, so the vms used as devstack slave in Jenkins are closely coupled with the images used by openstack folks. (flaviof, 15:26:27)
    4. using that, it matters not what distro is used (flaviof, 15:26:53)
    5. https://gist.github.com/9afc3fd1d6d4088bb3ff background on nodepool (regXboi, 15:30:49)

  6. cookies (regXboi, 15:33:28)


Meeting ended at 15:33:31 UTC (full logs).

Action items

  1. all reminder that we have a trello board
  2. detalhouet to write documentation for how to write a consumer of the neutron yang model.
  3. edwarnicke and regXboi to cut the stability branch once the transcriber is 100% coded


Action items, by person

  1. edwarnicke
    1. edwarnicke and regXboi to cut the stability branch once the transcriber is 100% coded
  2. regXboi
    1. edwarnicke and regXboi to cut the stability branch once the transcriber is 100% coded
  3. UNASSIGNED
    1. all reminder that we have a trello board
    2. detalhouet to write documentation for how to write a consumer of the neutron yang model.


People present (lines said)

  1. regXboi (87)
  2. edwarnicke (33)
  3. flaviof (25)
  4. adetalhouet (10)
  5. odl_meetbot (7)


Generated by MeetBot 0.1.4.