#opendaylight-neutron: neutron_northbound

Meeting started by regXboi at 15:00:21 UTC (full logs).

Meeting summary

  1. roll call and agenda bashing (regXboi, 15:00:32)
    1. https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings#Agenda_for_Next_Meeting_.287.2F24.29 agenda in the usual place (regXboi, 15:00:47)
    2. edwarnicke (edwarnicke, 15:00:55)
    3. regXboi (regXboi, 15:01:09)
    4. flaviof (flaviof, 15:01:31)
    5. ACTION: regXboi to send out reminder email on Thursdays with link to draft agenda (regXboi, 15:01:49)
    6. any additions to the agenda? (regXboi, 15:02:20)

  2. action items from last meeting (regXboi, 15:03:23)
    1. 1. everybody to +1 trello cards for Be items they are willing to work on (regXboi, 15:03:35)
    2. it looks like we've got items +1'd there which is good - we can pull them into the release plan and update trello board with what we are working on in Be :) (regXboi, 15:04:25)
    3. 2. everybody to think about whether they want to volunteer to be a contact (regXboi, 15:04:38)
    4. we'll cover this more under Be :) (regXboi, 15:04:54)
    5. 3. regXboi to consult with GBP folks about bug 3968 and why they are calling isXXX() methods directly (regXboi, 15:05:03)
    6. ACTION: regXboi to consult with GBP folks about bug 3968 and why they are calling isXXX() methods directly (regXboi, 15:05:21)
    7. 4. regXboi to update meeting minutes/agenda for next week (done or we wouldn't have our agenda now would we :) (regXboi, 15:11:10)
    8. 5. NN to finalize Be feature set at 7/24 meeting (regXboi, 15:11:22)
    9. regXboi realizes he misread the schedule, so that is a false action item and dropped (regXboi, 15:12:06)
    10. 6. regXboi to update Trello Board bug list (regXboi, 15:12:19)
    11. ACTION: regXboi to update Trello Board bug list (regXboi, 15:12:42)

  3. Beryllium (regXboi, 15:13:12)
    1. M1 deadline is 7/30 (regXboi, 15:13:24)
    2. https://wiki.opendaylight.org/view/NeutronNorthbound:Beryllium_Release_Plan draft project plan (regXboi, 15:13:36)
    3. we will add items from Trello board during M1-M2 (regXboi, 15:13:49)
    4. but... we *need* a testing contact by 7/30... any volunteers (regXboi, 15:16:25)
    5. ACTION: edwarnicke to add feature dependencies to draft release plan (regXboi, 15:20:15)
    6. to folks reading this that don't see the new APIs in the draft plan - not to worry, we have until M2 to finalize, so we'll be adding APIs as we go (regXboi, 15:23:45)

  4. Deprecate GET methods (regXboi, 15:25:47)
    1. ACTION: flaviof to find out what deprecating the northbound GET methods would break (regXboi, 15:26:55)

  5. should we remove checks on incoming items (regXboi, 15:27:22)
    1. status: In process of removing what we can, and deprecating what breaks downstream for removal in Boron (regXboi, 15:27:33)
    2. for backstory, see logs of discussion between regXboi and flaviof during action items (regXboi, 15:28:03)
    3. ACTION: regXboi to update API section of release plan with statement that in Be, model should be used rather than POJOs as POJOs are not part of any contract (regXboi, 15:29:05)
    4. or won't be after I*Aware goes away (regXboi, 15:29:24)

  6. Bugs (flaviof, 15:30:34)
    1. see action item above - once regXboi gets things updated, we can review and parcel out (regXboi, 15:31:04)

  7. should we meet 7/31 or not? (regXboi, 15:31:20)
    1. summit is next week, so should we meet? (regXboi, 15:31:30)
    2. AGREED: 7/24 meeting will be replaced with session at https://wiki.opendaylight.org/view/Events:Be_Dev_Forum#ODL_Neutron_in_Beryllium (regXboi, 15:33:59)
    3. https://wiki.opendaylight.org/view/Events:Be_Dev_Forum#ODL_Neutron_in_Beryllium replacement session for 7/24 mtg (regXboi, 15:34:14)

  8. open mike (regXboi, 15:34:30)
    1. how to add extensions into the project (regXboi, 15:35:02)
    2. regXboi has looked at this and doesn't see a good solution (regXboi, 15:35:14)

  9. cookies (regXboi, 15:44:40)


Meeting ended at 15:44:43 UTC (full logs).

Action items

  1. regXboi to send out reminder email on Thursdays with link to draft agenda
  2. regXboi to consult with GBP folks about bug 3968 and why they are calling isXXX() methods directly
  3. regXboi to update Trello Board bug list
  4. edwarnicke to add feature dependencies to draft release plan
  5. flaviof to find out what deprecating the northbound GET methods would break
  6. regXboi to update API section of release plan with statement that in Be, model should be used rather than POJOs as POJOs are not part of any contract


Action items, by person

  1. edwarnicke
    1. edwarnicke to add feature dependencies to draft release plan
  2. flaviof
    1. flaviof to find out what deprecating the northbound GET methods would break
  3. regXboi
    1. regXboi to send out reminder email on Thursdays with link to draft agenda
    2. regXboi to consult with GBP folks about bug 3968 and why they are calling isXXX() methods directly
    3. regXboi to update Trello Board bug list
    4. regXboi to update API section of release plan with statement that in Be, model should be used rather than POJOs as POJOs are not part of any contract


People present (lines said)

  1. regXboi (130)
  2. flaviof (29)
  3. edwarnicke (13)
  4. odl_meetbot (9)
  5. yamahata (1)


Generated by MeetBot 0.1.4.