#opendaylight-neutron: neutron_northbound

Meeting started by regXboi at 14:59:50 UTC (full logs).

Meeting summary

  1. roll call and agenda bashing (regXboi, 15:00:02)
    1. regXboi (regXboi, 15:00:05)
    2. edwarnicke (edwarnicke, 15:00:13)
    3. flaviof (flaviof, 15:00:15)
    4. yamahata (yamahata, 15:00:19)
    5. https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings#Agenda_for_Next_Meeting_.289.2F25.29 agenda in usual place (regXboi, 15:00:24)
    6. apologies for no meeting last week - regXboi was at hematologist for daughter (regXboi, 15:01:11)
    7. john_a_joyce (john-a-joyce, 15:01:45)

  2. action items from last meeting (regXboi, 15:05:18)
    1. edwarnicke, flaviof, regXboi to look at bug 3990 (regXboi, 15:05:31)
    2. this item folds into merge/verify job instability topic later (regXboi, 15:08:31)
    3. 2. yamahata to check and comment on bug 4026 (regXboi, 15:08:39)
    4. item fixed, but dependent bug for ovsdb routemgr has been filed (regXboi, 15:09:26)
    5. 3. yamahata to add test cases to PS 26266 and 26267 (regXboi, 15:09:42)
    6. that one is done because ... (regXboi, 15:09:48)
    7. 4. regXboi to review and merge 26266 and 26267 once test cases are in place (regXboi, 15:09:55)
    8. regXboi did that one this morning :) (regXboi, 15:10:02)
    9. 5. yamahata to fix up https://git.opendaylight.org/gerrit/#/c/25500/ (regXboi, 15:10:41)
    10. this has been done and the patch is in the list for looking at later (regXboi, 15:10:56)
    11. 6. regXboi to look at adding out of order IT tests to catch other issues like bug 4188 (regXboi, 15:11:38)
    12. ACTION: regXboi to look at adding out of order IT tests to catch other issues like bug 4188 (regXboi, 15:11:51)
    13. 7. edwarnicke to work with BGPVPN and GBP projects about getting their dependency on NN into their JJB configs so that integration on merge is handled correctly (regXboi, 15:12:10)
    14. this is done - I saw the patches merge :) (regXboi, 15:12:17)
    15. 8. regXboi to schedule network to device map patch set at top of list for 9/18 meeting (regXboi, 15:12:33)
    16. ACTION: regXboi to schedule network to device map patch set at top of list for 10/2 meeting (regXboi, 15:13:01)

  3. Merge and verify Job Instability (regXboi, 15:13:11)
    1. We are seeing org.opendaylight.yangtools.binding.data.codec.impl.MissingClassInLoadingStrategyException on org.opendaylight.yangtools.binding.data.codec.impl.MissingClassInLoadingStrategyException way too much w.r.t the merge and j7 verify jobs (regXboi, 15:14:04)
    2. now, regXboi has not seen this with j8 and j7's EOL was 5/2015 (regXboi, 15:14:19)
    3. regXboi has asked colindixon if ODL is supporting j7 for Be (regXboi, 15:14:33)
    4. https://git.opendaylight.org/gerrit/27434 Change Berrylium neutron jobs to use j8 (regXboi, 15:14:45)
    5. link is pending patch .... however.... (regXboi, 15:15:27)
    6. edwarnicke thought it might have been an issue with model dependency declarations in the implementation, but sadly it was not (regXboi, 15:16:29)
    7. ACTION: flaviof, edwarnicke to use -Dkaraf.debug to see if they can get more information on this problem (regXboi, 15:19:12)
    8. to see if it is j7 specific or if it may later bite us w.r.t j8 (regXboi, 15:19:49)

  4. open patch sets (regXboi, 15:20:06)
    1. note: some of these are -1 because of the above problem :( (regXboi, 15:20:17)
    2. https://git.opendaylight.org/gerrit/#/c/24042/ reversion yang model (regXboi, 15:20:28)
    3. https://git.opendaylight.org/gerrit/24598 Addressed review comments, added remaining APIs.(Added yang, APIs, Transcriber for L2gateway) (regXboi, 15:22:42)
    4. https://git.opendaylight.org/gerrit/26711 BGPVPN: Added yang, api and transcriber for BGPVPN (regXboi, 15:24:53)
    5. https://git.opendaylight.org/gerrit/25500 Bug 4354 - neutron tenant_id doens't contain '-'(dash) (regXboi, 15:27:34)
    6. ACTION: yamahata to test https://git.opendaylight.org/gerrit/25500 with tempest and report results (regXboi, 15:29:23)
    7. https://git.opendaylight.org/gerrit/27334 - this is in merge conflict (regXboi, 15:29:55)
    8. https://identity.opendaylight.org/carbon/userprofile/index.jsp?region=region5&item=userprofiles_menu (odl-casey, 15:37:00)

  5. ML2 ODL driver rewrite (regXboi, 15:41:39)
    1. https://lists.opendaylight.org/pipermail/neutron-dev/2015-September/000368.html start of ML2 ODL driver rewrite mail thread (regXboi, 15:42:45)
    2. https://wiki.opendaylight.org/view/NeutronNorthbound:NeutronDriverOverhaul wiki page on topic (regXboi, 15:44:46)
    3. https://review.openstack.org/#/c/222409/ (asomya, 15:47:52)
    4. https://review.openstack.org/#/c/222409/ WiP networking-odl refactor patch (regXboi, 15:48:21)
    5. ACTION: regXboi to include topic in 10/2 meeting along with updated from minutes/log (regXboi, 15:51:22)
    6. discussion of refactor in meeting logs, so read there (regXboi, 15:51:45)

  6. Open Mic (regXboi, 15:52:42)
    1. https://lists.opendaylight.org/pipermail/ovsdb-dev/2015-September/002004.html (vthapar, 15:55:04)
    2. https://lists.opendaylight.org/pipermail/neutron-dev/2015-September/000405.html mail about DVR and SNAT (regXboi, 15:55:18)


Meeting ended at 16:00:00 UTC (full logs).

Action items

  1. regXboi to look at adding out of order IT tests to catch other issues like bug 4188
  2. regXboi to schedule network to device map patch set at top of list for 10/2 meeting
  3. flaviof, edwarnicke to use -Dkaraf.debug to see if they can get more information on this problem
  4. yamahata to test https://git.opendaylight.org/gerrit/25500 with tempest and report results
  5. regXboi to include topic in 10/2 meeting along with updated from minutes/log


Action items, by person

  1. edwarnicke
    1. flaviof, edwarnicke to use -Dkaraf.debug to see if they can get more information on this problem
  2. flaviof
    1. flaviof, edwarnicke to use -Dkaraf.debug to see if they can get more information on this problem
  3. regXboi
    1. regXboi to look at adding out of order IT tests to catch other issues like bug 4188
    2. regXboi to schedule network to device map patch set at top of list for 10/2 meeting
    3. regXboi to include topic in 10/2 meeting along with updated from minutes/log
  4. yamahata
    1. yamahata to test https://git.opendaylight.org/gerrit/25500 with tempest and report results


People present (lines said)

  1. regXboi (132)
  2. flaviof (37)
  3. yamahata (19)
  4. edwarnicke (18)
  5. john-a-joyce (10)
  6. vthapar (8)
  7. odl-casey (7)
  8. asomya (7)
  9. odl_meetbot (5)
  10. colindixon (1)


Generated by MeetBot 0.1.4.