#opendaylight-neutron: neutron_northbound_03_20_2015

Meeting started by regXboi at 15:04:04 UTC (full logs).

Meeting summary

  1. agend bashing and roll call (regXboi, 15:05:00)
    1. edwarnicke (edwarnicke, 15:05:12)
    2. https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings <- agenda (regXboi, 15:05:18)
    3. regXboi (regXboi, 15:05:22)
    4. flaviof added link to lithium project page (regXboi, 15:08:46)
    5. edwarnicke has polled users about VPNaaS (regXboi, 15:09:15)
    6. nobody is reporting needing neutron VPNServices for LI (edwarnicke, 15:09:19)
    7. AGREED: therefore VPNaaS will be added as yang only in Li (regXboi, 15:09:44)
    8. lest there be confusion, we *do* have the ODL VPN Services guys doing good work, just not using that neutron API this round (edwarnicke, 15:09:49)
    9. ACTION: regXboi to put together integration patch (with resource help from dfarrell07|sick) for REST unmarshalling testing of odl-neutron-service with dummy provider. (regXboi, 15:10:07)
    10. ACTION: flaviof to try to find contrail folks to work on https://git.opendaylight.org/gerrit/#/c/16161/ or escalate it to zxiiro (flaviof, 15:14:33)
    11. ACTION: edwarnicke, flaviof to review initial documentation patch and provide comments/structure for fleshing out the two sides (regXboi, 15:15:27)
    12. https://git.opendaylight.org/gerrit/#/c/16340/ initial document patch (regXboi, 15:15:40)

  2. review yang model (regXboi, 15:16:16)
    1. https://git.opendaylight.org/gerrit/#/c/15989/ <- yang model patch (regXboi, 15:16:27)
    2. reviewed doc patch (edwarnicke, 15:16:45)
    3. ACTION: regXboi to review security-groups and metering models on yang model patch (regXboi, 15:17:43)

  3. review testing (regXboi, 15:26:54)
    1. regXboi still owes patch, but wants folks to review the proposed junit strategy (regXboi, 15:27:17)
    2. https://wiki.opendaylight.org/view/NeutronNorthbound:JUnitTestStrategy <- proposed strategy (regXboi, 15:27:26)
    3. http://java.dzone.com/articles/how-test-rest-api-junit possible junit approach for rest testing (regXboi, 15:28:15)
    4. regXboi exploring above link about testing dummy provider via junit and resteasy in jjb (regXboi, 15:28:38)

  4. review documentation (regXboi, 15:37:35)
    1. https://git.opendaylight.org/gerrit/#/c/16340/ <- documentation patch (regXboi, 15:37:46)
    2. we need to start fleshing out the body of that documentation patch as M4 will look for word counts (regXboi, 15:38:10)
    3. looking for volunteers - don't have to today, but will need somebody as we get closer to M4 (regXboi, 15:38:46)

  5. M4 status items (regXboi, 15:38:57)
    1. M4 deadline for us is 4/2 - two weeks (regXboi, 15:39:31)
    2. http://docs.openstack.org/high-availability-guide/content/ch-intro.html <- a starting point on OS HA (regXboi, 15:58:43)

  6. muffins (regXboi, 16:00:05)


Meeting ended at 16:00:08 UTC (full logs).

Action items

  1. regXboi to put together integration patch (with resource help from dfarrell07|sick) for REST unmarshalling testing of odl-neutron-service with dummy provider.
  2. flaviof to try to find contrail folks to work on https://git.opendaylight.org/gerrit/#/c/16161/ or escalate it to zxiiro
  3. edwarnicke, flaviof to review initial documentation patch and provide comments/structure for fleshing out the two sides
  4. regXboi to review security-groups and metering models on yang model patch


Action items, by person

  1. dfarrell07
    1. regXboi to put together integration patch (with resource help from dfarrell07|sick) for REST unmarshalling testing of odl-neutron-service with dummy provider.
  2. edwarnicke
    1. edwarnicke, flaviof to review initial documentation patch and provide comments/structure for fleshing out the two sides
  3. flaviof
    1. flaviof to try to find contrail folks to work on https://git.opendaylight.org/gerrit/#/c/16161/ or escalate it to zxiiro
    2. edwarnicke, flaviof to review initial documentation patch and provide comments/structure for fleshing out the two sides
  4. regXboi
    1. regXboi to put together integration patch (with resource help from dfarrell07|sick) for REST unmarshalling testing of odl-neutron-service with dummy provider.
    2. regXboi to review security-groups and metering models on yang model patch
  5. zxiiro
    1. flaviof to try to find contrail folks to work on https://git.opendaylight.org/gerrit/#/c/16161/ or escalate it to zxiiro


People present (lines said)

  1. regXboi (124)
  2. edwarnicke (43)
  3. flaviof (23)
  4. odl_meetbot (7)
  5. kkoushik_ (7)
  6. Gaurav_ (4)
  7. alagalah_ (3)
  8. zxiiro (2)
  9. odp-gerritbot (1)
  10. dfarrell07 (1)
  11. fflaviof (0)


Generated by MeetBot 0.1.4.