#opendaylight-neutron: neutron_northbound_03_27_2015

Meeting started by regXboi at 14:59:44 UTC (full logs).

Meeting summary

  1. roll call and agenda bashing (regXboi, 15:00:13)
    1. regXboi (regXboi, 15:00:22)
    2. edwarnicke (edwarnicke, 15:01:53)
    3. Bhavesh (Bhavesh, 15:02:03)
    4. https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings#Agenda_for_Next_Meeting_.283.2F27.29 Today's agenda (regXboi, 15:02:38)

  2. action items from last meeting (regXboi, 15:04:08)
    1. ACTION: regXboi to put together integration patch (with resource help from dfarrell07|sick) for REST unmarshalling testing of odl-neutron-service with dummy provider. (regXboi, 15:05:03)
    2. flaviof escalated the contrail merge issue to Thanh and Phil (regXboi, 15:05:24)
    3. https://git.opendaylight.org/gerrit/#/c/16340/ documentation patch in question (regXboi, 15:05:58)
    4. ACTION: edwarnicke, flaviof to review initial documentation patch and provide comments/structure for fleshing out the two sides (regXboi, 15:06:15)
    5. regXboi reviewed security-groups and metering models on yang model patch (regXboi, 15:06:44)

  3. M4 (regXboi, 15:06:56)
    1. M4 deadline is 4/2 (regXboi, 15:07:54)

  4. M4/API Freeze (regXboi, 15:08:46)
    1. yang model patch is merged (regXboi, 15:09:24)
    2. edwarnicke has tree structure topic to discuss (regXboi, 15:09:35)
    3. kkoushik (kkoushik__, 15:10:57)
    4. edwarnicke points out that each neutron object is being put at the top level of the model tree (regXboi, 15:11:54)
    5. while logically ther aren't global, they are scoped under neutron (regXboi, 15:12:13)
    6. so edwarnicke is proposing that we should actually scope them in the model tree under a neutron container (regXboi, 15:12:34)
    7. regXboi asks about the implication of splitting models that include augmentations :) (regXboi, 15:12:58)
    8. https://git.opendaylight.org/gerrit/17243 first go at this patch (regXboi, 15:14:13)
    9. ACTION: everybody to review https://git.opendaylight.org/gerrit/17243 and provide comments (regXboi, 15:14:50)
    10. yang also requires *aaS models (regXboi, 15:16:42)
    11. kkoushik__ has started LBaaS (regXboi, 15:16:50)
    12. the spi tree needs to catch up with the yang model (regXboi, 15:19:01)
    13. the nb tree needs methods for any new objects added to the spi tree (regXboi, 15:19:15)
    14. the transcriber tree needs to write into the yang model (regXboi, 15:19:26)
    15. and looking for volunteers for all of these (regXboi, 15:19:36)
    16. thanks for flaviof for rebasing the IPv6 patch from controller over to neutron - its merged in and that should help with the tempest testing (regXboi, 15:21:42)
    17. https://git.opendaylight.org/gerrit/#/q/project:neutron+status:open current open patches (regXboi, 15:22:07)

  5. M4/documentation (regXboi, 15:22:38)
    1. https://git.opendaylight.org/gerrit/#/c/16340/ updated documentation (regXboi, 15:23:00)
    2. We really need a volunteer for the YANG model piece of this (regXboi, 15:23:17)
    3. ACTION: regXboi to address colindixon review comments on the documenation patch (regXboi, 15:23:31)

  6. M4/Maven Central (regXboi, 15:24:19)
    1. http://central.sonatype.org/pages/requirements.html requirements for maven central (regXboi, 15:24:32)
    2. ACTION: edwarnicke to align pom with requriements from http://central.sonatype.org/pages/requirements.html#sufficient-metadata (regXboi, 15:26:52)

  7. M4/integration and system test (regXboi, 15:27:29)
    1. ACTION: flaviof to work karaf system test for merge, integration, and RC events (regXboi, 15:29:18)
    2. ACTION: Shreshtha_ to put together junit testing for some apis this week (regXboi, 15:29:49)
    3. the junit strategy documented on https://wiki.opendaylight.org/view/NeutronNorthbound:JUnitTestStrategy has been implemented (regXboi, 15:30:25)

  8. namespace ugliness in network junit/jaxb test (regXboi, 15:31:46)
    1. https://git.opendaylight.org/gerrit/#/c/17078/ patch in question (regXboi, 15:34:03)
    2. regXboi points out that this patch makes a change to how namespaces are handled in jaxb (regXboi, 15:34:27)
    3. because he has been unable to get namespace registration to work with jersey's stock jsonjaxb unmarshaller (regXboi, 15:34:49)
    4. so he only sees two options at this point: (1) pull out moxy and hardcode full attributes names (with namespace embedded) (regXboi, 15:35:14)
    5. or (2) pull moxy into the junit testing (regXboi, 15:35:24)
    6. ACTION: regXboi to rebase https://git.opendaylight.org/gerrit/#/c/17078/ and look at pulling MOXy out (regXboi, 15:38:51)

  9. marking FWaaS classes and interfaces as deprecated patch (regXboi, 15:39:19)
    1. https://git.opendaylight.org/gerrit/#/c/16150/ (regXboi, 15:39:30)

  10. open discussion (regXboi, 15:40:28)
    1. regXboi wonders if we need to schedule mini-hackathon IRC meetings and hangouts more frequently to increase velocity (regXboi, 15:41:12)
    2. ACTION: regXboi to float mini-hackathon trial ballong to mailing list (regXboi, 15:42:37)

  11. muffins (regXboi, 15:44:58)


Meeting ended at 15:45:03 UTC (full logs).

Action items

  1. regXboi to put together integration patch (with resource help from dfarrell07|sick) for REST unmarshalling testing of odl-neutron-service with dummy provider.
  2. edwarnicke, flaviof to review initial documentation patch and provide comments/structure for fleshing out the two sides
  3. everybody to review https://git.opendaylight.org/gerrit/17243 and provide comments
  4. regXboi to address colindixon review comments on the documenation patch
  5. edwarnicke to align pom with requriements from http://central.sonatype.org/pages/requirements.html#sufficient-metadata
  6. flaviof to work karaf system test for merge, integration, and RC events
  7. Shreshtha_ to put together junit testing for some apis this week
  8. regXboi to rebase https://git.opendaylight.org/gerrit/#/c/17078/ and look at pulling MOXy out
  9. regXboi to float mini-hackathon trial ballong to mailing list


Action items, by person

  1. edwarnicke
    1. edwarnicke, flaviof to review initial documentation patch and provide comments/structure for fleshing out the two sides
    2. edwarnicke to align pom with requriements from http://central.sonatype.org/pages/requirements.html#sufficient-metadata
  2. flaviof
    1. edwarnicke, flaviof to review initial documentation patch and provide comments/structure for fleshing out the two sides
    2. flaviof to work karaf system test for merge, integration, and RC events
  3. regXboi
    1. regXboi to put together integration patch (with resource help from dfarrell07|sick) for REST unmarshalling testing of odl-neutron-service with dummy provider.
    2. regXboi to address colindixon review comments on the documenation patch
    3. regXboi to rebase https://git.opendaylight.org/gerrit/#/c/17078/ and look at pulling MOXy out
    4. regXboi to float mini-hackathon trial ballong to mailing list
  4. Shreshtha_
    1. Shreshtha_ to put together junit testing for some apis this week


People present (lines said)

  1. regXboi (134)
  2. edwarnicke (30)
  3. flaviof (12)
  4. kkoushik__ (5)
  5. odl_meetbot (5)
  6. Shreshtha_ (5)
  7. odp-gerritbot (4)
  8. shreshtha (1)
  9. Bhavesh (1)


Generated by MeetBot 0.1.4.