#opendaylight-neutron: neutron_northbound_2015_03_13

Meeting started by regXboi at 15:00:22 UTC (full logs).

Meeting summary

  1. agenda bashing (regXboi, 15:00:42)
    1. https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings agenda (regXboi, 15:00:51)
    2. flaviof (flaviof, 15:02:35)

  2. cover action items (regXboi, 15:04:01)
    1. flaviof checked all uses of neutron and sent email (flaviof, 15:04:35)
    2. ACTION: flaviof to add link in Lithium project page on the info for migrating projects to the new neutron repo (flaviof, 15:07:20)
    3. https://wiki.opendaylight.org/view/NeutronNorthbound:Lithium_Release_Plan#User_Facing_Karaf_Features_List <- list of karaf features (regXboi, 15:07:40)
    4. https://git.opendaylight.org/gerrit/#/c/16340/ <- initial document commit (regXboi, 15:08:31)
    5. https://git.opendaylight.org/gerrit/#/c/16155/ <- dummy provider code (regXboi, 15:09:33)
    6. https://git.opendaylight.org/gerrit/#/c/15989/ <- yang model (regXboi, 15:10:31)
    7. https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings <- meeting wiki page (regXboi, 15:14:47)

  3. Yang Model (regXboi, 15:14:53)
    1. ACTION: edwarnicke to poll users of neutron to see if any (other than VPN services) are looking to use Neutron VPNaaS in the Li timeframe (regXboi, 15:30:03)
    2. https://lists.opendaylight.org/pipermail/neutron-dev/2015-March/000048.html list of neutron dependencies (regXboi, 15:32:16)
    3. we still need neutron-security-groups (security groups and rules) (regXboi, 15:33:51)
    4. we still need neutron-metering (metering labels and rules) (regXboi, 15:34:02)
    5. we still need neutron-lbaas (LBaaS v2.0) (regXboi, 15:34:10)

  4. testing (regXboi, 15:34:18)
    1. https://wiki.opendaylight.org/view/NeutronNorthbound:JUnitTestStrategy <- wiki page on JUnit testing strategy for more complex cases (regXboi, 15:37:50)
    2. ACTION: regXboi to put together integration patch (with resource help from dfarrell07|sick) for REST unmarshalling testing of odl-neutron-service with dummy provider. (regXboi, 15:56:39)

  5. documentation (regXboi, 15:57:15)
    1. https://git.opendaylight.org/gerrit/#/c/16340/ <- intiial documentation link (regXboi, 15:57:51)
    2. ACTION: edwarnicke, flaviof to review initial documentation patch and provide comments/structure for fleshing out the two sides (regXboi, 15:58:53)

  6. cookies (regXboi, 16:00:09)


Meeting ended at 16:00:12 UTC (full logs).

Action items

  1. flaviof to add link in Lithium project page on the info for migrating projects to the new neutron repo
  2. edwarnicke to poll users of neutron to see if any (other than VPN services) are looking to use Neutron VPNaaS in the Li timeframe
  3. regXboi to put together integration patch (with resource help from dfarrell07|sick) for REST unmarshalling testing of odl-neutron-service with dummy provider.
  4. edwarnicke, flaviof to review initial documentation patch and provide comments/structure for fleshing out the two sides


Action items, by person

  1. dfarrell07|sick
    1. regXboi to put together integration patch (with resource help from dfarrell07|sick) for REST unmarshalling testing of odl-neutron-service with dummy provider.
  2. edwarnicke
    1. edwarnicke to poll users of neutron to see if any (other than VPN services) are looking to use Neutron VPNaaS in the Li timeframe
    2. edwarnicke, flaviof to review initial documentation patch and provide comments/structure for fleshing out the two sides
  3. flaviof
    1. flaviof to add link in Lithium project page on the info for migrating projects to the new neutron repo
    2. edwarnicke, flaviof to review initial documentation patch and provide comments/structure for fleshing out the two sides
  4. regXboi
    1. regXboi to put together integration patch (with resource help from dfarrell07|sick) for REST unmarshalling testing of odl-neutron-service with dummy provider.


People present (lines said)

  1. regXboi (140)
  2. edwarnicke (49)
  3. flaviof (20)
  4. kkoushik_ (14)
  5. dfarrell07|sick (11)
  6. mestery (5)
  7. odl_meetbot (4)
  8. odp-gerritbot (1)


Generated by MeetBot 0.1.4.