#opendaylight-nic: #NIC

Meeting started by adetalhouet at 15:01:45 UTC (full logs).

Meeting summary

  1. New team members (adetalhouet, 15:04:50)
    1. Welcome to new developers (adetalhouet, 15:05:04)
    2. Gastuvo from Brazil (adetalhouet, 15:05:33)
    3. Anitha from the bay (HP) (adetalhouet, 15:05:53)

  2. M1 status puclished (adetalhouet, 15:06:58)
    1. https://wiki.opendaylight.org/view/NIC:Beryllium:Release_Plan (adetalhouet, 15:07:41)

  3. M2 planning (adetalhouet, 15:07:59)
    1. support for default action (adetalhouet, 15:08:38)
    2. ACTION: raphaelamorim and his team about to push patches for that (adetalhouet, 15:08:54)
    3. graph-based intent internal representation (adetalhouet, 15:09:33)
    4. gvrangan ask for exemple (adetalhouet, 15:12:38)
    5. ACTION: raphaelamorim to send some use case for graph based intent internal representation (adetalhouet, 15:13:13)
    6. Mapping service keeps track of EP, network event, basically keep track of everything (adetalhouet, 15:14:11)
    7. Mapping service allows to have the detail we do care about (adetalhouet, 15:16:34)
    8. gvrangan ask how the Mapping service will fit in (adetalhouet, 15:17:10)
    9. dlenrow advice to read to draft about that (adetalhouet, 15:17:24)
    10. mail thread regarding the draft https://lists.opendaylight.org/pipermail/nic-dev/2015-July/000837.html (adetalhouet, 15:19:47)
    11. ACTION: raphaelamorim to create a use case to present the ONF definition of the Mapping Service and to provide what needs to be done in NIC (adetalhouet, 15:23:02)
    12. ACTION: raphaelamorim to add cards in the trello board about Mapping service to help folks jump in (adetalhouet, 15:23:54)
    13. colindixon says a mapping of Neutron into Nic could be really useful (adetalhouet, 15:24:39)
    14. talking about the Neutron service of ODL - to add the abstract Neutron model on the abstract NIC model (adetalhouet, 15:25:23)
    15. doesn't need to be a perfect one to one mapping but we need to understand/know where we stand (adetalhouet, 15:26:09)
    16. raphaelamorim says the graph will be a separate module, kind of an improved version of the intent compiler bundle (adetalhouet, 15:28:34)
    17. for M2 we still have 18 days - Mapping service should be there by this deadline, at least the beginning of its implementation (adetalhouet, 15:29:58)
    18. Graph-based intent should also fit in M2 (adetalhouet, 15:30:30)
    19. raphaelamorim says Boulder project could bring folks to ODL - thinks it's a good idea (adetalhouet, 15:33:44)
    20. dlenrow says in BE timeframe ONOS guy should use also the Boulder (adetalhouet, 15:34:09)
    21. dlenrow says Boulder should be controller agnostic (adetalhouet, 15:34:21)
    22. https://github.com/OpenNetworkingFoundation/BOULDER-Intent-NBI (adetalhouet, 15:35:40)

  4. open mic (adetalhouet, 15:39:09)
  5. cookies (adetalhouet, 15:39:18)


Meeting ended at 15:39:25 UTC (full logs).

Action items

  1. raphaelamorim and his team about to push patches for that
  2. raphaelamorim to send some use case for graph based intent internal representation
  3. raphaelamorim to create a use case to present the ONF definition of the Mapping Service and to provide what needs to be done in NIC
  4. raphaelamorim to add cards in the trello board about Mapping service to help folks jump in


Action items, by person

  1. raphaelamorim
    1. raphaelamorim and his team about to push patches for that
    2. raphaelamorim to send some use case for graph based intent internal representation
    3. raphaelamorim to create a use case to present the ONF definition of the Mapping Service and to provide what needs to be done in NIC
    4. raphaelamorim to add cards in the trello board about Mapping service to help folks jump in


People present (lines said)

  1. adetalhouet (47)
  2. odl_meetbot (9)
  3. colindixon (2)
  4. raphaelamorim (0)


Generated by MeetBot 0.1.4.