#opendaylight-nic: NIC

Meeting started by adetalhouet at 15:01:12 UTC (full logs).

Meeting summary

    1. gzhao (gzhao, 15:02:39)

  1. M2 Status / Release Planning (adetalhouet, 15:02:47)
    1. Initial planning is done (adetalhouet, 15:03:18)
    2. Now we have 2 millstones to accomplish the features (adetalhouet, 15:03:34)
    3. https://lists.opendaylight.org/pipermail/nic-dev/2015-September/000878.html (raphaelamorim_, 15:05:12)
    4. release plan https://wiki.opendaylight.org/view/NIC:Beryllium:Release_Plan (adetalhouet, 15:06:29)
    5. renato_aguiar (renato_aguiar, 15:07:41)

  2. Community goals for NIC (adetalhouet, 15:09:53)
    1. reviewing the trello board (adetalhouet, 15:12:01)
    2. OF Renderer is almost done, a few review to address (adetalhouet, 15:12:13)
    3. Lot of items in the backlogs, please pick one and start working on it :) (adetalhouet, 15:13:35)
    4. dlenrow added 2 proposed goals on the Main page (adetalhouet, 15:14:55)
    5. dlenrow hope we can plan work on those 2 goals (adetalhouet, 15:16:20)
    6. Are we agree with the proposed goals? (adetalhouet, 15:16:49)
    7. 1st goal: Solve the problem of resource contention between disparate ODL apps/services (adetalhouet, 15:17:07)
    8. mlemay asking how it does fit with the extension of OFP, ... (adetalhouet, 15:18:10)
    9. ACTION: mlemay to send thread on discussions around this (adetalhouet, 15:18:42)
    10. Should we solve multiple writer in NIC? (adetalhouet, 15:19:17)
    11. mlemay say it might be an issue (adetalhouet, 15:19:26)
    12. Let's have a conversation around the layers where the conflict could happen (adetalhouet, 15:20:33)
    13. dlenrow says NIC is the common arbitration layer (adetalhouet, 15:22:12)
    14. 2nd goal: Provide a controller based, performant, easy to deploy (adetalhouet, 15:22:51)
    15. make the netvirt implementation coexist between the various SDN services (adetalhouet, 15:23:34)
    16. dlenrow would like NIC to do what NN does conceptually to handle better OpenStack (adetalhouet, 15:24:54)
    17. colindixon said, "I think that no matter how much we feel like everyone should go through NIC, there will be people who don't and they *will* solve their conflicts in some way at a lower layer." (helenchen, 15:25:11)
    18. mlemay mentioned that there is a lot of discussion around rewriting the plugin for OpenStack (adetalhouet, 15:26:55)
    19. gzhao asks if we're going to maintain Boulder? (adetalhouet, 15:27:45)
    20. dlenrow says it's a use case the world would be really interested in (adetalhouet, 15:28:00)
    21. raphaelamorim says that this is one of the BE deliverable (adetalhouet, 15:28:37)
    22. we need folks to invest time in its implementation (adetalhouet, 15:29:02)
    23. Boulder could help to make people being engaged in ODL-NIC (adetalhouet, 15:29:59)
    24. mlemay says that Boulder allow you to script the Intent (adetalhouet, 15:30:21)
    25. mlemay says Boulder is a scripting layer on top of NIC (adetalhouet, 15:30:45)
    26. raphaelamorim says this allow for SDN controller to have a common NB interface (adetalhouet, 15:32:10)
    27. ACTION: start the discussion on the ML (adetalhouet, 15:33:43)
    28. raphaelamorim says the 2 goals presented by dlenrow are in accordance with the current release planning (adetalhouet, 15:34:44)
    29. dlenrow says those 2 goals are the based principles of NIC project, and this is normal to address them (adetalhouet, 15:35:51)
    30. raphaelamorim says that even in the Neutron community, they are ready to discuss about skipping the NB interface and going directly into MD-SAL (adetalhouet, 15:36:25)
    31. ACTION: raphaelamorim to provide pointers about that (adetalhouet, 15:38:19)
    32. gvrangan_ says this is pretty much abstract and would like us to discuss around this (adetalhouet, 15:39:09)
    33. dlenrow says that we will discuss the design as a community (adetalhouet, 15:39:27)
    34. raphaelamorim mentioned that there are also bunch of stuff that need to be done to maintain the Intent, how they are manage, resolve, .. (adetalhouet, 15:40:49)
    35. raphaelamorim says that it would be nice to have tasks that add value to both NIC and surrounding project (adetalhouet, 15:41:46)
    36. raphaelamorim referring to the 2nd goals (adetalhouet, 15:42:07)
    37. raphaelamorim presents the sample renderer: it aims it to make folks who want to create their renderer to have an exemple to start with (adetalhouet, 15:44:32)
    38. raphaelamorim says this won't be part of the NIC features (adetalhouet, 15:44:53)
    39. it's a really open/abstract implementation (adetalhouet, 15:45:53)
    40. An H asks if renderer should resides in NIC or outside NIC (adetalhouet, 15:46:22)
    41. raphaelamorim says all renderer should be in NIC (adetalhouet, 15:46:32)
    42. dlenrow takes a concrete exemple with Netvirt: we don't want to build a new one, we want to leverage the one from the OVSDB project (adetalhouet, 15:47:55)
    43. dlenrow asks if we should have another meeting the discuss issues around bringing NN and OVSDB into NIC (adetalhouet, 15:48:54)
    44. raphaelamorim says it's a good idea (adetalhouet, 15:49:18)
    45. ACTION: dlenrow to send a mail to the list (adetalhouet, 15:50:07)

  3. cookies (adetalhouet, 15:50:25)


Meeting ended at 15:50:30 UTC (full logs).

Action items

  1. mlemay to send thread on discussions around this
  2. start the discussion on the ML
  3. raphaelamorim to provide pointers about that
  4. dlenrow to send a mail to the list


Action items, by person

  1. dlenrow
    1. dlenrow to send a mail to the list
  2. raphaelamorim
    1. raphaelamorim to provide pointers about that
  3. UNASSIGNED
    1. mlemay to send thread on discussions around this
    2. start the discussion on the ML


People present (lines said)

  1. adetalhouet (63)
  2. odl_meetbot (10)
  3. colindixon (3)
  4. helenchen (2)
  5. gzhao (1)
  6. renato_aguiar (1)
  7. raphaelamorim_ (1)
  8. dlenrow (1)
  9. raphaelamorim (0)


Generated by MeetBot 0.1.4.