#opendaylight-nic: nic_weekly
Meeting started by tbachman at 16:09:29 UTC
(full logs).
Meeting summary
- project culter (tbachman, 16:09:59)
  - dbainbri (dbainbri,
    16:10:03)
 
  - project culture is to use Trello for managing
    and tracking tasks (tbachman,
    16:10:30)
 
 
- Project Release Plane (tbachman, 16:11:35)
  - devond says we need to elect the project
    lead (tbachman,
    16:11:51)
 
  - devond asks if this is the right time to call
    for the election (tbachman,
    16:12:01)
 
  - dbainbri says we should do it on the mailing
    list (tbachman,
    16:12:13)
 
  - phrobb says to send mail asking for
    self-nominations (tbachman,
    16:12:21)
 
  - phrobb  says the condorcet web site is used for
    the election process (tbachman,
    16:12:45)
 
  - devond is the project contact (tbachman,
    16:12:53)
 
  - ACTION: devond to
    send mail for self nominations (phrobb,
    16:13:00)
 
  - devond asks how to approach the test
    contact (tbachman,
    16:13:15)
 
  - hideyuki says there’s not official process to
    elect a test contact (tbachman,
    16:13:43)
 
  - phrobb says the only elected position is the
    project lead; everything else is by appointment by the
    project (tbachman,
    16:13:58)
 
  - phrobb says the test and doc contacts work with
    the respective teams in ODL (e.g. integration and docs) (tbachman,
    16:14:21)
 
  - ACTION: devond to
    work with Project Lead, once elected, to get test and doc
    contacts (tbachman,
    16:15:11)
 
  - gzhao asks about the nic project dependencies —
    do we need the controller for the MD-SAL SFC pieces? (tbachman,
    16:15:53)
 
  - https://wiki.opendaylight.org/view/Network_Intent_Composition:Lithium_Release_Plan
    Lithim release plan for the NIC project (tbachman,
    16:16:34)
 
  - dbainbri says it should be yangtools and the
    controller for the dependency (tbachman,
    16:17:32)
 
  - gzhao says you list everything you need, and if
    there are new features needed, you need to make requests of those
    projects (tbachman,
    16:18:19)
 
  - ACTION: devond says
    he will do the legwork to manage the dependencies (tbachman,
    16:19:38)
 
  - dependencies to be added are yangtools,
    ofplugin, and the controller (tbachman,
    16:19:53)
 
  - devond asks if AAA is a dependency (tbachman,
    16:20:00)
 
  - team says no (tbachman,
    16:20:06)
 
  - hideyuki says he doesn’t understand the
    difference between prototype and ONF-SFC (tbachman,
    16:20:33)
 
  - hideyuki plans to implement a prototype, and
    would like to know the difference between them (tbachman,
    16:20:53)
 
  - ShaunWackerly says the ONF-SFC prototype was
    specifically what dlenrow and Cathy had spoken to on the mailing
    list — a well defined prototype (tbachman,
    16:21:41)
 
  - ShaunWackerly says they also plan to do some
    prototyping outside of the ONF-SFC as well (tbachman,
    16:21:54)
 
  - The prototyping selected components was
    starting implementation of the high level design we come up
    with (ShaunWackerly,
    16:23:19)
 
  - It would be unrelated to the ONF SFC. ONF SFC
    was described earlier as a dead-end branch. (ShaunWackerly,
    16:23:46)
 
  - dmentze describes that non-ONF prototyping
    would be the building blocks for a long-term NIC solution
    (ShaunWackerly,
    16:24:15)
 
  - devond asks if we should edit the wiki to get
    rid of the confusion around prototype (tbachman,
    16:25:15)
 
  - gzhao says yes (tbachman,
    16:25:19)
 
  - dmentze says that we need input from dlenrow
    about the differences (ShaunWackerly,
    16:25:44)
 
  - hideyuki asks if he should add a VTN prototype
    to the list, that's what he plans on working on (ShaunWackerly,
    16:27:13)
 
  - dmentze says that will hopefully be included
    under the general prototyping item (ShaunWackerly,
    16:27:34)
 
  - dmentze says that the team should discuss
    architecture well enough to be able to have a prototyped framework
    that works for all (ShaunWackerly,
    16:28:25)
 
  - ACTION: dlenrow has
    been asked (by devond) to give a fuller description of the scope of
    the ONF SFC prototype (ShaunWackerly,
    16:29:59)
 
  - devond asks if we need to update themes to
    reflect other items (ShaunWackerly,
    16:33:51)
 
  - dmentze suggests we add one item to reflect the
    high level priorities (ShaunWackerly,
    16:34:08)
 
  - dmentze says that we’ve got work going on with
    the model; use case work can progress from that (tbachman,
    16:36:00)
 
  - uchau asks if we should do f2f meetings
    (tbachman,
    16:37:04)
 
  - dbainbri says if we can get this all done in
    one week that’s great; depends on feedback for use cases
    (tbachman,
    16:38:08)
 
  - dbainbri says we can use email and the wiki, so
    that it’s documented in an easy to find place (tbachman,
    16:38:21)
 
  - ShaunWackerly asks if we can use email and post
    outcomes on the wiki? (tbachman,
    16:38:53)
 
  - ShaunWackerly says we can tag emails for use
    cases, so we can record a discussion per use case (tbachman,
    16:39:10)
 
  - dbainbri says that makes sense, as long as we
    identify the individual who’s going to document it (tbachman,
    16:39:23)
 
  - phrobb says we don’t typically do that kind of
    commenting on the wiki, but etherpad is available for such
    things (tbachman,
    16:39:44)
 
  - AGREED: will use
    email, tag use cases in the email, and document on the wiki
    (tbachman,
    16:40:02)
 
  - devond would like to have this done by next
    week; may prompt need for f2f meetings the following week
    (tbachman,
    16:40:26)
 
  - ShaunWackerly proposed some changes to the
    model; wonders if we’re suspending any model changes while we
    discuss use cases (tbachman,
    16:40:50)
 
  - dbainbri says we should do both at the same
    time (tbachman,
    16:41:26)
 
  - Helen asks if the current use cases are
    documented? (tbachman,
    16:41:51)
 
  - ShaunWackerly asks if Helen asks to discuss
    things on email, propose markups on etherpad or gdoc, and put
    results on wiki (tbachman,
    16:43:57)
 
  - Helen says that’s correct (tbachman,
    16:44:01)
 
  - dbainbri prefers first #agreed — do email, then
    take to wiki (tbachman,
    16:44:31)
 
  - devond asks if Helen is okay with the first
    approach (tbachman,
    16:44:39)
 
  - Helen says that’s okay — just finds it hard
    following all the emails (tbachman,
    16:44:50)
 
  - dbainbri agres it would be nice to have a tool
    for more focused discussion (tbachman,
    16:45:22)
 
  - ShaunWackerly asks that folks change the email
    thread name if the thread changes (e.g. per use case) (tbachman,
    16:47:32)
 
  - dmentze proposes a special meeting to discuss
    use cases, like uchau proposed f2f (ShaunWackerly,
    16:48:29)
 
  - ShaunWackerly asks if we want to talk about
    src/destinations split and other items (tbachman,
    16:50:40)
 
  - dbainbri submitted another patch about desired
    network state (tbachman,
    16:51:08)
 
  - dbainbri wonders if it makes sense for an
    intent to have src/dest, and policy with src/dst and dst/src
    (tbachman,
    16:51:37)
 
  - ShaunWackerly says that atomicity could be
    handled by grouping or some kind of ID in policies (ShaunWackerly,
    16:57:16)
 
  - dbainbri says that might move complexity from
    one area to another (ShaunWackerly,
    16:57:31)
 
  - dmentze asks if we need to solve the atomicity
    issue (ShaunWackerly,
    16:57:44)
 
  - dmentze proposes that different policies in
    each direction should be two separate intents (ShaunWackerly,
    16:59:41)
 
  - dbainbri points out that this would need 2
    intents per bidirectional connection (ShaunWackerly,
    17:00:07)
 
  - dmentze says we should talk more use
    cases (ShaunWackerly,
    17:00:26)
 
  - dbainbri referred to an email that LouisF sent,
    where he identified all of the different options for A,B,C
    policies (ShaunWackerly,
    17:01:20)
 
 
Meeting ended at 17:02:12 UTC
(full logs).
Action items
  - devond to send mail for self nominations
 
  - devond to work with Project Lead, once elected, to get test and doc contacts
 
  - devond says he will do the legwork to manage the dependencies
 
  - dlenrow has been asked (by devond) to give a fuller description of the scope of the ONF SFC prototype
 
Action items, by person
  -  devond 
    - devond to send mail for self nominations
 
    - devond to work with Project Lead, once elected, to get test and doc contacts
 
    - devond says he will do the legwork to manage the dependencies
 
    - dlenrow has been asked (by devond) to give a fuller description of the scope of the ONF SFC prototype
 
  
 
People present (lines said)
  - tbachman (107)
 
  - ShaunWackerly (36)
 
  - odl_meetbot (9)
 
  - dbainbri (4)
 
  - phrobb (3)
 
  - uchau (3)
 
  - gzhao (2)
 
  - devond (1)
 
Generated by MeetBot 0.1.4.