#opendaylight-nic: nic_weekly

Meeting started by tbachman at 16:02:11 UTC (full logs).

Meeting summary

  1. agenda (tbachman, 16:02:24)
    1. https://meetings.opendaylight.org/opendaylight-nic/2015/nic_weekly/opendaylight-nic-nic_weekly.2015-02-06-16.09.html Minutes from last week’s meeting (tbachman, 16:02:43)
    2. Agenda: PTL Election; Clarify SFC prototype in release plan; thread discussions (tbachman, 16:03:29)
    3. agenda item: how to keep pressing key topics (tbachman, 16:04:34)

  2. PTL Election (tbachman, 16:04:41)
    1. ShaunWackerly1 (ShaunWackerly1, 16:05:34)
    2. dbainbri (dbainbri, 16:05:37)
    3. devond (devond, 16:05:42)
    4. dmentze (dmentze, 16:05:45)
    5. tbachman (tbachman, 16:05:47)
    6. alagalah (alagalah, 16:05:53)
    7. gzhao (gzhao, 16:05:56)
    8. devond says last call for PTL election (ShaunWackerly1, 16:06:09)
    9. devond has pulled his election nomination for PTL; dmentze has added his (tbachman, 16:06:24)
    10. current nominations are dbainbri and dmentze (tbachman, 16:06:31)
    11. ShaunWackerly1 asks how long the election should take (tbachman, 16:06:50)
    12. election period will last for 1 week (ShaunWackerly1, 16:06:51)
    13. https://wiki.opendaylight.org/view/CondorcetElection4PTLs Wiki page showing how to setup PTL elections (tbachman, 16:07:51)
    14. devond asks what the criteria is to add committers (tbachman, 16:08:11)
    15. phrobb says that it requires contributions to the project, and project votes on whether to add the committer, then brings this to the TSC (tbachman, 16:08:32)

  3. Clarify SFC Prototype in release plan (tbachman, 16:08:47)
    1. devond asks if anyone aside from dlenrow can speak to this (tbachman, 16:09:21)
    2. dmentze says we’ll probably need dlenrow for this (tbachman, 16:09:32)
    3. ACTION: devond says he’ll contact dlenrow to get him at the next meeting to discuss (tbachman, 16:09:52)

  4. How to keep pressing forward on key topics (ShaunWackerly1, 16:10:31)
    1. devond suggests options like f2f meetings or more frequent webex (ShaunWackerly1, 16:11:11)
    2. dbainbri says f2f would be ideal, but non-local people would need a way to be involved (ShaunWackerly1, 16:11:38)
    3. mlemay asks if anyting from ONF meeting will be included in our NIC project (ShaunWackerly1, 16:12:08)
    4. dbainbri says ONF has lots of interest in intent, but some things need clarified in terms of how ONF will work on intent (ShaunWackerly1, 16:12:35)
    5. dbainbri says subgroups are looking at models, should be looked at and pulled in (ShaunWackerly1, 16:13:40)
    6. devond asks if we can identify some key topics to focus on (ShaunWackerly1, 16:14:06)
    7. dbainbri suggests "endpoint" definition, SFC (ShaunWackerly1, 16:14:18)
    8. dmentze suggests multi-writer and multi-api, and the difference between them (ShaunWackerly1, 16:14:42)
    9. dmentze says he has prototype code to share with multi-writer (ShaunWackerly1, 16:15:20)
    10. mlemay says he also has code to share, would like to discuss offline details (ShaunWackerly1, 16:15:40)
    11. dbainbri asks mlemay if his company will be funded by ONF (ShaunWackerly1, 16:16:10)
    12. mlemay says that it is being decided (ShaunWackerly1, 16:16:25)
    13. dbainbri notes that dlenrow (in the ONF meeting) mentioned that ONF would make code available in git repo, and that code would be utilized by ONOS and ODL (ShaunWackerly1, 16:17:04)
    14. mlemay says that politics get involved (ShaunWackerly1, 16:17:33)
    15. dbainbri asks if everyone from NIC needs to work on ONF (ShaunWackerly1, 16:18:00)
    16. mlemay says that NIC and ONF would need a similar set of primitives need to be exposed (ShaunWackerly1, 16:18:19)
    17. ShaunWackerly1 asks how we can guarantee we've got the same primitives (ShaunWackerly1, 16:19:20)
    18. mlemay says that's what cross-project meetings are for (ShaunWackerly1, 16:19:31)
    19. dmentze asks how this will factor into the policy engine that NIC is going to develop, how will it generate native code (ShaunWackerly1, 16:20:34)
    20. mlemay says that the ONF stuff will sit on top, above policy level (ShaunWackerly1, 16:20:58)
    21. dbainbri says he was under the impression that ONF would develop the policy engine underneath (ShaunWackerly1, 16:21:24)
    22. dmentze says that if ONF wants to participate in ODL, they are welcome to (ShaunWackerly1, 16:21:49)
    23. mlemay says that ONF wanted NIC to be the reference implementation of what ONF wanted to do (ShaunWackerly1, 16:22:06)
    24. mlemay says ONF would bring standards, ODL would bring implementation (ShaunWackerly1, 16:22:28)
    25. ShaunWackerly1 asks if agreement was made between ONF and NIC (ShaunWackerly1, 16:24:00)
    26. mlemay says that ONF and dlenrow came up with a compromise (not on behalf of NIC), it is more of an experiment (ShaunWackerly1, 16:24:32)
    27. dbainbri says that NIC still retains the right to not use ONF code (ShaunWackerly1, 16:24:53)
    28. mlemay says that we will remain flexible, that another higher level runtime project may be what interfaces with ONF (ShaunWackerly1, 16:25:36)
    29. mlemay mentions that the project could be GBP (ShaunWackerly1, 16:25:50)
    30. mlemay says it is more politics than technology (ShaunWackerly1, 16:26:23)
    31. mlemay says that the goal was an experiment to try and come up with a way for ONF to work with ODL (ShaunWackerly1, 16:27:44)
    32. dbainbri adds "and ONOS" (ShaunWackerly1, 16:27:51)
    33. mlemay says will try to send more info about ONF meetings, perhaps NIC can influence ONF's git repo (ShaunWackerly1, 16:28:38)
    34. dmentze notes that ONF is interested in northbound API, asks if ONF has reviewed NIC discussions on NB API (ShaunWackerly1, 16:29:01)
    35. mlemay says discussions in ONF are over whether they will even have an API, or will it just be primitives/models (ShaunWackerly1, 16:29:29)
    36. dbainbri notes that individuals in ONF have pinged him, regarding discussions (ShaunWackerly1, 16:30:03)
    37. dmentze says that if ONF wants to participate, they will need to speak up in NIC (ShaunWackerly1, 16:30:19)
    38. dbainbri says that ONF is restructuring to focus on intent (ShaunWackerly1, 16:30:33)
    39. dbainbri says they might not have voiced opinions because they don't know what they are doing yet (ShaunWackerly1, 16:31:20)
    40. ("they" being ONF) (ShaunWackerly1, 16:31:27)
    41. mlemay says he and dbainbri may be able to help bridge the gap (ShaunWackerly1, 16:32:10)
    42. dbainbri says he's not too involved with ONF, but dlenrow is the chair of the ONF NBI group and dlenrow is also involved in NIC (ShaunWackerly1, 16:32:37)
    43. phrobb says that as we figure out which software ONF is building, we need to keep licenses in view. ONF and ONOS are under apache, ODL is under EPL. (ShaunWackerly1, 16:33:27)
    44. phrobb says licenses would prevent moving code from ONF to ODL easily (ShaunWackerly1, 16:34:34)
    45. dbainbri says that since it's "open source", NIC folks could go over to ONF and develop code, swap between projects (ShaunWackerly1, 16:35:21)
    46. dbainbri is scared by forking and having our own copy of code (ShaunWackerly1, 16:35:34)
    47. phrobb says ONF is meant for upstreaming w/apache license (ShaunWackerly1, 16:36:01)
    48. mlemay says he will try to keep informed of the ONF work (ShaunWackerly1, 16:37:00)
    49. devond asks for more topics to discuss in the future (ShaunWackerly1, 16:38:08)
    50. ShaunWackerly1 says we should decide on classifier/filter (or not) (ShaunWackerly1, 16:38:32)
    51. dmentze says we need use cases defined before API discussions (ShaunWackerly1, 16:38:47)
    52. ShaunWackerly1 notes that API is frozen on 3/19, need to freeze use cases prior (ShaunWackerly1, 16:39:34)
    53. dbainbri says use cases can be developed in tandem to the API discussions (ShaunWackerly1, 16:40:15)
    54. dmentze and dbainbri agree that we should pick a use case deadline (ShaunWackerly1, 16:40:37)
    55. mlemay suggests a topic, that we discuss primitives (ShaunWackerly1, 16:41:03)
    56. ACTION: mlemay will send out some primitives from the HP intent summit, and notes from ONF discussions (ShaunWackerly1, 16:41:55)
    57. devond asks if we need a special use case meeting (ShaunWackerly1, 16:42:53)
    58. ShaunWackerly1 says the only reason we'd need that is in the presence of disagreement over whether a use case is valid (ShaunWackerly1, 16:43:11)
    59. dmentze says he'd rather present advanced topics (like multi-writer and SFC) in a f2f meeting, suggests we could share the floor with ONF to present and listen (ShaunWackerly1, 16:44:06)
    60. devond says use cases will be discussed over email, asks if we meet f2f next week (ShaunWackerly1, 16:44:37)
    61. dmentze says that f2f meeting should be the following week (2/23-27?) (ShaunWackerly1, 16:45:02)
    62. dbainbri asks if multi-writer is predicated on use cases (ShaunWackerly1, 16:45:17)
    63. dmentze says he can meet sooner than 2 weeks from now, if desired (ShaunWackerly1, 16:45:41)
    64. mlemay and dbainbri say that f2f scheduling may be problematic (ShaunWackerly1, 16:46:18)
    65. dmentze asks for poll regarding f2f meeting regarding multi-writer and SFC (ShaunWackerly1, 16:46:35)
    66. dmentze asks who would be interested in f2f meeting (ShaunWackerly1, 16:48:04)
    67. F2F Devond Roseville (devond, 16:48:25)
    68. dmentze bay area (dmentze, 16:48:31)
    69. DavidB - bay area (dbainbri, 16:48:38)
    70. F2F ShaunWackerly1 Roseville (ShaunWackerly1, 16:48:39)
    71. uchau Roseville (uchau, 16:48:48)
    72. keith bay area (dbainbri, 16:48:51)
    73. mlemay is based on ottowa, and can travel to bay area (ShaunWackerly1, 16:49:47)
    74. dmentze (tbachman, 16:50:10)
    75. dmentze suggests bay area would give best chance for participants (ShaunWackerly1, 16:50:17)
    76. dmentze roseville - but wiling to travel to bay areal (tbachman, 16:50:20)
    77. dbainbri offers to donate ciena offices (ShaunWackerly1, 16:50:30)
    78. dbainbri asks for a date (ShaunWackerly1, 16:51:27)
    79. dmentze proposes 2/18 or 2/19 (ShaunWackerly1, 16:51:37)
    80. ACTION: devond will email mailing list to ask for interest and solidify the date (ShaunWackerly1, 16:52:42)
    81. devond asks for pre-work that's necessary before the meeting (ShaunWackerly1, 16:54:12)
    82. dmentze asks what is the best way to offer code for review prior to meeting (ShaunWackerly1, 16:54:54)
    83. dbainbri suggests git (along with tbachman) (ShaunWackerly1, 16:55:06)
    84. dbainbri asks for explanation of reasoning, along with code (ShaunWackerly1, 16:55:29)
    85. ACTION: dbainbri will secure meeting location for f2f (ShaunWackerly1, 16:56:15)


Meeting ended at 16:56:53 UTC (full logs).

Action items

  1. devond says he’ll contact dlenrow to get him at the next meeting to discuss
  2. mlemay will send out some primitives from the HP intent summit, and notes from ONF discussions
  3. devond will email mailing list to ask for interest and solidify the date
  4. dbainbri will secure meeting location for f2f


Action items, by person

  1. dbainbri
    1. dbainbri will secure meeting location for f2f
  2. devond
    1. devond says he’ll contact dlenrow to get him at the next meeting to discuss
    2. devond will email mailing list to ask for interest and solidify the date


People present (lines said)

  1. ShaunWackerly1 (96)
  2. tbachman (48)
  3. odl_meetbot (6)
  4. alagalah (4)
  5. dbainbri (4)
  6. dmentze (3)
  7. uchau (3)
  8. devond (2)
  9. gzhao (2)


Generated by MeetBot 0.1.4.