#opendaylight-nic: nic weekly

Meeting started by gzhao at 15:02:57 UTC (full logs).

Meeting summary

  1. Roll Call (gzhao, 15:03:14)
    1. gzhao (gzhao, 15:03:19)
    2. tbachman (tbachman, 15:03:23)
    3. https://meetings.opendaylight.org/opendaylight-nic/2015/nic_weekly/opendaylight-nic-nic_weekly.2015-03-13-15.02.html Minutes from last week’s meeting (tbachman, 15:03:34)
    4. duane mentze (dmentze, 15:03:59)
    5. Hideyuki Tai (hideyuki, 15:04:33)

  2. agenda (gzhao, 15:05:36)
    1. dmentze and devon have to change roles — moving on (tbachman, 15:05:43)
    2. https://lists.opendaylight.org/pipermail/nic-dev/2015-March/000584.html email describing today’s agenda (tbachman, 15:06:21)
    3. gzhao will be the project contact (tbachman, 15:06:41)
    4. ACTION: gzhao to work with dmentze for M3 status (gzhao, 15:07:07)

  3. PTL election (gzhao, 15:07:45)
    1. dbainbri is out until the end of the month; dmentze says we have two options — do election w/o dbainbri, or just have folks volunteer for those roles until a PTL election can be done that includes dbainbri (tbachman, 15:09:18)
    2. https://lists.opendaylight.org/pipermail/nic-dev/2015-March/000600.html email from gzhao describing his thoughts/proposal on this issue (tbachman, 15:10:20)
    3. phrobb says his recommendation is to try to contact dbainbri to see if he will self-nominate (tbachman, 15:11:11)
    4. https://wiki.opendaylight.org/view/CondorcetElection4PTLs < --- ODL PTL process (gzhao, 15:11:27)
    5. phrobb says worst-case is that a Point of Contact can be used for a while — asks if anyone else is planning to self-nominate (tbachman, 15:13:22)
    6. ACTION: gzhao will try to contact dbainbri re: PTL self-nomination (tbachman, 15:14:08)
    7. ACTION: colindixon to also try to contact dbainbri (tbachman, 15:14:45)
    8. dlenrow may self-nominate (pending approval from mgmt) (tbachman, 15:15:42)
    9. mlemay says there are a couple of candidates who are expressing concern about the amount of time involved in being PTL (tbachman, 15:16:10)
    10. gzhao asks if everyone agrees to extend deadline to next week (tbachman, 15:16:22)
    11. dmentze agrees we need to extend it to next week (tbachman, 15:16:35)
    12. dmentze asks colindixon if the TSC would approve just putting dbainbri’s name on the PTL nominiation list (tbachman, 15:17:04)
    13. colindixon says that projects are free to determine their nomiation process — the election has to be handled as called out by the TSC (tbachman, 15:17:35)
    14. colindixon says he’s not aware of any timeline that a project has for running w/o a PTL (tbachman, 15:17:53)
    15. gzhao recommends moving the deadline to March 31st, as there are several candidates who need more time — would have PTL elected on April 3rd meeting (tbachman, 15:18:22)
    16. AGREED: moving the nomination deadline to March 31st; PTL election on April 3rd meeting (tbachman, 15:18:57)

  4. M3 status (tbachman, 15:19:08)
    1. dmentze says NIC doesn’t have customer-visible features, which simplifies this (tbachman, 15:20:21)
    2. dmentze asks for volunteers for karaf features (tbachman, 15:20:56)
    3. mlemay says dmentze can put mlemay’s name next to karaf features (tbachman, 15:21:12)
    4. colindixon says the docs requirement for M3 is to mostly just create a template, not filling in content; requests help adding content as the project moves along (tbachman, 15:23:20)
    5. dmentze says there are no system/integration requirements, as there are no user-facing features (tbachman, 15:25:15)
    6. dmentze recommends picking a model so that code can be written (tbachman, 15:27:12)
    7. dmentze asks how to get a consensus decision from a large group (tbachman, 15:27:42)
    8. dmentze says one possibility is to take HP code, work with it, and then let that drive design discussions (tbachman, 15:30:36)
    9. gzhao agrees with dmentze — if we want something to happen in Lithium time frame, given that we’re at M3, this may be the best path (tbachman, 15:31:39)
    10. gzhao asks who at HP would be the contact for his code going forward (tbachman, 15:31:52)
    11. dmentze says during the deep-dive, there wasn’t a lot of questions; wasn’t sure how to interpret that; going forward, HP has 3 dedidcate engineers who are going to be ramping on the code (tbachman, 15:32:23)
    12. https://lists.opendaylight.org/pipermail/nic-dev/2015-March/000574.html email from dmentze describing replacements from HP (tbachman, 15:33:02)
    13. helen says sometimes it’s harder to inherit code than create from scratch (tbachman, 15:34:19)
    14. helen says it may be better to focus on a single use case, such as SFC (tbachman, 15:35:14)
    15. dmentze says it’s important for the group to agree on that use case (tbachman, 15:35:37)
    16. colindixon says the challenge is to create clean, simple abstractions in order to support a bunch of use cases; focusing on a single use case early on may make creating such a model hard (tbachman, 15:36:14)
    17. helen said we look at the whole use case set, and implement one for the lithium time frame (helen_chen, 15:38:13)
    18. mlemay says there’s been a lot of model discussions — we’ve identified a bunch of use cases, but we need to start working at providing extra value in ODL through this project (tbachman, 15:40:04)
    19. dmentze says that while he appreciates the need for clean APIs, the code underneath is really non-trivial (tbachman, 15:41:20)
    20. dmentze says we need to get coders working on supporting some of these APIs — might be good for some to go explore SFC space; pull HP code and work with it (tbachman, 15:42:01)
    21. dmentze says it might be hard to do a “think-tank” design (tbachman, 15:42:26)
    22. colindixon says there are lots of implementations of intent in ODL: OVSDB is an implementation of one kind of intent; SFC is another implementation of another kind of intent; there’s GBP which is another implementation of another kind of intent; he feels that this might be down to simple shims into those projects (tbachman, 15:43:27)
    23. colindixon says his experience is that if the people who wrote the code aren’t there, then the code is not useful (tbachman, 15:43:52)
    24. gzhao says during the 2hrs deep dive let people understand the structures; but to take ownership of the HP code is harder (tbachman, 15:44:14)
    25. colindixon says there are implementations that are lying around, with active committers; figuring out how NIC maps onto those might be very constructive (tbachman, 15:44:39)
    26. mlemay agrees with colindixon — having a shim layer to existing pieces in ODL is already providing value (tbachman, 15:45:14)
    27. mlemay says having the ability to batch intent has a lot of value, and an intent topology (tbachman, 15:45:42)
    28. gzhao agrees with colindixon and mlemay (tbachman, 15:45:54)
    29. helen_chen agrees with that idea (tbachman, 15:46:32)
    30. someone asks if we need to agree on the API for intent, and then can start on the implementation (tbachman, 15:47:18)
    31. mlemay asks if those on the meeting would be okay with merging the HP code in one folder and the models in another folder, and then get started on the code piece (tbachman, 15:49:22)
    32. hideyuki asks what the shim layer is (tbachman, 15:49:29)
    33. mlemay says the shim layer is a mapping of the intent NB’s to existing projects or ways of implementing that, instead of translating to existing openflow rules (tbachman, 15:50:02)
    34. mlemay says for example, an intent that would describe an overlay could map to an overlay model in OVSDB (tbachman, 15:50:53)
    35. hideyuki says they are planning to developing a mapping layer in VTN project; that’s fine for them (tbachman, 15:51:20)
    36. gzhao asks what the concrete plan for Lithium, given agreement to the shim layer strategy (tbachman, 15:51:56)
    37. mlemay says we may come up with a model totally different (gzhao, 15:53:29)
    38. mlemay says one thing to keep in mind for the models is to keep the notion of groups (tbachman, 15:53:35)
    39. colindixon says he believes the developers will drive the model (tbachman, 15:55:07)
    40. dmentze and mlemay agree (tbachman, 15:56:11)
    41. gzhao asks if the conclusion is to let the developers work on the models (tbachman, 15:56:52)
    42. dmentze asks how the project is going to operationalize all of this — who are the people who are going to write the code to connect it into ODL projects (tbachman, 15:58:36)
    43. mlemay says he can commit 2 resources to the project (tbachman, 15:59:56)
    44. helen_chen says she can include 1-2 resources (tbachman, 16:00:06)
    45. colindixon notes (in the IRC logs) that this is going to be *really* hard because it needs to be bottom up from the coders, but also keep the implementation details out of the model and keep the abstractions very simple (colindixon, 16:00:10)
    46. dmentze has committed resources (tbachman, 16:00:21)


Meeting ended at 16:01:20 UTC (full logs).

Action items

  1. gzhao to work with dmentze for M3 status
  2. gzhao will try to contact dbainbri re: PTL self-nomination
  3. colindixon to also try to contact dbainbri


Action items, by person

  1. colindixon
    1. colindixon to also try to contact dbainbri
  2. dmentze
    1. gzhao to work with dmentze for M3 status
  3. gzhao
    1. gzhao to work with dmentze for M3 status
    2. gzhao will try to contact dbainbri re: PTL self-nomination


People present (lines said)

  1. tbachman (88)
  2. gzhao (16)
  3. alagalah_ (11)
  4. dlenrow (6)
  5. odl_meetbot (6)
  6. colindixon (6)
  7. helen_chen (5)
  8. hideyuki (2)
  9. mlemay (2)
  10. dmentze (1)
  11. phrobb (0)


Generated by MeetBot 0.1.4.