#opendaylight-nic: nic weekly

Meeting started by gzhao at 15:01:07 UTC (full logs).

Meeting summary

  1. roll call (gzhao, 15:01:15)
    1. gzhao (gzhao, 15:01:22)
    2. tbachman (tbachman, 15:01:34)
    3. dlenrow (dlenrow, 15:01:34)
    4. Phil Robb (phrobb1, 15:01:42)
    5. hideyuki (hideyuki, 15:01:57)
    6. https://lists.opendaylight.org/pipermail/nic-dev/2015-March/000609.html <-- agenda (gzhao, 15:02:23)

  2. PTL update (gzhao, 15:03:58)
    1. no self nomination so far (gzhao, 15:04:45)
    2. gzhao sent David B email (gzhao, 15:05:24)
    3. AGREED: PTL self nomination deadline extends to 4/3 (gzhao, 15:06:54)
    4. AGREED: PTL self nomination deadline extends to 4/3 (gzhao, 15:07:14)
    5. agreed with no opposition on call to push deadline for self-nomination for PL to 4/3 (dlenrow, 15:07:21)
    6. mlemay suggest two parallel code repository for NIC (gzhao, 15:10:22)
    7. mlemay agrees with gzhao time is running short (gzhao, 15:10:52)
    8. dlenrow suggests cut a snapshot for Lithium and have a long term in parallel. (gzhao, 15:12:38)
    9. mahesh ask which model should NIC use (gzhao, 15:13:16)
    10. mahesh asks how to define shim layer (gzhao, 15:13:55)
    11. mlemay says shim layer will use reservation, GBP, SFC, VTN in ODL (gzhao, 15:16:05)
    12. dlenrow says this is a common layer that northbound will talk and eco system build around. (gzhao, 15:17:28)
    13. Cathy says API is different than GBP (gzhao, 15:18:08)
    14. LouisF asks mlemay details about shium (gzhao, 15:20:05)
    15. dlenrow NIC is common layer that can be mapped to different new or existing projects. (gzhao, 15:22:11)
    16. ACTION: dlenrow will draft a wiki page for NIC direction. (gzhao, 15:23:04)
    17. ACTION: mlemay to prepare two repository for NIC (gzhao, 15:24:39)
    18. ACTION: dlenrow to work with mahesh for HP code pass IPR (gzhao, 15:25:06)
    19. mlemay will propose architecture for review. (gzhao, 15:26:46)
    20. mahesh ask if HP code can be refactored to avoid two code base (gzhao, 15:32:17)
    21. mlemay says technically HP code is too AD-SAL ish or OSGI-ish. (gzhao, 15:33:55)
    22. there're two parallel approach for NIC: one is contintuing discussion on data model and others for post-Lithium release; another one is creating shim layer from scratch (helenc878, 15:34:05)
    23. dlenrow build first shim layer with simple definitions (gzhao, 15:37:50)
    24. Mahesh asks who will be the consumer for the shim layer (gzhao, 15:38:54)
    25. dlenrow says will be anything to the north of controller (gzhao, 15:39:12)
    26. dlenrow says we have the SFC use case in the NIC web page, We will try to align our northbound API and model with that (gzhao, 15:39:39)
    27. : you asked me to use #info, so that is why I rewrite it (cathy_, 15:41:43)

  3. M3 status (gzhao, 15:42:30)
    1. gzhao asks will NIC define Karaf features (gzhao, 15:43:51)
    2. hideyuki says yes, NIC should define karaf features (gzhao, 15:44:33)
    3. mlemay says ETA for feature is next Monday (gzhao, 15:45:45)

  4. others (gzhao, 15:48:08)
    1. gzhao says NIC should be able to catch up in M4,M5 time frame if high level architecture is determined. (gzhao, 15:52:58)
    2. ACTION: mehesh will work on for submit HP code for NIC (gzhao, 15:53:33)


Meeting ended at 15:53:42 UTC (full logs).

Action items

  1. dlenrow will draft a wiki page for NIC direction.
  2. mlemay to prepare two repository for NIC
  3. dlenrow to work with mahesh for HP code pass IPR
  4. mehesh will work on for submit HP code for NIC


Action items, by person

  1. dlenrow
    1. dlenrow will draft a wiki page for NIC direction.
    2. dlenrow to work with mahesh for HP code pass IPR
  2. mlemay
    1. mlemay to prepare two repository for NIC


People present (lines said)

  1. gzhao (52)
  2. tbachman (9)
  3. odl_meetbot (8)
  4. cathy_ (7)
  5. helenc878 (7)
  6. dlenrow (3)
  7. hideyuki (3)
  8. mlemay (2)
  9. phrobb1 (1)


Generated by MeetBot 0.1.4.