#opendaylight-nic: nic_weekly

Meeting started by raphael at 15:04:12 UTC (full logs).

Meeting summary

  1. agend bashing (colindixon, 15:07:16)
    1. https://wiki.opendaylight.org/view/Network_Intent_Composition:Main#May_1.2C_2015 the agenda (colindixon, 15:07:57)

  2. initial YANG / interface models (colindixon, 15:08:35)
    1. https://github.com/opendaylight/nic/tree/master/intentengine-api/src/main/yang the current YANG interfaces (colindixon, 15:09:46)
    2. it seems like the major changes are that we’ve split out primitive actions, and factored thigns apart into multiple yang files (colindixon, 15:10:40)
    3. dbainbri says we’d like to freeze this API in the next few days and wants feedback on that idea (colindixon, 15:11:32)
    4. dbainbri and colindixon seem to agree that focusing on just allow and deny (colindixon, 15:12:29)
    5. AGREED: barring a major uprising, we’ll scale back the primitive actions to allow/deny, with agumentations for thigns like SFC (and maybe redirect steer for mlemay’s work) (colindixon, 15:13:19)
    6. dlenrow raises concerns about just allow/deny for now (colindixon, 15:13:52)
    7. ACTION: dbainbri to make the changes to trim down the primitives in the repository (colindixon, 15:15:04)
    8. Now we have a high level intent model, but we're going to focus on actions allow and deny for lithium. (raphael, 15:15:39)
    9. ACTION: mlemay to work with dbainbri to make sure that the revised model will work for his issues in the Lithium time-frame (colindixon, 15:15:54)
    10. colindixon asks if we should have a “YANG expert” (e.g., Ed, Robert, etc.) look through things and make sure we’re not making any obvious mistakes (colindixon, 15:17:28)

  3. Karaf CLI (colindixon, 15:18:42)
    1. ACTION: raphaelamorim to push karaf console extensions with add, delete and list support today (colindixon, 15:18:51)

  4. providers (colindixon, 15:19:04)
    1. there are two providers we’re looking at in Lithium: VTN and GBP (colindixon, 15:19:31)
    2. dbainbri asks if we have any commitment from those projects, because at some point we will really want that (colindixon, 15:20:26)
    3. colindixon asks if there’s a simple way that we could map NIC onto Neutron in Lithium so that we would have a provider (colindixon, 15:26:29)
    4. dlenrow says that we need to deliver an SFC demo on top of ODL and ONOS in the Lithium timeframe, it appears as though mlemay is the person who is staffing that effort (colindixon, 15:27:43)
    5. hideyuki is working on VTN provider and focusing on alow/deny action for lithium timeframe (raphael, 15:31:12)
    6. dbainbri say he hasn’t seen any evidence of that work in the Lithium release, which concerns him, mlemay says he will try to reshuffle resources to make that happen (colindixon, 15:31:13)

  5. documentation (colindixon, 15:31:39)
    1. ACTION: dbainbri to work on docs for the model (colindixon, 15:31:50)
    2. dbainbri would love help with docs and especially adding anything for things for providers if we have any (colindixon, 15:32:28)
    3. ACTION: raphael to work on integration testing for NIC (colindixon, 15:33:23)

  6. trello board review (colindixon, 15:33:32)
    1. https://trello.com/b/L4GssBld/opendaylight-nic (colindixon, 15:33:56)

  7. deliverable review (colindixon, 15:36:14)
    1. https://wiki.opendaylight.org/view/Network_Intent_Composition:Lithium_Release_Plan the release plan (colindixon, 15:36:37)
    2. we seem to be in good shape on: use cases, the YANG model, and the high-level design (colindixon, 15:37:13)
    3. the prototype and ONF SFC seem much, much scarier (colindixon, 15:37:26)
    4. in particular we don’t seem to have worked out either (a) if the model is sufficient for those and (b) if there’s a provider for the model that will be sufficient in the Lithium release (colindixon, 15:39:15)
    5. ACTION: dlenrow Will work with innocybe and HP team's to either present detailed plan to include SFC/VTN provider demo or will agree to miss Li milestones. Report back by email to lists early next week (colindixon, 15:39:30)
    6. there is a longer discussion around worries about missing delivering on our Lithium release plans (colindixon, 15:43:51)
    7. colindixon and dbainbri say that there seems to be a real likelihood of shipping no NIC providers in Lithium, although it seems most likely that hideyuki and VTN will deliver one of the options (colindixon, 15:45:30)


Meeting ended at 15:46:01 UTC (full logs).

Action items

  1. dbainbri to make the changes to trim down the primitives in the repository
  2. mlemay to work with dbainbri to make sure that the revised model will work for his issues in the Lithium time-frame
  3. raphaelamorim to push karaf console extensions with add, delete and list support today
  4. dbainbri to work on docs for the model
  5. raphael to work on integration testing for NIC
  6. dlenrow Will work with innocybe and HP team's to either present detailed plan to include SFC/VTN provider demo or will agree to miss Li milestones. Report back by email to lists early next week


Action items, by person

  1. dbainbri
    1. dbainbri to make the changes to trim down the primitives in the repository
    2. mlemay to work with dbainbri to make sure that the revised model will work for his issues in the Lithium time-frame
    3. dbainbri to work on docs for the model
  2. dlenrow
    1. dlenrow Will work with innocybe and HP team's to either present detailed plan to include SFC/VTN provider demo or will agree to miss Li milestones. Report back by email to lists early next week
  3. mlemay
    1. mlemay to work with dbainbri to make sure that the revised model will work for his issues in the Lithium time-frame
  4. raphael
    1. raphael to work on integration testing for NIC


People present (lines said)

  1. colindixon (44)
  2. dlenrow (25)
  3. raphael (10)
  4. odl_meetbot (8)
  5. mlemay (3)
  6. hideyuki (2)
  7. dbainbri (1)


Generated by MeetBot 0.1.4.