#opendaylight-nic: nic weekly 2015-05-22

Meeting started by dbainbri at 15:04:37 UTC (full logs).

Meeting summary

    1. dbainbri (dbainbri, 15:05:06)
    2. dlenrow (dlenrow, 15:05:10)

  1. agenda bashing (dbainbri, 15:05:27)
  2. code freeze (dbainbri, 15:06:05)
    1. code freeze pending the gbp renderer ok (dbainbri, 15:06:50)
    2. adetalhouet (adetalhouet, 15:09:16)
    3. grmontpetit (grmontpetit, 15:09:29)
    4. Renato reports on status of simple allow/deny actions. Working on test cases. (dlenrow, 15:10:05)
    5. ACTION: dbainbri check with GBP about code freeze ETA (dbainbri, 15:10:10)
    6. need to hear from Mathieu on status relative to code freeze and GBP dependencies (dlenrow, 15:10:25)
    7. ACTION: dbainbri to get status from Mathieu Lemay (dlenrow, 15:10:51)

  3. open reviews (dbainbri, 15:10:54)
    1. first pending patch set can't be reviewed because it doesn't build. Need to fix this (dlenrow, 15:11:39)
    2. ACTION: review https://git.opendaylight.org/gerrit/#/c/20840/ https://git.opendaylight.org/gerrit/#/c/20933 (grmontpetit, 15:11:51)
    3. ACTION: reviewers to pay attention if the branch is rebased before merging to avoid the creation of merge commits in the master branch (raphaelamorim, 15:12:57)
    4. second patch GBP augmentation needs review/merge. Partially reviewed awaiting author feedback (dlenrow, 15:13:48)
    5. dlenrow asks if reviewers are bottleneck, dbainbri: no (dlenrow, 15:14:11)
    6. we reviewed of open patches in gerrit and sorted (dlenrow, 15:18:01)
    7. ACTION: dbainbri to ask mailing list if there is anyone who is too busy with Lithium to discuss Be and would object to our starting without them? (dlenrow, 15:18:36)
    8. discussed having reviewer re-base as end of their process to produce a cleaner gerrit/git history and logs. (dlenrow, 15:22:01)
    9. dbainbri suggests this is an issue of ODL-wide best practices and might need to be asked in wider audience such as discuss list (dlenrow, 15:22:47)
    10. discussion of changing the process locally will be invisible to ODL-wide but make our project best practice better (dlenrow, 15:23:35)
    11. ACTION: raphaelamorim to suggest new "best practice for nic group on nic-dev list (dlenrow, 15:26:58)
    12. https://wiki.opendaylight.org/view/OpenDaylight_Controller:Pulling,_Hacking,_and_Pushing_the_Code_from_the_CLI (dbainbri, 15:27:28)
    13. renato would like a way to make repo where review is being done visible to everyone, not just reviewer for collaboration (dlenrow, 15:28:21)
    14. thanks dlenrow for meeting notes (dbainbri, 15:29:18)


Meeting ended at 15:29:21 UTC (full logs).

Action items

  1. dbainbri check with GBP about code freeze ETA
  2. dbainbri to get status from Mathieu Lemay
  3. review https://git.opendaylight.org/gerrit/#/c/20840/ https://git.opendaylight.org/gerrit/#/c/20933
  4. reviewers to pay attention if the branch is rebased before merging to avoid the creation of merge commits in the master branch
  5. dbainbri to ask mailing list if there is anyone who is too busy with Lithium to discuss Be and would object to our starting without them?
  6. raphaelamorim to suggest new "best practice for nic group on nic-dev list


Action items, by person

  1. dbainbri
    1. dbainbri check with GBP about code freeze ETA
    2. dbainbri to get status from Mathieu Lemay
    3. dbainbri to ask mailing list if there is anyone who is too busy with Lithium to discuss Be and would object to our starting without them?
  2. raphaelamorim
    1. raphaelamorim to suggest new "best practice for nic group on nic-dev list
  3. UNASSIGNED
    1. review https://git.opendaylight.org/gerrit/#/c/20840/ https://git.opendaylight.org/gerrit/#/c/20933
    2. reviewers to pay attention if the branch is rebased before merging to avoid the creation of merge commits in the master branch


People present (lines said)

  1. dlenrow (16)
  2. dbainbri (12)
  3. odl_meetbot (5)
  4. raphaelamorim (2)
  5. grmontpetit (2)
  6. adetalhouet (1)


Generated by MeetBot 0.1.4.