#opendaylight-nic: NIC Weekly Meeting

Meeting started by ShaunWackerly at 16:03:14 UTC (full logs).

Meeting summary

    1. gzhao (gzhao, 16:04:06)
    2. ShaunWackerly (ShaunWackerly, 16:04:13)
    3. PTL election, will need to add +1's from email (ShaunWackerly, 16:08:59)
    4. devond recommends that dmentze be considered project lead, unless any objections (ShaunWackerly, 16:09:27)
    5. devond asks how Test Contact is chosen (ShaunWackerly, 16:09:57)
    6. colindixon says typically Test Contact is PTL, unless someone volunteers to do the work (ShaunWackerly, 16:10:29)
    7. colindixon says Test Contact must assure at least one system test (ShaunWackerly, 16:11:35)
    8. dlenrow points out that if Test Contact goes on vacation, they need to identify a replacement (ShaunWackerly, 16:12:42)
    9. Documentation Contact, will likely follow same path as Test Contact (ShaunWackerly, 16:13:05)
    10. dmentze will be listed for both, then possibly delegate later (ShaunWackerly, 16:14:05)

  1. F2F follow-up (ShaunWackerly, 16:14:46)
    1. dlenrow will present slides showing collaboration with ONF (ShaunWackerly, 16:15:24)
    2. dlenrow says it would be good for ODL to be reference implementation of Intent NBI (ShaunWackerly, 16:16:22)
    3. https://wiki.opendaylight.org/view/Network_Intent_Composition:F2F-02-18-15 <-- f2f meeting slides (gzhao, 16:16:22)
    4. dlenrow says a possible conflict is that ONF NBI decision may be slower (ShaunWackerly, 16:17:20)
    5. dlenrow says ONF can't slow down NIC (ShaunWackerly, 16:17:34)
    6. dlenrow presents possible solution to put approved (official) ONF info model fragments in ONF intent repo (ShaunWackerly, 16:18:09)
    7. dlenrow says a conversion tool could convert from official/non-official model fragments in ONF intent repo, to a format that NIC could consume (ShaunWackerly, 16:18:50)
    8. dlenrow says best case would be ONF defining broadly-adopted IM fragments (ShaunWackerly, 16:19:39)
    9. dlenrow says worst case is that ONF and ODL diverge information models (IMs) (ShaunWackerly, 16:20:08)
    10. dlenrow suggests that we look at how to accomplish his proposed possible solution (ShaunWackerly, 16:21:18)
    11. dbainbri says that models have already diverged, since NIC has some code/yang and ONF does not (ShaunWackerly, 16:22:00)
    12. dlenrow says progress has been made on both sides, so we'll have some initial sync up work (ShaunWackerly, 16:22:18)
    13. dmentze asks why ONF folks wouldn't participate in NIC project (ShaunWackerly, 16:23:07)
    14. https://lists.opendaylight.org/pipermail/nic-dev/2015-February/000360.html this is a mailing list thread which has some conversation about the ONF/ODL interactions (colindixon, 16:23:26)
    15. dlenrow says he is chair of NBI working group, and colindixon and dbainbri are also working on ONF (ShaunWackerly, 16:23:26)
    16. dmentze says that moving code out of NIC is not contributing (ShaunWackerly, 16:23:48)
    17. dlenrow says goal of NBI is to develop a controller-agnostic NBI, and ODL is one of the controllers which should align with that NBI (ShaunWackerly, 16:24:50)
    18. dmentze says that defining the model is different than moving code (ShaunWackerly, 16:25:08)
    19. dlenrow says that he is not proposing to move code from NIC to ODL (ShaunWackerly, 16:25:33)
    20. dlenrow asks if we could get some people to work out details of how this might work (ShaunWackerly, 16:26:07)
    21. dmentze asks whether ideas or code are flowing from ONF to ODL (ShaunWackerly, 16:26:26)
    22. dlenrow says it is TBD (ShaunWackerly, 16:26:33)
    23. colindixon says that the definition could reside in ONF, then ODL could consume the information model (on the level of yang) (ShaunWackerly, 16:27:11)
    24. colindixon says that the code which implements the NBI could reside fully in NIC/ODL (ShaunWackerly, 16:27:35)
    25. colindixon says he can help dlenrow with details of how to accomplish this (ShaunWackerly, 16:28:05)
    26. colindixon asks if we agree that the goal is something we want (ShaunWackerly, 16:29:00)
    27. dbainbri says that phrobb identified some issues with 3rd party artifacts like this previously (ShaunWackerly, 16:29:29)
    28. colindixon says he thinks that we can find a way for it to work (ShaunWackerly, 16:30:36)
    29. colindixon and dbainbri discuss details of how to keep artifact snapshots over time, so they aren't lost (ShaunWackerly, 16:31:49)
    30. colindixon identifies some technical details, starting with licensing (apache vs EPL) (ShaunWackerly, 16:32:35)
    31. can go apache->EPL, but not EPL->apache (ShaunWackerly, 16:32:46)
    32. colindixon says this means ODL could never push code back to ONF (ShaunWackerly, 16:33:10)
    33. colindixon says intellectual property becomes an issue, between ODL and ONF (IP sharing) (ShaunWackerly, 16:33:35)
    34. dlenrow says linux foundation lawyers and other lawyers are sorting this out (ShaunWackerly, 16:33:52)
    35. dlenrow says that anyone can participate in ONF, so ODL members are not restricted (ShaunWackerly, 16:34:39)
    36. ShaunWackerly asks if non-ONF members need to join an ONF NBI to affect the NIC API (ShaunWackerly, 16:36:43)
    37. colindixon says that it would be an additional 1-hour per week, plus some email list stuff (ShaunWackerly, 16:37:09)
    38. dbainbri says that ODL is currently focused on implementation, ONF discussion is more academic right now (ShaunWackerly, 16:38:32)
    39. dlenrow says that we could split discussions along those lines (academic/implementation) (ShaunWackerly, 16:39:01)
    40. colindixon says that if you are only interested in 10% of a project, you are doing a disservice if you don't join the mailing list (ShaunWackerly, 16:39:30)
    41. colindixon implies that if ShaunWackerly does a good job taking notes, it will prevent that problem for NIC (personal commentary :) ) (ShaunWackerly, 16:39:51)
    42. colindixon says we should make someone responsible for producing a project summary for each project per week (ShaunWackerly, 16:40:15)
    43. colindixon identifies another risk: what if ONF does weird things? (ShaunWackerly, 16:40:43)
    44. colindixon says that if NIC dislikes the ONF NBI, then we'd have a technical divergence (ShaunWackerly, 16:41:29)
    45. dmentze says that other problems like ONF moving too slow or ONF's NBI being unimplementable are other risks (ShaunWackerly, 16:42:22)
    46. colindixon mildly agrees, says those are forms of divergence (ShaunWackerly, 16:42:38)
    47. colindixon says the only way to stop divergence is to participate (ShaunWackerly, 16:43:14)
    48. dlenrow says the build process could omit some pieces of the NBI which are problematic, until there's time to implement them (ShaunWackerly, 16:43:42)
    49. colindixon says we shouldn't walk away from potential upsides because of potential downsides (ShaunWackerly, 16:44:24)
    50. colindixon says there is value to having academic input, if it can be maintained (ShaunWackerly, 16:44:55)
    51. dlenrow says the value is having a single interface that's larger than a single controller (ShaunWackerly, 16:45:09)
    52. dlenrow acknowledges that there are some risks and inconveniences (ShaunWackerly, 16:45:34)
    53. dbainbri agrees that ONF has thought about this a while and can provide value from various perspectives that the NIC project people have not thought about. The trick is prioritizing that insight in terms of development (colindixon, 16:46:49)
    54. ShaunWackerly asks if lithium API deliverable is in conflict with waiting for ONF NBI (ShaunWackerly, 16:47:09)
    55. dlenrow says that lithium API wouldn't necessarily be equivalent to ONF NBI (ShaunWackerly, 16:48:52)
    56. dlenrow says big picture goal is to have a common NBI (ShaunWackerly, 16:49:22)
    57. dmentze suggests that ONF ideas be shared, dlenrow says it is currently empty (repository) (ShaunWackerly, 16:49:54)
    58. dlenrow says they could use current NIC yang model as starting point (ShaunWackerly, 16:50:06)
    59. dlenrow says ODL isn't ready to start, dmentze says that NIC's yang isn't ready to go either (ShaunWackerly, 16:50:33)
    60. colindixon says the current yang model could be lifted from NIC (ShaunWackerly, 16:51:00)
    61. dmentze says the current model is not agreed upon (ShaunWackerly, 16:51:10)
    62. colindixon says that agreement within NIC may align with ONF timing for readiness (ShaunWackerly, 16:51:44)
    63. colindixon says it would be nice for ONF to publish a maven artifact (ShaunWackerly, 16:52:13)
    64. dmentze asks if NIC team has choice for what they pull from ONF (ShaunWackerly, 16:53:36)
    65. colindixon says ONF could do a weekly release of their model (ShaunWackerly, 16:53:57)
    66. dmentze objects to another group (ONF) making changes to a model that NIC has to support (ShaunWackerly, 16:54:23)
    67. colindixon says that as long as ONF produces release versions, there is no automatic tethering of NIC to ONF (ShaunWackerly, 16:54:47)
    68. dmentze says NIC could internally review and approve (ShaunWackerly, 16:55:03)
    69. colindixon says that ODL NIC could use augmentations to adapt ONF NBI (?) (ShaunWackerly, 16:55:50)
    70. mlemay says he proposed to ONF that the model should be totally decoupled from a language (ShaunWackerly, 16:56:33)
    71. mlemay says that ONF would be completely orthogonal, something like UML, that's mappable to NIC (ShaunWackerly, 16:57:11)
    72. mlemay says we may need a translation/shim/adapter for NIC ODL (ShaunWackerly, 16:57:39)
    73. dlenrow proposes discussion through email this next week (ShaunWackerly, 16:58:16)
    74. mlemay says he is trying to build a compiler which goes to intent instructions (ShaunWackerly, 16:58:37)
    75. dbainbri asks if mlemay's proposal will compile from intent into OpenFlow, or something else (ShaunWackerly, 16:59:29)
    76. dlenrow says that mlemay's proposal is different from dlenrow's proposal (ShaunWackerly, 17:00:22)
    77. dmentze suggests we set up a separate discussion for discussing and deciding between proposals (ShaunWackerly, 17:00:51)
    78. ACTION: dmentze will email to list regarding plan for making progress toward NIC lithium deliverables (ShaunWackerly, 17:01:41)
    79. ACTION: mlemay and dlenrow will coordinate with colindixon and others to prepare summary of general approach being proposed (ShaunWackerly, 17:02:32)
    80. ACTION: colindixon will work on the summary of the proposal (ShaunWackerly, 17:04:20)
    81. colindixon supports the notion of separating implementation discussion groups from API design (ShaunWackerly, 17:05:47)


Meeting ended at 17:05:59 UTC (full logs).

Action items

  1. dmentze will email to list regarding plan for making progress toward NIC lithium deliverables
  2. mlemay and dlenrow will coordinate with colindixon and others to prepare summary of general approach being proposed
  3. colindixon will work on the summary of the proposal


Action items, by person

  1. colindixon
    1. mlemay and dlenrow will coordinate with colindixon and others to prepare summary of general approach being proposed
    2. colindixon will work on the summary of the proposal
  2. mlemay
    1. mlemay and dlenrow will coordinate with colindixon and others to prepare summary of general approach being proposed


People present (lines said)

  1. ShaunWackerly (94)
  2. dbainbri (10)
  3. gzhao (4)
  4. odl_meetbot (3)
  5. colindixon (2)
  6. mlemay (1)


Generated by MeetBot 0.1.4.