#opendaylight-nic: weekly-status

Meeting started by dbainbri at 15:02:46 UTC (full logs).

Meeting summary

    1. dbainbri (dbainbri, 15:04:31)
    2. Hideyuki Tai (hideyuki, 15:04:33)
    3. adetalhouet (adetalhouet, 15:04:38)

  1. Helium (adetalhouet, 15:04:47)
    1. renato_aguiar (renato_aguiar, 15:05:05)
    2. Cut off for Helium doesn't affect us as we don't have any patches (adetalhouet, 15:05:50)

  2. Berylium (adetalhouet, 15:06:00)
    1. How to document action for each renderer type? (adetalhouet, 15:08:44)
    2. dbainbri said we could have a different lead for each renderer? (adetalhouet, 15:10:09)
    3. dbainbri said we could have a lead for the control loop (adetalhouet, 15:10:24)
    4. lead would have to document the wiki and help folks on how to do (adetalhouet, 15:11:05)
    5. dbainbri: DSL concept means: intent can be express, so the tough was that we could threat all this expression as DSL (adetalhouet, 15:12:32)
    6. dbainbri the idea is one intent abstraction (adetalhouet, 15:13:59)
    7. two concept: 1. renderer that goes down to some common core abstraction (core policies) 2. Other project, as NEMO, could compile as Intent, but this couldn't be control (adetalhouet, 15:15:06)
    8. this will allow the renderer to implement Intent how they intend to do (adetalhouet, 15:15:41)
    9. Be will keep renderer's flexibility (adetalhouet, 15:17:14)
    10. Renderers should describe how the action behave, how they should be compose (adetalhouet, 15:19:51)
    11. (altonfong, 15:20:29)
    12. but for instance Action should be compatible with all renderers as we wan't to avoid incompatibility between actions (adetalhouet, 15:20:45)
    13. idea: have a compiler for each Renderers (adetalhouet, 15:21:48)
    14. idea: when a new action is added, a snippet could be added dynamically to each renderer (GBP, VTN, OF, ...) (adetalhouet, 15:23:41)
    15. we need a PL for each kind of renderer that will well define the scope for renderer, in wiki (adetalhouet, 15:25:55)
    16. need to be on the same page regarding terminology (adetalhouet, 15:28:07)
    17. ACTION: Dave Lenrow to post the link to the draft document regarding Intent (adetalhouet, 15:30:05)

  3. Project Technical Lead (adetalhouet, 15:31:11)
    1. the TSC won't push this, so the thought is to do a checkpoint as each release (adetalhouet, 15:31:53)
    2. if we want to change PTL, someone can just self nominate by sending a mail to the mailing list (adetalhouet, 15:32:23)
    3. if no one self nominate, thing stays the same (adetalhouet, 15:32:41)

  4. cookies (adetalhouet, 15:32:58)


Meeting ended at 15:33:51 UTC (full logs).

Action items

  1. Dave Lenrow to post the link to the draft document regarding Intent


People present (lines said)

  1. adetalhouet (33)
  2. odl_meetbot (5)
  3. gzhao (3)
  4. dbainbri (3)
  5. renato_aguiar (1)
  6. altonfong (1)
  7. hideyuki (1)


Generated by MeetBot 0.1.4.