#opendaylight-openflowplugin: of_plugin

Meeting started by tbachman at 15:08:30 UTC (full logs).

Meeting summary

  1. flow programming improvements (tbachman, 15:08:43)
    1. edwarnicke says there are 3 options for programming (tbachman, 15:08:57)
    2. 1) write state and then take action (FRM picks up state change and takes action by calling RPC to cause action to occur) (tbachman, 15:09:16)
    3. 2) take action then record state (RPC call is made, which then takes action and records the flow information in the data store) (tbachman, 15:09:43)
    4. 3) hybrid approach (but there could be challenges here) (tbachman, 15:10:13)
    5. edwarnicke says that for #3, someone writes state and you could take action on that or if they call the RPCs they can change the config state, but have to be careful not to wind up with loops (tbachman, 15:11:01)
    6. edwarnicke says he has additional ambitions for Lithium, based on things learned from Helium (tbachman, 15:12:00)
    7. michal_rehak says that pushing flows using the data store results in 100’s of flows/second (tbachman, 15:12:46)
    8. this shouldn’t happen, and he thinks there’s a bug here somewhere (tbachman, 15:13:02)
    9. michal_rehak says that the expensive thing is the beginning and closing of the transaction, so a difference is number of flows per transaction (tbachman, 15:13:33)
    10. abhijitkumbhare asks if there can be something wrong with the tests, as these results seem low compared to numbers reported by others (e.g. Jan) (tbachman, 15:14:44)
    11. edwarnicke says that part of it depends on what you’re doing to test stuff (tbachman, 15:15:03)
    12. For example, running against L2 Switch, and get so-and-so results — but these results may be terrible when using a tool such as CBench, b/c of the way L2 Switch is intended to be used (tbachman, 15:15:47)
    13. michal_rehak says there is a major optimization plan for statistics and writing things into the data store (tbachman, 15:18:18)
    14. michal_rehak says that there’s a bug where 1 transaction is used for 1 operation, which has poor results; one improvement is to bulk/batch the transactions, or have 1 thread writing the data store (no merging conflicts b/c only a single thread writing) (tbachman, 15:20:16)
    15. CM says that compared to the hydrogen release, the helium release seems to have hit some bottlenecks (tbachman, 15:21:32)
    16. CM says that using hydrogen, they were able to scale to about 5k or 6k flows/s using the drop test (tbachman, 15:22:00)
    17. using the drop test with Helium, that scales to a max of about 1k (tbachman, 15:22:13)
    18. edwarnicke says that there are peole measuring 50-100k flows/s on laptops (tbachman, 15:22:39)
    19. edwarnicke asks what features CM is loading (tbachman, 15:23:34)
    20. CM says that they are only loading the drop test (tbachman, 15:23:41)
    21. edwarnicke says he’d like to look at this, possibly over a webex, as this is inconsistent with what others are seeing (tbachman, 15:24:00)
    22. CM says that hey disabled a lot of logs (tbachman, 15:24:41)
    23. edwarnicke asks what kind of log messages were seen (tbachman, 15:24:50)
    24. CM says he will have to get that information (tbachman, 15:24:57)
    25. edwarnicke says that there’s a bug in the OVSDB project that’s causing log messages (tbachman, 15:25:33)
    26. ACTION: CM to send email to the list on this, and ping edwarnicke on IRC to coordinate debugging this problem (tbachman, 15:26:55)

  2. multiple nodes (tbachman, 15:27:59)
    1. edwarnicke says that after looking at the APIs, there are some changes that we might want to consider, keeping in mind that we need to support existing users (tbachman, 15:28:27)
    2. These changes relate to connection management, message ordering management, and translation (tbachman, 15:28:44)
    3. edwarnicke says it would be nice to allow people to plug in their own codecs (tbachman, 15:29:10)
    4. abhijitkumbhare asks if edwarnicke could write up something on this (tbachman, 15:30:40)
    5. edwarnicke said he’d like to discuss this here first (tbachman, 15:30:51)
    6. michal_rehak says this sounds like it might be a good idea (tbachman, 15:31:23)
    7. edwarnicke asks if CM could provide the output of feature:list -i (tbachman, 15:33:52)
    8. ACTION: Mouli to provide the ouptut of feature:list -i to edwarnicke (tbachman, 15:34:29)
    9. Have captured the potential Lithium items from the design summit here: (abhijitkumbhare, 15:34:41)
    10. https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:Potential_Lithium_Items (abhijitkumbhare, 15:34:45)
    11. edwarnicke says that the performance of the openflowplugin has improved rapidly in Helium, based on what he’s seen (tbachman, 15:35:28)
    12. Mouli asks what the enhancements were made in Helium (tbachman, 15:35:54)
    13. edwarnicke says he doesn’t have that list, but there was a huge amount of work done there (tbachman, 15:36:07)
    14. Mouli asks if there’s a wiki that may capture this (tbachman, 15:36:15)
    15. Also added the Helium backlog here: (abhijitkumbhare, 15:36:29)
    16. https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:Helium_Backlog (abhijitkumbhare, 15:36:33)
    17. Please update these links (abhijitkumbhare, 15:36:50)
    18. edwarnicke points out that openflowplugin is the “poster child” for needing more time up front, as there are many consumers/players involved (tbachman, 15:39:12)
    19. abhijitkumbhare asks if we should sort out the Lithium features here (tbachman, 15:40:25)
    20. abhijitkumbhare says one of the features that folks wanted was the ability to subscribe to a particular packet_in (tbachman, 15:42:26)
    21. abhijitkumbhare says we should look into adding that to the Lithium release (tbachman, 15:42:45)
    22. edwarnicke says we may want to look at what l2switch does, as that might be a good start (tbachman, 15:44:16)
    23. abhijitkumbhare says we could also look at what linux does with iptables (tbachman, 15:44:28)
    24. edwarnicke says there they have to still do a full decode of the packet (tbachman, 15:44:59)
    25. abhijitkumbhare says another feature is openflow 1.4 support (tbachman, 15:45:53)
    26. one particular feature that looks particularly interesting is the possibility to have bundles, where a group of openflow messages can be applied as a single operation (tbachman, 15:46:28)
    27. abhijitkumbhare asks if it’s possible to pick up features for 1.4 as extensions for 1.3 (tbachman, 15:48:33)
    28. edwarnicke asks if abhijitkumbhare can present what’s possible in 1.4 (tbachman, 15:48:43)
    29. abhijitkumbhare says yes, but not next week (tbachman, 15:48:51)
    30. edwarnicke says we need to figure out what we’re doing for High Availability — this may turn into requests to the clustering team (tbachman, 15:49:37)
    31. This includes Role Request messages (tbachman, 15:51:04)
    32. edwarnicke says there is the configuration state, which is what the state we’re trying to get to (tbachman, 15:58:26)
    33. the other is the operational state, which is whatever the switch tells us (tbachman, 15:58:36)
    34. edwarnicke says that for the “what should be the source of truth”, he feels that should be the controller (tbachman, 15:58:54)
    35. Mouli agress with edwarnicke on this point (tbachman, 15:59:03)


Meeting ended at 15:59:46 UTC (full logs).

Action items

  1. CM to send email to the list on this, and ping edwarnicke on IRC to coordinate debugging this problem
  2. Mouli to provide the ouptut of feature:list -i to edwarnicke


People present (lines said)

  1. tbachman (72)
  2. abhijitkumbhare (8)
  3. odl_meetbot (5)
  4. mawil (2)


Generated by MeetBot 0.1.4.