#opendaylight-openflowplugin: OpenFlow Plugin meeting

Meeting started by abhijitkumbhare at 15:13:54 UTC (full logs).

Meeting summary

    1. abhijitkumbhare (abhijitkumbhare, 15:14:18)
    2. michal_rehak (abhijitkumbhare, 15:14:23)
    3. vishnoianil (vishnoianil, 15:14:38)
    4. Jonathan (abhijitkumbhare, 15:15:02)
    5. v_demcak (abhijitkumbhare, 15:15:11)
    6. oflibMichal (abhijitkumbhare, 15:15:23)

  1. Signup spreadsheet (abhijitkumbhare, 15:16:05)
    1. https://docs.google.com/spreadsheets/d/1BePeDvDIEgHf7A0hP-jgEY0sRmgT4FbjtZIVqZQOXXk/edit#gid=0 (abhijitkumbhare, 15:16:13)
    2. Task Cleanup Yang models - Add more info around it (abhijitkumbhare, 15:16:47)
    3. what models need to be cleaned up (abhijitkumbhare, 15:17:10)
    4. edwarnicke had started the model cleanup (abhijitkumbhare, 15:17:24)
    5. edwarnicke had started flattening the models (abhijitkumbhare, 15:17:48)
    6. edwarnicke also mentions how to cleanup models handling backward compatibility (abhijitkumbhare, 15:18:38)
    7. ACTION: abhijitkumbhare to follow up with edwarnicke and prasanna for their inputs with Model cleanup - if they can put up wiki (abhijitkumbhare, 15:19:27)
    8. martin bobak (abhijitkumbhare, 15:19:54)
    9. https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:Lithium_Design_Proposal (oflibMichal, 15:25:17)
    10. abhijitkumbhare mentions that the highest priority tasks would be in the areas of performance, cleanup, usability, etc. (abhijitkumbhare, 15:25:46)
    11. abhijitkumbhare adds adding OpenFlow 1.4 would be a good statement at the same time (abhijitkumbhare, 15:26:20)
    12. michal_rehak is explaining Robert Varga's proposal (abhijitkumbhare, 15:28:42)
    13. Robert Varga's proposal (abhijitkumbhare, 15:31:30)
    14. https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:Lithium_Design_Proposal (abhijitkumbhare, 15:31:40)
    15. vishnoianil thinks this is a big overhaul - and lot of good suggestions - but we should really study this well and the impact (abhijitkumbhare, 15:42:59)
    16. vishnoianil thinks we should also look into HP's code to see what design ideas can be picked up - to have best of both proposals (abhijitkumbhare, 15:45:17)
    17. michal_rehak this proposal is probably larger then lithium time frame and will be divided into blocks, assigned priority, estimations.. (michal_rehak, 15:46:03)

  2. Simultaneous Release Milestones (abhijitkumbhare, 15:50:42)
    1. OpenFlow Plugin will be offset 1 (abhijitkumbhare, 15:50:58)
    2. M1 for offset 1 is Dec 18 - 2 weeks from now (abhijitkumbhare, 15:51:18)
    3. We need to have a candidate release plan by M1 (Dec 18) (abhijitkumbhare, 15:51:40)
    4. Please sign up on work items (abhijitkumbhare, 15:59:26)

  3. OpenFlow Java project plan (abhijitkumbhare, 15:59:55)
    1. openflowjava hasn't decided yet what the next steps are - currently there are discussion on model update, DTLS and OpenFlow 1.4 support (abhijitkumbhare, 16:00:01)


Meeting ended at 16:00:09 UTC (full logs).

Action items

  1. abhijitkumbhare to follow up with edwarnicke and prasanna for their inputs with Model cleanup - if they can put up wiki


Action items, by person

  1. abhijitkumbhare
    1. abhijitkumbhare to follow up with edwarnicke and prasanna for their inputs with Model cleanup - if they can put up wiki
  2. edwarnicke
    1. abhijitkumbhare to follow up with edwarnicke and prasanna for their inputs with Model cleanup - if they can put up wiki


People present (lines said)

  1. abhijitkumbhare (43)
  2. odl_meetbot (9)
  3. oflibMichal (2)
  4. michal_rehak (1)
  5. edwarnicke (1)
  6. vishnoianil (1)


Generated by MeetBot 0.1.4.