#opendaylight-openflowplugin: OpenFlow plugin weekly meeting Nov 20

Meeting started by abhijitkumbhare at 15:03:33 UTC (full logs).

Meeting summary

  1. Spreadsheet used by Ed for the controller (abhijitkumbhare, 15:05:24)
    1. https://docs.google.com/spreadsheets/d/1xXDMQRzJtsF6-KASWQ_ywBO9uwGKclavZCTPvJcidP4/edit#gid=0 (abhijitkumbhare, 15:05:29)
    2. Keith's spreadsheet for GBP - good release template (abhijitkumbhare, 15:06:46)
    3. https://docs.google.com/spreadsheets/d/15nBWBNxCy3518o3tj808HjKaz2n7qyUgxQWDUKZEmy4/edit#gid=0 (abhijitkumbhare, 15:06:51)
    4. vishnoianil (vishnoianil, 15:07:20)
    5. abhijitkumbhare (abhijitkumbhare, 15:09:30)
    6. Definition of offsets in the release plan - offset 0 - core; offset 1 - dependent on offset 0 - plus there are projects dependent on offset 1; offset 2 - leaf projects (abhijitkumbhare, 15:12:30)
    7. vishnoianil thinks OFplugin should be offset 1 (abhijitkumbhare, 15:13:09)
    8. OFPlugin welcomes Jonathan from Inocybe (abhijitkumbhare, 15:14:42)
    9. http://icodebythesea.blogspot.com/2014/11/ktop-update-and-opendaylight-mdsal.html info on the mdsal status command (edwarnicke, 15:16:42)
    10. Helium backlogs: https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:Helium_Backlog (abhijitkumbhare, 15:18:55)
    11. Potential Lithium items: https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:Potential_Lithium_Items (abhijitkumbhare, 15:19:49)

  2. Project contacts - leads (abhijitkumbhare, 15:31:46)
    1. abhijitkumbhare is the only nominee for the OpenFlow plugin project lead. We will commence vote on the OpenFlow plugin project lead (abhijitkumbhare, 15:33:22)
    2. Chris O'Shea had expressed interest in being the test contact for the OpenFlow plugin - vishnoianil, edwarnicke & abhijitkumbhare were OK with this (abhijitkumbhare, 15:33:31)
    3. https://wiki.opendaylight.org/view/Weekly_Project_Meeting_List#OpenFlow_Plugin (abhijitkumbhare, 15:36:30)
    4. lots of people new to ODL and the openflowplugin get confused about the AD-SAL/MD-SAL (tbachman, 15:37:26)
    5. rgowrishankar asks whether the AD-SAL can be deprecated (tbachman, 15:37:46)
    6. edwarnicke says this is a bigger discussion than just the openflowplugin (tbachman, 15:37:57)
    7. there would have to be a recommendation and agreement to do this, and it would have to be marked as deprecated in a release before it would be removed in a subsequent release (tbachman, 15:38:29)
    8. rgowrishankar asks if the AD-SAL compatibility is under the openflowplugin (tbachman, 15:38:59)
    9. edwarnicke says that this is actually in the controller project (tbachman, 15:39:08)
    10. rgowrishankar asks if the AD-SAL compatibility can be moved into the openflowplugin, and subsequently deprecate (tbachman, 15:39:45)
    11. edwarnicke says that in the design summit there was a discussion about the controller project being too big, tho breaking things up is a non-trivial process (tbachman, 15:40:36)
    12. edwarnicke says as a first step he’s moved all the AD-SAL bits into their own directory (tbachman, 15:40:49)
    13. edwarnicke is also pushing patches to put the AD-SAL pieces into ordered chunks (tbachman, 15:41:07)
    14. edwarnicke would (personally) like to take some of the flow models and flow-based-service things and have those moved to the openflowplugin (tbachman, 15:41:32)
    15. rgowrishankar asks what the next steps would be here (tbachman, 15:43:23)
    16. edwarnicke recommends that rgowrishankar open a discussion on controller-dev or discuss on deprecating the AD-SAL (tbachman, 15:44:15)
    17. abhijitkumbhare says +1 :) (abhijitkumbhare, 15:44:45)
    18. ACTION: rgowrishankar to start thread on controller-dev and openflowplugin-dev, cc’ing discuss, vtn, opendov, and ovsdb-dev, on deprecating the AD-SAL (tbachman, 15:46:16)
    19. rgowrishankar asks if we can deprecate the openflow AD-SAL APIs (tbachman, 15:46:57)
    20. edwarnicke says if you deprecate the AD-SAL flow APIs, you end up largely deprecating the AD-SAL, due to cross-linkage (tbachman, 15:48:14)
    21. edwarnicke as an example, the host tracker doesn’t keep it’s own data, but stores it in the topology manager (tbachman, 15:48:34)
    22. abhijitkumbhare asks if the NSFs are essentially the MD-SAL plugins (tbachman, 15:49:22)
    23. edwarnicke says the things that we’re calling NSFs are essentially MD-SAL plugins, but some we probably don’t want to be separate plugins (e.g. inventory) (tbachman, 15:49:50)
    24. There are multiple topology trees and openflow and bgp write to different topology trees. There are ways of linking nodes between the different trees to denote that nodes on the different tree correspond to the same physical box (rgowrishankar, 15:54:15)
    25. rgowrishankar asks whether the HP contributions are planned for the openflowplugin (tbachman, 15:56:40)
    26. abhijitkumbhare says he’s seen a few proposals, some at the design forum (tbachman, 15:57:05)
    27. rgowrishankar asks about their netty.io and other mechanisms (tbachman, 15:57:20)
    28. edwarnicke says we should have a discussion with them about whether they plan to contribute (tbachman, 15:57:40)
    29. Anil says that they already pushed some code (tbachman, 15:58:00)
    30. edwarnicke says that they pushed more than just their openflow plugin, so it wasn’t clear what could be done with all of that (scope) (tbachman, 15:58:25)


Meeting ended at 15:58:51 UTC (full logs).

Action items

  1. rgowrishankar to start thread on controller-dev and openflowplugin-dev, cc’ing discuss, vtn, opendov, and ovsdb-dev, on deprecating the AD-SAL


Action items, by person

  1. rgowrishankar
    1. rgowrishankar to start thread on controller-dev and openflowplugin-dev, cc’ing discuss, vtn, opendov, and ovsdb-dev, on deprecating the AD-SAL


People present (lines said)

  1. tbachman (31)
  2. abhijitkumbhare (24)
  3. odl_meetbot (4)
  4. edwarnicke (2)
  5. rgowrishankar (1)
  6. vishnoianil (1)


Generated by MeetBot 0.1.4.