#opendaylight-openflowplugin: IRC sync up

Meeting started by abhijitkumbhare at 16:19:42 UTC (full logs).

Meeting summary

    1. abhijitkumbhare asks if anyone has any thoughts on Anton’s changes (tbachman, 16:20:48)
    2. https://lists.opendaylight.org/pipermail/openflowplugin-dev/2015-May/003101.html (abhijitkumbhare, 16:20:58)
    3. https://git.opendaylight.org/gerrit/#/c/20704 The gerrit proposed in that email (tbachman, 16:21:16)
    4. kot-begemot says this is round one fo the cleanup — there needs to be many more (but it should work); all tests he’s used pass so far (tbachman, 16:22:43)
    5. abhijitkumbhare asks michal_rehak if he agrees with kot-begemot’s changes (tbachman, 16:24:35)
    6. ACTION: michal_rehak to review kot-begemot’s gerrit (tbachman, 16:25:30)

  1. Updates (abhijitkumbhare, 16:25:57)
    1. kot-begemot says he’s planning on backporting his patch to stable/helium (tbachman, 16:26:21)
    2. abhijitkumbhare asks if there are any updates (tbachman, 16:26:30)
    3. jamoluhrsen says CI is better for stable/helium codebase flow-services tests (tbachman, 16:27:05)
    4. Bugs 3261, 3262, 3264, 3265, 3266 (abhijitkumbhare, 16:28:48)
    5. abhijitkumbhare says jamoluhrsen has filed a new set of bugs (tbachman, 16:28:54)
    6. jamoluhrsen says he’s filed 6 buts. He guesses they can mostly be marked fixed now, but it woudl be good to know of some patch(es) that did the fixing (tbachman, 16:29:19)
    7. kot-begemot asks what does jenkins run by default on submission for the Lithium code base — full CI, or a subset? (tbachman, 16:30:39)
    8. jamoluhrsen says we have duplicate suites — one with odl-ofp-flow-services-ui feature, then antoerh with -li feature (tbachman, 16:31:03)
    9. https://bugs.opendaylight.org/show_bug.cgi?id=3272 (abhijitkumbhare, 16:36:26)
    10. 3051 if we stay with Li codebase still needs to be cascaded to the hashing code (kot-begemot, 16:37:17)
    11. if we go back to He it needs to be backported (kot-begemot, 16:37:35)
    12. abhijitkumbhare asks kot-begemot what should be the next steps for 3051 (tbachman, 16:39:00)
    13. tbachman asks kot-begemot if this is covered in https://git.opendaylight.org/gerrit/#/c/20704 (tbachman, 16:56:05)
    14. kot-begemot says it fixes passing of prefixes, it fixes the utility classes and merges them and it fixes the testcases (tbachman, 16:56:21)
    15. kot-begemot says it reuses the same code where possible for v4 and v6 so it does not break again (tbachman, 16:56:34)
    16. kot-begemot says this is because v4 was part-fixed at some point by someone — just that fix did not propagate to v6 (tbachman, 16:56:54)
    17. kot-begemot says he can problaby do most of the fixes for openflowplugin tomorrow, but someone needs to review the MatchConverter specifically (tbachman, 17:00:19)
    18. kot-begemot says this desperately needs a BIG round of cleanup and abstraction, but at the very least if the fixes do their job now (tbachman, 17:01:03)
    19. ACTION: michal_rehak to review MatchConverter (tbachman, 17:01:06)
    20. abhijitk_ asks if we should meet via IRC on Thursday (tbachman, 17:03:56)
    21. abhijitk_ says we’ll do an IRC meeting at 9am PDT on Thursday (tbachman, 17:04:49)


Meeting ended at 17:06:45 UTC (full logs).

Action items

  1. michal_rehak to review kot-begemot’s gerrit
  2. michal_rehak to review MatchConverter


Action items, by person

  1. kot-begemot
    1. michal_rehak to review kot-begemot’s gerrit
  2. michal_rehak
    1. michal_rehak to review kot-begemot’s gerrit
    2. michal_rehak to review MatchConverter


People present (lines said)

  1. tbachman (58)
  2. abhijitkumbhare (34)
  3. kot-begemot (27)
  4. abhijitk_ (22)
  5. jamoluhrsen (7)
  6. odl_meetbot (4)
  7. michal_rehak (2)


Generated by MeetBot 0.1.4.