#opendaylight-openflowplugin: OpenFlow plugin bug scrub

Meeting started by abhijitkumbhare at 17:16:58 UTC (full logs).

Meeting summary

  1. Bugs list (blocker, critical, major) (abhijitkumbhare, 17:17:47)
    1. https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_severity=critical&bug_severity=major&bug_status=UNCONFIRMED&bug_status=CONFIRMED&bug_status=IN_PROGRESS&bug_status=WAITING_FOR_REVIEW&list_id=39862&product=openflowplugin&query_format=advanced&resolution=--- (abhijitkumbhare, 17:18:42)
    2. https://bugs.opendaylight.org/show_bug.cgi?id=3735 “flows not removed from the switch when 80k flows configured” (abhijitkumbhare, 17:20:47)
    3. https://bugs.opendaylight.org/show_bug.cgi?id=3741 “groups and meters tests fails for Li design ofp” (abhijitkumbhare, 17:28:51)
    4. https://bugs.opendaylight.org/show_bug.cgi?id=3762 “flows statistics unstable when 80k flow configured” (abhijitkumbhare, 17:32:44)
    5. https://bugs.opendaylight.org/show_bug.cgi?id=4104 “Problems observed when connecting openflow switches to multiple instances of controller" (abhijitkumbhare, 17:41:08)
    6. 4104 assigned to Kamal (abhijitkumbhare, 17:44:28)
    7. 4104 prio lowered as the feature not ready (abhijitkumbhare, 17:44:49)
    8. https://bugs.opendaylight.org/show_bug.cgi?id=4062 “Flow Reconciliator does not account for flow-deletions when the switch connection is disrupted" (abhijitkumbhare, 17:45:21)
    9. Muthu has already picked 4062 (abhijitkumbhare, 17:46:11)
    10. https://bugs.opendaylight.org/show_bug.cgi?id=3039 “NxmNxTunIpv4Src not supported” (abhijitkumbhare, 17:46:55)
    11. lowered priority of 3039 to normal (due to only the alien issue remaining) - assigned it to Michal Rehak for his thoughts on this (abhijitkumbhare, 17:51:06)
    12. https://bugs.opendaylight.org/show_bug.cgi?id=3774 “stats for 80k fows not collected properly after mininet restart” (abhijitkumbhare, 17:51:39)
    13. Kavitha has taken 3774 - most likely she intends to do this later - will ask update on this on the bug (abhijitkumbhare, 17:53:17)
    14. https://bugs.opendaylight.org/show_bug.cgi?id=4069 “[GROUP RECONCILIATION] Group Chaining fails during reconciliation” (abhijitkumbhare, 17:54:42)
    15. Related to reconciliation - assigning it to Shuva (abhijitkumbhare, 17:55:10)
    16. https://bugs.opendaylight.org/show_bug.cgi?id=3754 “NPE at org.opendaylight.openflowplugin.openflow.md.core.ConnectionConductorImpl.updatePort(ConnectionConductorImpl.java:299)[256:org.opendaylight.openflowplugin:0.1.0.SNAPSHOT]” (abhijitkumbhare, 17:56:38)
    17. Fixed but need to check with Martin if has been pushed to stable/lithium (abhijitkumbhare, 17:58:06)
    18. https://bugs.opendaylight.org/show_bug.cgi?id=4099 “[GROUP RECONCILIATION]Groups pointing to ports donot reconcile if ports come up late” (abhijitkumbhare, 20:03:26)
    19. assigned to Shuva since this is reconciliation related (abhijitkumbhare, 20:05:26)
    20. https://bugs.opendaylight.org/show_bug.cgi?id=4111 “[FLOW RECONCILIATION]Expirable flows appear in the switch post reconnect” (abhijitkumbhare, 20:06:00)
    21. assigned to Shuva as part of reconciliation work (abhijitkumbhare, 20:07:03)
    22. https://bugs.opendaylight.org/show_bug.cgi?id=3548 “LLDP speaker does not start/stop sending LLDP packets on port up/down events" (abhijitkumbhare, 20:07:50)
    23. https://git.opendaylight.org/gerrit/#/c/23795/ (vishnoianil, 20:10:44)
    24. ACTION: LuisGomez to recheck bug 3548 (abhijitkumbhare, 20:13:21)
    25. https://bugs.opendaylight.org/show_bug.cgi?id=4064 “[GROUP-CHAINING]Deleting a child Indirect-Group from a parent All-group does not delete the parent from the config DS" (abhijitkumbhare, 20:13:57)
    26. ACTION: Muthu to check 4064 is really a bug - and whether an empty group should be a concern? (abhijitkumbhare, 20:24:39)
    27. https://bugs.opendaylight.org/show_bug.cgi?id=2985 “Detailed Documention of different ways of programming flows, meters, groups including acks/barriers, DS vs RPCs, operational vs cfg DS" (abhijitkumbhare, 20:25:30)
    28. https://bugs.opendaylight.org/show_bug.cgi?id=2664 (LuisGomez, 20:28:48)
    29. https://bugs.opendaylight.org/show_bug.cgi?id=2664 “Buckets in groups are not ordered" (abhijitkumbhare, 20:29:11)
    30. ACTION: abhijitkumbhare LuisGomez to discuss the priority “normal” in the future (abhijitkumbhare, 20:36:11)


Meeting ended at 20:36:23 UTC (full logs).

Action items

  1. LuisGomez to recheck bug 3548
  2. Muthu to check 4064 is really a bug - and whether an empty group should be a concern?
  3. abhijitkumbhare LuisGomez to discuss the priority “normal” in the future


Action items, by person

  1. abhijitkumbhare
    1. abhijitkumbhare LuisGomez to discuss the priority “normal” in the future
  2. LuisGomez
    1. LuisGomez to recheck bug 3548
    2. abhijitkumbhare LuisGomez to discuss the priority “normal” in the future


People present (lines said)

  1. abhijitkumbhare (125)
  2. LuisGomez (90)
  3. odl_meetbot (9)
  4. vishnoianil (9)


Generated by MeetBot 0.1.4.