#opendaylight-openflowplugin: OpenFlow plugin June 15 2015

Meeting started by abhijitkumbhare at 16:04:55 UTC (full logs).

Meeting summary

  1. OpenFlow bugs (abhijitkumbhare, 16:06:55)
    1. https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_severity=critical&bug_severity=major&list_id=34411&product=openflowplugin&query_format=advanced&resolution=--- (abhijitkumbhare, 16:07:00)
    2. https://bugs.opendaylight.org/show_bug.cgi?id=2657 Bug 2657 raised by GBP (tbachmann) (abhijitkumbhare, 16:12:25)
    3. vishnoianil asking whether GBP are using extensions for this bug (abhijitkumbhare, 16:15:33)
    4. ACTION: vishnoianil to request more info (regarding whether using extensions & using a different cookie as a workaround) (abhijitkumbhare, 16:17:56)
    5. https://bugs.opendaylight.org/show_bug.cgi?id=3735 Bug 3735 - flows not removed from the switch when 80k flows configured (abhijitkumbhare, 16:18:55)
    6. michal_rehak says probably clean the device of flows when switch connects (but will need to be configurable - which will need API change) (abhijitkumbhare, 16:21:05)
    7. abhijitkumbhare & LuisGomez say this is not a blocker (abhijitkumbhare, 16:22:42)
    8. Clarification: abhijitkumbhare thinks this may be too late to fix (abhijitkumbhare, 16:24:38)
    9. https://bugs.opendaylight.org/show_bug.cgi?id=1526 Bug 1526 filed by Madhu in Helium (that was not followed up by Madhu) (abhijitkumbhare, 16:26:24)
    10. ACTION: abhijitkumbhare & vishnoianil to document the workaround for bug 1526 in the release notes (abhijitkumbhare, 16:36:55)
    11. https://bugs.opendaylight.org/show_bug.cgi?id=3039 Bug 3039 (abhijitkumbhare, 16:39:26)
    12. ACTION: Jozef to check if 3039 is a blocker - and a status of this (abhijitkumbhare, 16:40:32)
    13. https://bugs.opendaylight.org/show_bug.cgi?id=3548 - - after restarting a two node linear network LLDP packet-outs are not sent for one port causing one side of the bi-directional link to not be learned (abhijitkumbhare, 16:41:19)
    14. Needs investigation (abhijitkumbhare, 16:42:49)
    15. ACTION: michal_rehak to investigate 3548 next week (abhijitkumbhare, 16:44:49)
    16. ACTION: kot-begemot will also look into 3548 after Wednesday (abhijitkumbhare, 16:48:04)
    17. https://bugs.opendaylight.org/show_bug.cgi?id=3062 - Concurrent modification exception seen when programming flows into mininet (abhijitkumbhare, 16:48:48)
    18. michal_rehak says 3062 related to dead code - no longer an issue. Should be marked as fixed (abhijitkumbhare, 16:50:08)

  2. Release review on June 23 (abhijitkumbhare, 16:51:03)
    1. https://lists.opendaylight.org/pipermail/release/2015-June/002655.html Email about what is needed for release review (abhijitkumbhare, 16:51:44)
    2. Documentation for OpenFlow plugin is largely missing (abhijitkumbhare, 16:52:49)
    3. https://git.opendaylight.org/gerrit/22416 patch restoring to Helium documentation needs to be merged (abhijitkumbhare, 16:53:16)
    4. ACTION: michal_rehak & co. to work on the user guide using wiki converted to asciidoc using tony tkacik’s technique & push it to the docs repo by June 17 (abhijitkumbhare, 17:09:26)
    5. ACTION: abhijitkumbhare to look up info on tony t’s technique & share (abhijitkumbhare, 17:10:21)
    6. ACTION: vishnoianil to send a summary of what he thinks should be added in the documentation (abhijitkumbhare, 17:16:24)
    7. We will have a meeting on Wednesday for the release review items at the same time (abhijitkumbhare, 17:16:39)


Meeting ended at 17:16:54 UTC (full logs).

Action items

  1. vishnoianil to request more info (regarding whether using extensions & using a different cookie as a workaround)
  2. abhijitkumbhare & vishnoianil to document the workaround for bug 1526 in the release notes
  3. Jozef to check if 3039 is a blocker - and a status of this
  4. michal_rehak to investigate 3548 next week
  5. kot-begemot will also look into 3548 after Wednesday
  6. michal_rehak & co. to work on the user guide using wiki converted to asciidoc using tony tkacik’s technique & push it to the docs repo by June 17
  7. abhijitkumbhare to look up info on tony t’s technique & share
  8. vishnoianil to send a summary of what he thinks should be added in the documentation


Action items, by person

  1. abhijitkumbhare
    1. abhijitkumbhare & vishnoianil to document the workaround for bug 1526 in the release notes
    2. abhijitkumbhare to look up info on tony t’s technique & share
  2. UNASSIGNED
    1. vishnoianil to request more info (regarding whether using extensions & using a different cookie as a workaround)
    2. Jozef to check if 3039 is a blocker - and a status of this
    3. michal_rehak to investigate 3548 next week
    4. kot-begemot will also look into 3548 after Wednesday
    5. michal_rehak & co. to work on the user guide using wiki converted to asciidoc using tony tkacik’s technique & push it to the docs repo by June 17
    6. vishnoianil to send a summary of what he thinks should be added in the documentation


People present (lines said)

  1. abhijitkumbhare (41)
  2. odl_meetbot (8)


Generated by MeetBot 0.1.4.