#opendaylight-openflowplugin: OpenFlow Plugin meeting June 1

Meeting started by abhijitkumbhare at 16:01:47 UTC (full logs).

Meeting summary

    1. Topics to be discussed: (abhijitkumbhare, 16:02:36)
    2. 1) Bug 3350 (OVS 2.0, etc.) (abhijitkumbhare, 16:03:10)
    3. 2) Documentation - useability (abhijitkumbhare, 16:03:30)
    4. 3) Default OpenFlow plugin (integration repo) (abhijitkumbhare, 16:04:11)
    5. 4) Blocking bugs (abhijitkumbhare, 16:04:28)
    6. 5) Third party plugins we are using extremely old (topic for Beryllium) (abhijitkumbhare, 16:05:49)
    7. odlcasey says the 3rd party plugins do not have sources - we need to update to latest stable versions for security/stability (abhijitkumbhare, 16:09:11)
    8. zxiiro will likely reach out to projects (we need to find this out) (abhijitkumbhare, 16:11:42)

  1. Bug 3350 (OVS 2.0, meters/groups, etc.) (abhijitkumbhare, 16:12:14)
    1. Discussion whether 3350 is a blocker bug (abhijitkumbhare, 16:14:13)
    2. Plan is to make these features (groups, meters, etc.) optional (abhijitkumbhare, 16:15:58)
    3. 3350 will be fixed by June 3 (abhijitkumbhare, 16:16:18)
    4. kot-begemot asks whether making the features optional will add the possibility to override features (abhijitkumbhare, 16:18:30)
    5. martin says override will not be provided at the moment (abhijitkumbhare, 16:19:15)

  2. Documentation (abhijitkumbhare, 16:19:51)
    1. Developers are currently busy on blocking issues - we need to figure out exactly when we can start documentation (most likely documentation) (abhijitkumbhare, 16:21:54)
    2. vishnoianil says we need to have at least documentation on what the users need to do (to use old or new plugin) (abhijitkumbhare, 16:22:37)
    3. vishnoianil says not much has changed user facing - so the old docs will still apply - some of the gaps can be addressed (abhijitkumbhare, 16:26:20)
    4. ACTION: vishnoianil will start on some of the gaps in docs (abhijitkumbhare, 16:27:03)

  3. Default OpenFlow plugin (abhijitkumbhare, 16:27:21)
    1. No default as such (abhijitkumbhare, 16:28:14)
    2. Dependent projects using the old flow services (Helium design) (abhijitkumbhare, 16:28:43)
    3. vishnoianil (vishnoianil, 16:31:14)
    4. from openflowplugin project perspective there is no default setting as such for features (vishnoianil, 16:32:15)
    5. it's all dependent on the projects who want to consume it, they can use either of the implementation (vishnoianil, 16:32:38)
    6. given that we are at the end of the release process, i am not sure project will be ready for doing that exercise (abhijitkumbhare, 16:34:45)
    7. but i believe it's individual projects decision on which version they want to use (abhijitkumbhare, 16:34:52)

  4. Blocking bugs (abhijitkumbhare, 16:35:07)
    1. Bug https://bugs.opendaylight.org/show_bug.cgi?id=2862 (abhijitkumbhare, 16:35:16)
    2. Bug 2862 is a regression (abhijitkumbhare, 16:35:26)
    3. LuisGomez says in Helium the flow ID in config and operational used to match - and was very convenient for the user (abhijitkumbhare, 16:39:24)
    4. In Lithium the flow ID is always shown as an alien flow (abhijitkumbhare, 16:40:03)
    5. vishnoianil says without the flow IDs matching - without the flow IDs matching - this will break applications & having the flow in operational will be useless (abhijitkumbhare, 16:41:19)
    6. vishnoianil & Martin say this should not have changed in the old design - so the applications need to be tested (abhijitkumbhare, 16:44:12)
    7. LuisGomez & vishnoianil think this is a blocker (abhijitkumbhare, 16:45:19)
    8. ACTION: vishnoianil to look into this bug 2862 (abhijitkumbhare, 16:49:26)
    9. ACTION: Jozef to continue looking into the bug 2862 for the new design (abhijitkumbhare, 16:49:33)
    10. ACTION: Martin will check if there is a clear instruction on the wiki on how to use the Lithium Karaf featureset and Helium featureset - and add it if not present (abhijitkumbhare, 17:03:11)


Meeting ended at 17:03:18 UTC (full logs).

Action items

  1. vishnoianil will start on some of the gaps in docs
  2. vishnoianil to look into this bug 2862
  3. Jozef to continue looking into the bug 2862 for the new design
  4. Martin will check if there is a clear instruction on the wiki on how to use the Lithium Karaf featureset and Helium featureset - and add it if not present


Action items, by person

  1. vishnoianil
    1. vishnoianil will start on some of the gaps in docs
    2. vishnoianil to look into this bug 2862
  2. UNASSIGNED
    1. Jozef to continue looking into the bug 2862 for the new design
    2. Martin will check if there is a clear instruction on the wiki on how to use the Lithium Karaf featureset and Helium featureset - and add it if not present


People present (lines said)

  1. abhijitkumbhare (57)
  2. odl_meetbot (14)
  3. vishnoianil (6)
  4. jamoluhrsen (1)


Generated by MeetBot 0.1.4.