#opendaylight-openflowplugin: OpenFlow plugin meeting May 11

Meeting started by abhijitkumbhare at 16:29:51 UTC (full logs).

Meeting summary

  1. Bug 2429 (abhijitkumbhare, 16:30:11)
    1. https://git.opendaylight.org/gerrit/#/c/13739/2 (vishnoianil, 16:30:26)
    2. https://git.opendaylight.org/gerrit/#/c/14809/1 (vishnoianil, 16:30:39)
    3. There was an old bug 2394 - for this issue (abhijitkumbhare, 16:30:46)
    4. Fix was https://git.opendaylight.org/gerrit/#/c/13739/2 & https://git.opendaylight.org/gerrit/#/c/14809/1 (stable/helium & master) (abhijitkumbhare, 16:31:34)
    5. Need to check if 2429 is fixed in stable/helium and only occurs in master (abhijitkumbhare, 16:32:20)
    6. ACTION: jamoluhrsen Need to check if 2429 is fixed in stable/helium and only occurs in master (abhijitkumbhare, 16:32:39)

  2. Creating stable/lithium branch (abhijitkumbhare, 16:35:33)
    1. Needs cherry-pick to both master & stable/lithium & need to keep in sync (abhijitkumbhare, 16:36:39)
    2. First submit patches to stable/lithium and then cherry pick to master (abhijitkumbhare, 16:39:27)
    3. ACTION: All-developers First submit patches to stable/lithium and then cherry pick to master (abhijitkumbhare, 16:40:00)
    4. ACTION: michal_rehak to cut the stable/lithium branch (abhijitkumbhare, 16:41:09)

  3. Lithium redesign (abhijitkumbhare, 16:41:45)
    1. LuisGomez says that the redesign looks better now - tests are passing better (abhijitkumbhare, 16:42:21)
    2. Anton says there is a performance drop recently (abhijitkumbhare, 16:42:54)
    3. michal_rehak says that he will make a decision by end of the week whether we need to go back to the old plugin design in case the performance is not better (abhijitkumbhare, 16:52:47)
    4. scale test link: https://jenkins.opendaylight.org/releng/view/openflowplugin/job/openflowplugin-csit-periodic-1node-cds-scalability-daily-only-master/ (abhijitkumbhare, 16:53:17)
    5. Most redesign developers will be busy this week in making the determination if we need to go back to the old design - hence we are skipping any additional bug scrubs this week (abhijitkumbhare, 17:06:19)

  4. Documentation (abhijitkumbhare, 17:08:21)
    1. Documentation will be started next week (after this week's determination effort on redesign code vs old design) (abhijitkumbhare, 17:09:07)


Meeting ended at 17:09:15 UTC (full logs).

Action items

  1. jamoluhrsen Need to check if 2429 is fixed in stable/helium and only occurs in master
  2. All-developers First submit patches to stable/lithium and then cherry pick to master
  3. michal_rehak to cut the stable/lithium branch


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen Need to check if 2429 is fixed in stable/helium and only occurs in master
  2. UNASSIGNED
    1. All-developers First submit patches to stable/lithium and then cherry pick to master
    2. michal_rehak to cut the stable/lithium branch


People present (lines said)

  1. abhijitkumbhare (29)
  2. colindixon (6)
  3. odl_meetbot (4)
  4. jamoluhrsen (2)
  5. vishnoianil (2)


Generated by MeetBot 0.1.4.