#opendaylight-openflowplugin: OpenFlow Plugin Meeting Nov 16

Meeting started by abhijitkumbhare at 17:02:47 UTC (full logs).

Meeting summary

  1. Agenda for the meeting (abhijitkumbhare, 17:03:57)
    1. Graduation Review (abhijitkumbhare, 17:04:07)
    2. API changes (abhijitkumbhare, 17:04:30)
    3. OpenFlow Cluster Test (abhijitkumbhare, 17:05:59)
    4. General Issues (abhijitkumbhare, 17:07:08)

  2. Graduation Review (abhijitkumbhare, 17:07:20)
    1. Template for Graduation review (abhijitkumbhare, 17:07:58)
    2. https://wiki.opendaylight.org/view/Graduation_Reviews/Template (abhijitkumbhare, 17:08:02)
    3. what is still missing for OFP: (michal_rehak, 17:11:48)
    4. Active Community: Prospective new developers can learn how to get involved here... (michal_rehak, 17:12:20)
    5. Committers vote on seeking graduation (michal_rehak, 17:12:35)
    6. ACTION: Abhijit will send out formal vote (michal_rehak, 17:13:53)
    7. AGREED: Meeting participants feel OpenFlow plugin should seek graduation review (abhijitkumbhare, 17:14:16)

  3. API changes and the API freeze (abhijitkumbhare, 17:14:41)
    1. michal_rehak notes there are several API change related gerrits that need to merge (abhijitkumbhare, 17:15:05)
    2. https://git.opendaylight.org/gerrit/#/q/status:open++project:openflowplugin+branch:master (michal_rehak, 17:15:33)
    3. https://git.opendaylight.org/gerrit/#/q/status:open+project:openflowplugin+branch:master+topic:experimenterMsg - Experimenter Message (abhijitkumbhare, 17:16:17)
    4. OK to merge pending code review (abhijitkumbhare, 17:18:13)
    5. https://git.opendaylight.org/gerrit/28267 OpenflowProgrammer: a common middle layer for openflow programming (abhijitkumbhare, 17:18:50)
    6. ACTION: abhijitkumbhare to follow up with Yi Yang whether OpenFlowProgrammer is ready for merge (abhijitkumbhare, 17:20:46)
    7. https://git.opendaylight.org/gerrit/29357 Make the statistics polling interval configurable Merge Conflict Renato Aguiar (abhijitkumbhare, 17:21:34)
    8. OK to merge pending code review / build fixing (abhijitkumbhare, 17:22:09)
    9. https://git.opendaylight.org/gerrit/27382 BUG-4062: Flows,Groups,Meters not getting deleted during switch flap Muthukumaran Kothandaraman (abhijitkumbhare, 17:22:29)
    10. This code not affecting if switch connected (in that case flows/groups deleted as before) - this affects only when switch not connected (abhijitkumbhare, 17:27:54)
    11. ACTION: vishnoianil will review this patch (abhijitkumbhare, 17:28:58)
    12. OK to merge pending code review (abhijitkumbhare, 17:29:17)
    13. Behavior not changing - just reconciliation made robust (abhijitkumbhare, 17:29:49)
    14. Knob to turn on this behavior - default old behavior (turned off) (abhijitkumbhare, 17:31:27)
    15. Additional change for port reconciliation - bug 4099 - being reviewed internally by Muthu / Shuva and will be shared for review by others Nov 17 (abhijitkumbhare, 17:34:00)
    16. https://git.opendaylight.org/gerrit/29484 BUG-2188: To populate the port_number of switches - yang model (abhijitkumbhare, 17:34:19)
    17. No functional change - corresponding code needs to be added but michal_rehak wants the API to be present (abhijitkumbhare, 17:36:14)
    18. https://git.opendaylight.org/gerrit/#/c/28563/ Add PipelineManager application Renato Aguiar (abhijitkumbhare, 17:36:48)
    19. ACTION: abhijitkumbhare vishnoianil michal_rehak to check how Yi Yang’s patch overlap and how to merge these together (abhijitkumbhare, 17:38:57)
    20. https://git.opendaylight.org/gerrit/29266 Support for statistics collection per flow Merge Conflict Renato Aguiar (abhijitkumbhare, 17:39:27)
    21. OK to merge pending code review & merge fixing (abhijitkumbhare, 17:40:02)

  4. OpenFlow Cluster Test (abhijitkumbhare, 17:40:30)
    1. Not specifically testing OF HA, but also devices that don’t support HA? (abhijitkumbhare, 17:41:35)
    2. LuisGomez says simple test plan - 3 node cluster test (abhijitkumbhare, 17:42:04)
    3. LuisGomez suite for this not yet merged (abhijitkumbhare, 17:42:30)
    4. However a few basic things not working - need investigation (abhijitkumbhare, 17:43:27)
    5. kamal will investigate RPCs (abhijitkumbhare, 17:44:29)
    6. Cluster test meeting on Wednesdays - LuisGomez has sent the info to the OpenFlow plugin mailing list (abhijitkumbhare, 17:47:10)
    7. there are al least 3-4 bugs visible in the current basic OF cluster test (LuisGomez, 18:16:21)
    8. ACTION: LuisGomez Kamal to respond to the meeting minutes email with the summary of the cluster test discussion - and folks can reply to that (abhijitkumbhare, 18:16:25)
    9. I will send detailed mail after MoM (LuisGomez, 18:16:47)


Meeting ended at 18:18:07 UTC (full logs).

Action items

  1. Abhijit will send out formal vote
  2. abhijitkumbhare to follow up with Yi Yang whether OpenFlowProgrammer is ready for merge
  3. vishnoianil will review this patch
  4. abhijitkumbhare vishnoianil michal_rehak to check how Yi Yang’s patch overlap and how to merge these together
  5. LuisGomez Kamal to respond to the meeting minutes email with the summary of the cluster test discussion - and folks can reply to that


Action items, by person

  1. abhijitkumbhare
    1. abhijitkumbhare to follow up with Yi Yang whether OpenFlowProgrammer is ready for merge
    2. abhijitkumbhare vishnoianil michal_rehak to check how Yi Yang’s patch overlap and how to merge these together
  2. LuisGomez
    1. LuisGomez Kamal to respond to the meeting minutes email with the summary of the cluster test discussion - and folks can reply to that
  3. michal_rehak
    1. abhijitkumbhare vishnoianil michal_rehak to check how Yi Yang’s patch overlap and how to merge these together
  4. UNASSIGNED
    1. Abhijit will send out formal vote
    2. vishnoianil will review this patch


People present (lines said)

  1. abhijitkumbhare (56)
  2. odl_meetbot (8)
  3. michal_rehak (6)
  4. LuisGomez (2)


Generated by MeetBot 0.1.4.