#opendaylight-openflowplugin: OpenFlow Plugin Meeting Sept 28

Meeting started by abhijitkumbhare at 16:06:03 UTC (full logs).

Meeting summary

  1. Agenda (abhijitkumbhare, 16:06:54)
    1. M3 Deliverables (abhijitkumbhare, 16:07:08)
    2. OpenFlow Bug Scrub (abhijitkumbhare, 16:07:21)
    3. M3 Deliverables/Reporting (abhijitkumbhare, 16:07:58)

  2. M3 Deliverables/Reporting (abhijitkumbhare, 16:09:07)
    1. “Functionality Freeze: Final list of externally consumable APIs defined and documented” (abhijitkumbhare, 16:10:15)
    2. Need to check on the two OpenFlow 1.4 features (abhijitkumbhare, 16:11:49)
    3. ACTION: abhijitkumbhare check with Shreshtha, etc. about the 2 OpenFlow 1.4 feature external API (abhijitkumbhare, 16:12:44)
    4. Using swagger tool the API can be documented from the yang models (abhijitkumbhare, 16:15:55)
    5. ACTION: kamalr will find about this model (abhijitkumbhare, 16:18:20)
    6. ACTION: Everybody - make sure that yang models are done by Thursday Oct 1 (abhijitkumbhare, 16:19:09)
    7. Deliverable: “Karaf Features defined” (abhijitkumbhare, 16:20:03)
    8. ACTION: abhijitkumbhare find out if OpenFlow 1.4 results in new karaf features from Shreshtha/Vivek (abhijitkumbhare, 16:20:56)
    9. Deliverable: “Documentation Started” (will answer yes for this in the reported - but docs really need to be improved) (abhijitkumbhare, 16:22:17)
    10. Deliverable: “Integration & System Test: Simple system test on a karaf distribution with the project's recommended features installed” - YES (abhijitkumbhare, 16:23:06)
    11. Deliverable: “OpenFlow clustering for Lithium Design: OF clustering based on Lithium design” (abhijitkumbhare, 16:23:46)
    12. Done most of it - except for disabling LLDP on the slaves. Also testing required for slave to master role transition (abhijitkumbhare, 16:26:17)
    13. https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-08-27-17.00.html (LuisGomez, 16:32:54)
    14. this link is from tsc call where Li SR dates were decided (LuisGomez, 16:33:15)
    15. Lithium SR2: Lithium design clustering should be ready for Oct 8 release (abhijitkumbhare, 16:33:29)
    16. Deliverable: “Lithium Design - Disable stats polling” (abhijitkumbhare, 16:33:56)
    17. michal_rehak says this is done (abhijitkumbhare, 16:34:58)
    18. Deliverable: “Java API with OF version abstraction” (abhijitkumbhare, 16:35:30)
    19. API already supports OF version abstraction - so task not needed (abhijitkumbhare, 16:36:21)
    20. Deliverable: “OpenFlow 1.4: Flow Entry Eviction” (abhijitkumbhare, 16:37:05)
    21. ACTION: abhijitkumbhare follow up with Shreshta/Gaurav about the status of “OpenFlow 1.4: Flow Entry Eviction" (abhijitkumbhare, 16:37:56)

  3. OpenFlow Plugin Bug Scrub (abhijitkumbhare, 16:43:56)
    1. abhijitkumbhare & LuisGomez had a bug scrub - and assigned a few bugs (abhijitkumbhare, 16:44:25)

  4. Table Features (abhijitkumbhare, 16:47:36)
    1. Anandhi had asked question regarding the support of Table Features (abhijitkumbhare, 16:48:43)
    2. michal_rehak responded this support is available only on the Lithium code base (abhijitkumbhare, 16:49:05)


Meeting ended at 16:52:07 UTC (full logs).

Action items

  1. abhijitkumbhare check with Shreshtha, etc. about the 2 OpenFlow 1.4 feature external API
  2. kamalr will find about this model
  3. Everybody - make sure that yang models are done by Thursday Oct 1
  4. abhijitkumbhare find out if OpenFlow 1.4 results in new karaf features from Shreshtha/Vivek
  5. abhijitkumbhare follow up with Shreshta/Gaurav about the status of “OpenFlow 1.4: Flow Entry Eviction"


Action items, by person

  1. abhijitkumbhare
    1. abhijitkumbhare check with Shreshtha, etc. about the 2 OpenFlow 1.4 feature external API
    2. abhijitkumbhare find out if OpenFlow 1.4 results in new karaf features from Shreshtha/Vivek
    3. abhijitkumbhare follow up with Shreshta/Gaurav about the status of “OpenFlow 1.4: Flow Entry Eviction"
  2. UNASSIGNED
    1. kamalr will find about this model
    2. Everybody - make sure that yang models are done by Thursday Oct 1


People present (lines said)

  1. abhijitkumbhare (32)
  2. odl_meetbot (4)
  3. LuisGomez (2)
  4. michal_rehak (0)
  5. Hari_ (0)
  6. vishnoianil (0)


Generated by MeetBot 0.1.4.