#opendaylight-openflowplugin: OpenFlow Plugin Oct 19

Meeting started by abhijitkumbhare at 16:10:43 UTC (full logs).

Meeting summary

    1. vishnoianil (vishnoianil__, 16:12:11)

  1. Agenda (abhijitkumbhare, 16:12:46)
    1. M4 deliverables (abhijitkumbhare, 16:13:00)
    2. Technical issues (abhijitkumbhare, 16:13:14)
    3. Status of the Lithium design - clustering - as well aswhere it stands with respect to the comparison we had https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:He_vs_Li_comparison (abhijitkumbhare, 16:13:31)
    4. OpenFlow plugin committers (abhijitkumbhare, 16:14:03)

  2. M4 deliverables (abhijitkumbhare, 16:17:11)
    1. OpenFlow clustering design for the existing design - in progress (abhijitkumbhare, 16:21:57)
    2. Vacancy events - Gaurav Pandey to demo the partial 1.4 related features next meeting (abhijitkumbhare, 16:23:13)
    3. Flow, group, meter ordering - Muthu says group ordering pushed in (abhijitkumbhare, 16:24:06)
    4. Muthu mentions port ordering code complete - being tested (abhijitkumbhare, 16:25:03)
    5. Muthu mention reconciliation framework - work in progress, modeling completed (abhijitkumbhare, 16:25:49)
    6. "Add support to HPE's OpenFlow matching extensions" - renato_aguiar will start on this next week (abhijitkumbhare, 16:27:45)
    7. renato_aguiar working on stats optimizations at the moment and there is a chance that this (HPE OpenFlow extensions) may be pushed (abhijitkumbhare, 16:28:58)
    8. renato_aguiar pushing some patches - one related to table features, another a request from NIC (abhijitkumbhare, 16:30:24)

  3. New stuff needed by other projects (abhijitkumbhare, 16:36:38)
    1. michal_rehak to work on multipart experimenter messages since he has now some cycles on this - this will help the circuit switch project (Aneesha) (abhijitkumbhare, 16:37:44)
    2. vishnoianil__ says OVSDB Net Virt also needs an extension (port range - bug 4411) (abhijitkumbhare, 16:38:26)
    3. enhancement bug https://bugs.opendaylight.org/show_bug.cgi?id=4411 (vishnoianil__, 16:38:28)
    4. vishnoianil__ will work on this unless someone picks this up (abhijitkumbhare, 16:38:53)

  4. Status of the Lithium design (abhijitkumbhare, 16:39:34)
    1. abhijitkumbhare asks michal_rehak about where are we with this? (abhijitkumbhare, 16:40:48)
    2. Currently not many downstream projects using this - we need to educate the community on how to migrate as well as have clear instructions (abhijitkumbhare, 16:45:37)
    3. Need to find out how the downstream projects are using the OpenFlow plugin, which design they are using (abhijitkumbhare, 16:46:20)
    4. We need to study this more (abhijitkumbhare, 16:47:52)
    5. renato_aguiar what are the things only supported in the existing design (abhijitkumbhare, 16:49:27)
    6. michal_rehak says notifications are not supported (abhijitkumbhare, 16:50:57)
    7. vishnoianil__ mentions applications need to use data change notifications and need to change in order to use the Lithium design (abhijitkumbhare, 16:51:13)
    8. Few projects which may have used Lithium design - GBP (there have been some bugs filed), L2 switch, NIC & DIDM (abhijitkumbhare, 16:56:11)
    9. Muthu mentions he prefers the datastore notifications (of the Lithium design) rather than the yang notifications - as he finds them more reliable (abhijitkumbhare, 17:02:24)
    10. ACTION: abhijitkumbhare to reach out to individual project members to discuss Lithium design in more detail (abhijitkumbhare, 17:03:46)


Meeting ended at 17:04:13 UTC (full logs).

Action items

  1. abhijitkumbhare to reach out to individual project members to discuss Lithium design in more detail


Action items, by person

  1. abhijitkumbhare
    1. abhijitkumbhare to reach out to individual project members to discuss Lithium design in more detail


People present (lines said)

  1. abhijitkumbhare (35)
  2. odl_meetbot (5)
  3. vishnoianil__ (3)
  4. michal_rehak (1)
  5. renato_aguiar (0)


Generated by MeetBot 0.1.4.